Reply

R7000 management web site: Router LAN IP address v. routerlogin.*

antinode
Guru

R7000 management web site: Router LAN IP address v. routerlogin.*

   I recently observed some interesting behavior on a freshly reset
R7000 ("V1.0.9.88_10.2.88", or, I believe, "V1.0.9.42_10.2.44"; others
not tested).

 

   I dimly recall seeing some reports of behavior like that described
below.  I don't recall seeing (or providing) any satisfactory
explanation or remedy.  I ran into it today, did a little exploration,
and may have learned something.

 

   I was trying to load some firmware onto a freshly reset R7000.  I
connected one of its LAN Ethernet ports to the (normally unused) second
Ethernet interface ("Ethernet 2") on a Mac Pro (where the firmware image
file was stored).

 

   The primary Ethernet interface on the Mac Pro ("Ethernet 1") has a
"10.0.0.X" address, so the R7000 used its default LAN subnet,
"192.168.1.*", with the R7000 LAN at "192.168.1.1", and the Mac
("Ethernet 2", DHCP) at "192.168.1.2".  No problem so far.

Pointing a Safari browser at "http://192.168.1.1" worked as expected:


      Enable router to automatically update to future firmware. This
      keeps your router up to date with the latest features and security
      fixes.

 

      Select one of the following options:

 

      ( ) I Agree        ( ) I Disagree

 

      Enable collection of router analytics data that will help NETGEAR
      improve our services and products.

 

      Select one of the following options:

 

      ( ) I Agree ( )        I Disagree

 

      Please make your selection for both features above to continue.
                                                      [ Apply ]


   I selected "Disagree" for both, and then the "Apply" control led
(after what looked like a tachistoscopic redirection) to the infamous
"worst error message in the world" page:

 

      https://www.netgear.com/home/products/networking/routerlogincom.html

 

      You may not be connected to your Router's WiFi network. To access
      routerlogin.com, your device must be connected to your Router's
      WiFi network. Check your current connection and try again.

 

      [... more drivel ...]

 

   Being too lazy to investigate, I speculated.  My guess is that the
over-clever router firmware attempts to "improve" appearances by
replacing the unsightly (but functional) router LAN IP address in the
victim-specified URL with the prettier "routerlogin.com" or
"routerlogin.net" (both of which, these days, tend to lead to the same
lame page, which mentions only "routerlogin.com").


   If the network environment includes only a single computer connected
to only the target router, and that computer is configured to use DHCP
(hence the target router) for DNS, then such a substitution might be
harmless.  However, in a more complex environment, where the client
computer is able to reach a real-world DNS server by other means (such
as, in my case, "Ethernet 1", with an Internet connection through a
functioning router) the victim is trapped by an apparently bullet-proof
redirection to the infamous "worst error message in the world" page.

 

   Some simple extensions to the URL all failed the same way.  For
example:

 

      http://192.168.1.1/
      http://192.168.1.1/setup.htm
      http://192.168.1.1/start.htm


   If one falls into this trap, one remedy seems to be to not to use a
conveniently complex network environment to perform what should be a
simple task, because the folks who wrote the router firmware seem to
have anticipated no environment more complicated than the one shown in
the pictures in the router User Manual, and decided to "help" the victim
by fiddling around with a perfectly satisfactory (and functional) URL.
The result being, of course, yet more unnecessary exposure for what may
be the "worst error message in the world" page.  Thanks for the "help".

 

   I know not how many other ways there might be to get trapped by this
sort of punji firmware "enhancement", nor to which other models the joy
might have been spread.

Model: R7000|AC1900 Smart WIFI Router
Message 1 of 1
Top Contributors
Discussion stats
  • 0 replies
  • 117 views
  • 0 kudos
  • 1 in conversation
Announcements