Discussion stats
  • 12 replies
  • 707 views
  • 0 kudos
  • 2 in conversation
Announcements

Top Contributors
Reply
Highlighted
Aspirant

R7000 not portforwarding

Dear,

I want to host my own minecraft server just for my friends, i am new in the portforwarding scene and do not know much about this. So i followed a youtube tutorial of how to portforward for netgear routers. 
First i went to CMD: Ipconfig were i found my IPv4 adress to use for portforwarding:

 

After this, i went to the router login and went to advanced tab, advanced settings and then port forward/activate port. 
I created a new service page. 

This was all i had to do in this tutorial that i have seen on youtube. After i did this, i went to the website: Whatismyipadress.com to see what the IP adres is for my friends to join to me. I runned the server and gave the IP and port to my friends. They were not able to join. I checked on a website if my port is open. It was closed. I have searched allot on google what i was able to do without succes.
I also added a rule in my virusscanner to add the port: 25565 and added java.exe as a rule. Without succes either. Someone know what i can do to solve this issue?

 

I added 2 photo's so you can see what i did. Thx!

thx for your patient!

Model: XR700|Nighthawk Pro Gaming Router
Message 1 of 13

Accepted Solutions
Highlighted
Sensei

Re: R7000 not portforwarding

> [...] But if i want to set the modem to bridge mode, my netgear router
> is not working. [...]

 

   There are many kinds of "not working".  "not working" is not a useful
problem description.  It does not say what you did.  It does not say
what happened when you did it.  As usual, showing actual actions
(commands) with their actual results (error messages, LED indicators,
...) can be more helpful than vague descriptions or interpretations.

 

   I know nothing about how your EPC3940L was configured when it was a
modem+router.  You might need to do things to the R7000 to make it work
with your ISP when it's your main/only router.

 

   Did you try a settings reset on the R7000 after you changed the
EPC3940L to modem-only mode?

 

> [...] See picture 2. (Router IP:192.168.1.1) because the C (In
> A.B.C.D) is a 1, i cannot reserve a adress for my port. [...]


   Regarding "cannot", see "not a useful problem description [...]",
above.

 

   LAN addresses like "192.168.1.1" (for the R7000) and "192.168.1.2"
(for your computer) seem normal to me.  You should still have a reserved
address for your server system.

 

> [...] Also with that C in my ipv4 adress i cannot port forward via my
> modem because its a closed IPv4?

 

   Why not?  Regarding "cannot", again, see "not a useful problem
description [...]", above.

 

> [...] call my ISP tomorrow [...]

 

   They may be able to tell you if you need to specify any special
settings on your (R7000) router when you're not using the router in the
EPC3940L.

View solution in original post

Message 12 of 13

All Replies
Highlighted
Sensei

Re: R7000 not portforwarding

> R7000 [...]

 

   Firmware version?  Connected to what?

 

> [...] So i followed a youtube tutorial [...]

 

   That's very odd. I once viewed a YouTube tutorial, and it had
nothing to do with port forwarding on Netgear routers.  Is it possible,
do you suppose, that there might be more than one tutorial on YouTube?

 

> First i went to CMD: Ipconfig were i found my IPv4 adress to use for
> portforwarding:

 

   Not a very good beginning.  What happens to your port-forwarding rule
next week, when your Windows system gets a different IP address?

 

> [...] i am new in the portforwarding scene and do not know much about
> this. [...]


   You've persuaded me.

 

   Visit http://netgear.com/support , put in your model number, and look
for Documentation.  Get the User Manual.  Read.  Look for "Manage Port
Forwarding and Port Triggering" and "Manage Port Forwarding to a Local
Server".  Pay particular attention to:

 

      3. Assign the server computer a reserved IP address.

 

> I created a new service page.

 

   I can't see what you put there, but let's pretend that you did
everything right there.

 

> [...] to see what the IP adres is [...]

 

   And that address was, ...?  (The top half, "a.b" out of "a.b.c.d",
would satisfy my curiosity.)


   Does that address match the address of the router's WAN/Internet
interface?  (ADVANCED > ADVANCED Home : Internet Port : Internet IP
Address)  If not, then what's the routers WAN/Internet address?

 

   Can you access the server from a system on your LAN using the
server's LAN IP address?  If you can't access the server locally, then
there may be little chance of doing it from the outside world.

 

   If that works, then, still from a system on your LAN, try using the
router's WAN/Internet IP address.  That should verify the
port-forwarding rule(s) (and the "NAT loopback" feature of the router).


   One possibility is becoming a more frequent problem as more ISPs
adopt carrier-grade NAT to conserve IPv4 addresses:

 

      https://en.wikipedia.org/wiki/Carrier-grade_NAT

 

But any other NAT router between your R7000 and your ISP would cause the
same problem.

Message 2 of 13
Highlighted
Aspirant

Re: R7000 not portforwarding

Good day, Thanks that you want to help me!
I followed some of your steps

 

My firmware version for now is V1.0.9.88_10.2.88. I have seen that there is a new firmware version and i want to update the router today.

My PC is directly connected with ethernet cable to the router. 

 

[...] So i followed a youtube tutorial [...]

I will send you the link of the video, it is 6 minutes. I followed it, in this video they also assign the server a reserved IP address.



 [...] I can't see what you put there [...]
i will send a file with this message(picture 1) of how i filled the service tab in. (25565 is the port for minecraft)

 [...] And that address was [...]

It is: 90.145.x.x. This is not the same Ip-adres that is written in the advanced home tab. This is 192.168.x.x

[... ]Can you access the server from a system on your LAN using the
server's LAN IP address? [...] 
Yes, i can acces the server from an other system on my lan using the server's LAN IP adress.

Picture 1 is the picture how i filled in the advanced service tab.
Pitcute 2 is a picture of my ipconfig.

 

I hope you can still help me! Thx

Message 3 of 13
Highlighted
Sensei

Re: R7000 not portforwarding

> It is: 90.145.x.x. This is not the same Ip-adres that is written in the
> advanced home tab. This is 192.168.x.x

 

   There are two IP addressses "in the advanced home tab".  Under
"Router Information" is the "LAN Port" address.  (There's no need to
hide that one.)  Under "Internet Port" is the WAN/"Internet IP Address",
which is the important one.  If the _WAN/Internet_ IP Address is
"192.168.x.y", then that would be the the problem.

 

>       https://en.wikipedia.org/wiki/Carrier-grade_NAT

 

   Ask your ISP?

 

> I hope you can still help me! Thx

 

   The only solutions I know are: 1) to ask your ISP for a real public
address (for which they might charge more), or 2) to use a tunneling
service like the one mentioned in another thread (near the end):

 

      https://community.netgear.com/t5/x/x/m-p/1748431

 

Some ISPs do not permit servers for residential customers, but I'm
confident that they'll tell you that if you ask.

Message 4 of 13
Highlighted
Aspirant

Re: R7000 not portforwarding

ah thx for the reply!

 

So if i understand it correctly, My internetport IP-adres and my IP that i find on the internet (whatismyipaddress.com) has to be the same?

 

If this is true, i will call my ISP tomorrow and ask if they can set it good?

 

 

Message 5 of 13
Highlighted
Sensei

Re: R7000 not portforwarding

> So if i understand it correctly, My internetport IP-adres and my IP that
> i find on the internet (whatismyipaddress.com) has to be the same?

 

   Yes.

 

> internetport.png

 

   "192.168.0.20" is a private address, and that's a problem.  But
that's not an address which I would expect from an ISP using CGN.

 

> [...] Connected to what?

 

   Still wondering.  To what is the WAN/Internet port of the R7000
connected?

 

   If your R7000 is connected to some other router, then the fact that
you have more than one router is the problem.  If your only router is
the R7000, then the other router must be at your ISP.

Message 6 of 13
Aspirant

Re: R7000 not portforwarding

[...] If your only router is the R7000, [...]

 

Yes, the r7000 is the only router i got, its connected the the modem that i received from the ISP. I hope this is your answer haha. I will contact my ISP for another IP adres that is open. Thx for your help! I hope it will soon be fixed. 

 

Message 7 of 13
Highlighted
Sensei

Re: R7000 not portforwarding

> [...] its connected the the modem that i received from the ISP [...]

 

   And what, exactly, is "the modem that i received from the ISP"?  Has
it a maker and model number?  Is it a simple modem, or a modem+router?

Message 8 of 13
Highlighted
Aspirant

Re: R7000 not portforwarding

[...] Has it a maker and model number? [...]

 

jea, its from cisco.  EPC3940L  its just a simple modem, i dont think you can change things in that. the R7000 is connected to the modem via bridge modus like in the picture that i sended

Message 9 of 13
Highlighted
Sensei

Re: R7000 not portforwarding

> jea, its from cisco. EPC3940L its just a simple modem, i dont think
> you can change things in that. [...]

 

   Guess again?

 

      https://www.rega-sense.ch/content/pdf/UserGuide_CiscoEPC3940L.pdf

 

> [...] like in the picture that i sended

 

   Except the picture shows a simple modem, not a "gateway"
(modem+router), like an EPC3940L.

 

   Your ISP is innocent.  You have cascaed two routers.

 

   There are two ways to avoid the problems which you can experience
when cascading multiple routers, each of which involves using only one
router:


   1. Leave the EPC3940L as a modem+router, and cripple the R7000.  Visit
http://netgear.com/support , put in your model number, and look for
Documentation.  Get the User Manual.  Read.  Look for "Set Up the
Router as a WiFi Access Point".  If you do that, then you would need to
configure your port forwarding on your (one) router, the EPC3940L.

 

   2. Cripple the EPC3940L by putting it into modem-only ("bridge")
mode, and use the R7000 as your only router.

 

   I know nothing about how to configure an EPC3940L.

Message 10 of 13
Highlighted
Aspirant

Re: R7000 not portforwarding

I think i have found the solution. My modum is in router modes aswell, so in my netwerk i have 2 routers. See picture 1. But if i want to set the modem to bridge mode, my netgear router is not working. Or even worse, if i do something in my modem (that i got from the ISP) and save it, the modem will crash in my opinion. It happend this evening twice. After reinstalling my modem and netgear router i had finally my internet back. After the hole re-install progress my PC generated a new Ip adres for my netgear router. See picture 2. (Router IP:192.168.1.1) because the C (In A.B.C.D) is a 1, i cannot reserve a adress for my port. Also with that C in my ipv4 adress i cannot port forward via my modem because its a closed IPv4?

 

My PC has the IPv4: 192.168.1.2 (picture 3)

 

My modem is 15 years old. I dont know if that is long for a modem? But im gonna call my ISP tomorrow to ask if they can help me out.

 

I will keep you up to date with the status.

 

Thx!

Message 11 of 13
Highlighted
Sensei

Re: R7000 not portforwarding

> [...] But if i want to set the modem to bridge mode, my netgear router
> is not working. [...]

 

   There are many kinds of "not working".  "not working" is not a useful
problem description.  It does not say what you did.  It does not say
what happened when you did it.  As usual, showing actual actions
(commands) with their actual results (error messages, LED indicators,
...) can be more helpful than vague descriptions or interpretations.

 

   I know nothing about how your EPC3940L was configured when it was a
modem+router.  You might need to do things to the R7000 to make it work
with your ISP when it's your main/only router.

 

   Did you try a settings reset on the R7000 after you changed the
EPC3940L to modem-only mode?

 

> [...] See picture 2. (Router IP:192.168.1.1) because the C (In
> A.B.C.D) is a 1, i cannot reserve a adress for my port. [...]


   Regarding "cannot", see "not a useful problem description [...]",
above.

 

   LAN addresses like "192.168.1.1" (for the R7000) and "192.168.1.2"
(for your computer) seem normal to me.  You should still have a reserved
address for your server system.

 

> [...] Also with that C in my ipv4 adress i cannot port forward via my
> modem because its a closed IPv4?

 

   Why not?  Regarding "cannot", again, see "not a useful problem
description [...]", above.

 

> [...] call my ISP tomorrow [...]

 

   They may be able to tell you if you need to specify any special
settings on your (R7000) router when you're not using the router in the
EPC3940L.

View solution in original post

Message 12 of 13
Highlighted
Aspirant

Re: R7000 not portforwarding

Finally some good news! My port is open! 

[...] Did you try a settings reset on the R7000 after you changed the EPC3940L to modem-only mode? [...]

This was the solution. Did not think about this! My port is open and i can connect via the ip what i find op the internet. Thx! With a tool like canyouseeme.org it also says the port is open!

 

Thx for the help!

Message 13 of 13