Reply

R7000 slow speeds

Kubricks
Initiate

R7000 slow speeds

I have been noticing slow Internet and WiFi speeds through my R7000 router. I assumed it was through my ISP's end, but I called them and they had me troubleshoot through things and we determined that the issue was being caused by the router, not their modem or service.

We have Spectrum Ultra which gives us "up to" 400Mbps, but when we first got the service we frequently saw around 500Mbps even during high traffic times. Lately (maybe the last month or so), our speed has been around 120Mbps, the max I've seen it at one time was 140Mbps. I am hardwired to the router with 2 PC's and an Xbox One console, plus wirelessly with 2 phones and several IoT devices, all of which have the same speed from what I've been able to test. Hardwiring my PCs straight to the modem gave me speeds of ~470Mbps, typical of what I used to get.

 

I've already factory reset the router. After doing so, I was still getting only 120Mbps downloads. Although the firmware auto update showed that I had the most current update (1.0.9.88 I believe it was) I noticed there was a more recent update on the Netgear Support site (1.0.11.102) which I then downloaded. After installing the new firmware version, my speeds are still not any better. Most other troubleshooting guides I've seen recommend factory resets or firmware updates, so I'm not sure what else I can do from here.

Model: R7000|AC1900 Smart WIFI Router
Message 1 of 3

Accepted Solutions
Kubricks
Initiate

Re: R7000 slow speeds

I was able to fix it somehow after hours of trying different firmware and trying things others have done. I am currently running firmware version 1.0.9.32. I'm not sure, but I believe what fixed my issue was "reloading" the QOS by running a speed test, enabling it, then disabling it. Maybe somehow a profile got loaded that said my max bandwidth was around 140Mbps and it didn't process any more than that. Strange that it would limit my bandwidth when it wasn't enabled, but I saw another thread where someone had similar issues and that worked for them.

Hardwired speeds are at 480Mbps, and my phone was getting ~390Mpbs on the other side of the house.

View solution in original post

Message 3 of 3

All Replies
plemans
Guru

Re: R7000 slow speeds

What modem do you have from your provider? 

What speeds do you get directly hardwired into the modem? 

 

In terms of the R7000, I'd highly recommend installing version 1.0.9.42 of the firmware to it. Then factory reset it, and disable auto updates. A few devices of the R7000 seem to have issues with the firmware versions >1.0.9.42. 

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 2 of 3
Kubricks
Initiate

Re: R7000 slow speeds

I was able to fix it somehow after hours of trying different firmware and trying things others have done. I am currently running firmware version 1.0.9.32. I'm not sure, but I believe what fixed my issue was "reloading" the QOS by running a speed test, enabling it, then disabling it. Maybe somehow a profile got loaded that said my max bandwidth was around 140Mbps and it didn't process any more than that. Strange that it would limit my bandwidth when it wasn't enabled, but I saw another thread where someone had similar issues and that worked for them.

Hardwired speeds are at 480Mbps, and my phone was getting ~390Mpbs on the other side of the house.
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 13317 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi WiFi 6E