Reply
Highlighted
Guide

R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

I just updated my Nighthawk X4 R7500 to the latest available firmware, V1.0.0.108, and wireless clients no longer receive the correct IP address assignments after they connect to the 5.0 GHz wireless network. I have used the Nighthawk web interface to give an iPhone and a Mac fixed IP addresses (based on the MAC addresses of their wireless cards) when they connect, but both devices are receiving addresses in my DHCP range, instead.

 

This did not happen on the V1.0.0.94 firmware I was previously using. Has anyone experienced something similar?

Model: R7500|Nighthawk X4 AC2350 Smart WiFi Router
Message 1 of 17

Accepted Solutions
Highlighted
Guide

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

I just upgraded to the latest R7500 firmware, V1.0.0.110. This appears to have resolved the issue, although NETGEAR does not include this fix in the release notes for this firmware upgrade.

 

If you were affected by this issue, I recommend you install V1.0.0.110. You may need to download the firmware update directly from NETGEAR's website; when I attempted to update the firmware through the router's interface, the firmware update page refreshed constantly and indefinitely, never finding the available update.

 

View solution in original post

Message 16 of 17

All Replies
Highlighted
Master

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

Hi justinl,

 

Try to reset the router and reconfigure it. Check if still the same.

Message 2 of 17
Highlighted
Master

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

Hi justinl,

 

We’d greatly appreciate hearing your feedback letting us know if you need further assistance.

Message 3 of 17
Highlighted
Aspirant

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

Same issue on my side :-(

After resetting the router, it is sometimes working but just a few hours...

On my smartphone, after a reset I'm able to connect to the wlan but when I'm coming back home after my working day ... no way, I have to reset the router once again :-((

Message 4 of 17
Highlighted
Aspirant

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

By the way, I have already put a Netgear R6300 to the trash for the same reason and I think this one will soon follow the same route :-((

Message 5 of 17
Highlighted
Master

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

Hi Feyroce,

 

How many devices are affected?

Is it on both 2.4Ghz or 5GHz?

Is wired connection working?

Do you have the latest firmware? If yes, was it working with the previous firmware?

Message 6 of 17
Highlighted
Guide

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

Hi @Feyroce,

 

I am not sure we have the same issue. It sounds like your smartphone might not be receiving any IP address at all, leading to no WLAN connectivity. After upgrading to V1.0.0.108 of the firmware on my R7500, IP addresses are still assigned to my wireless clients, but the addresses that get assigned are in the DHCP range rather than the static addresses that I have configured for my wireless devices, based on their MAC addresses.

 

For example, I have assigned my iPhone the address 192.168.0.60, but the R7500 gives it the address 192.168.0.101, which is the first address in the DHCP range I configured.

 

@JamesGL, this behavior happened only *after* a firmware upgrade (to V1.0.0.108) and the firmware upgrade reset the router configuration. I had to reconfigure it from scratch. It seems unlikely that a second reset would resolve the issue. But, I appreciate the initial assistance.

 

Message 7 of 17
Highlighted
Aspirant

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

Hi JamesGL,

 

Basically all wireless devices are affected, devices are first getting an IP address then I receive a message that internet connection is not available and finally the devices are disconnected.

 

Regards,

R.

Model: R7500|Nighthawk X4 AC2350 Smart WiFi Router
Message 8 of 17
Highlighted
Aspirant

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

same issue hapens to me , only started with the latest firmware .

 

sometimes fixes with turing the device on and off. any alteration on router can also cause problems to come back 

Message 9 of 17
Highlighted
Master

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

Hi Feyroce,

 

When your reset the router, did you reconfigure it manually or did you load the config file?

 

Hi 1Nic,

 

Reset and reconfigure manually.

Message 10 of 17
Highlighted
Guide

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

After updating the firmware, I reconfigured the router manually. Instructions included with the firmware update indicated that restoring from a configuration file would not work, which itself pretty much defeats the purpose of having a function to save a configuration file...

 

Message 11 of 17
Highlighted
Aspirant

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

Hi JamesGL

 

I reconfigured the router manually.

 

 

Message 12 of 17
Highlighted
Aspirant

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

i also configured it manually after the update and reset 

Message 13 of 17
Highlighted
Aspirant

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

I am experiencing the same issue after upgrading the firmware.  I was on a much older version - 1.0.2.4, and finally upgraded to the latest.  I figured out that the DHCP Server was not using the MAC addresses to assign the fixed IP addresses that I setup when I go the router.  I went back to the firmware version I was using and it worked fine.  So the question is, what happened to the latest firmware or a prior version to cause this.  Seems like a major issue that should be resolved.  Let me know if I can provide any more information.

Model: R7500v2|Nighthawk X4 AC2350 Smart WiFi
Message 14 of 17
Highlighted
Aspirant

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

Hi JamesGL

any other ideas on how to fix issue

or

is there new firmwre being deloped to fix issue 

Model: R7500|Nighthawk X4 AC2350 Smart WiFi Router
Message 15 of 17
Highlighted
Guide

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

I just upgraded to the latest R7500 firmware, V1.0.0.110. This appears to have resolved the issue, although NETGEAR does not include this fix in the release notes for this firmware upgrade.

 

If you were affected by this issue, I recommend you install V1.0.0.110. You may need to download the firmware update directly from NETGEAR's website; when I attempted to update the firmware through the router's interface, the firmware update page refreshed constantly and indefinitely, never finding the available update.

 

View solution in original post

Message 16 of 17
Highlighted
Aspirant

Re: R7500 not assigning correct IP addresses to wireless clients after firmware upgrade

Hi justinl

Just did the upgrade as well and it seems to work :-)

I'll check over the next days and see if the issues are solved!

Message 17 of 17
Top Contributors
Discussion stats
  • 16 replies
  • 4058 views
  • 2 kudos
  • 5 in conversation
Announcements