Reply

R7800 Ethernet port gets assigned Public IP at random. PC is publicly exposed on the internet.

j894
Aspirant

R7800 Ethernet port gets assigned Public IP at random. PC is publicly exposed on the internet.

Here's an interesting and unusual problem I ran into on my R7800, that I've had a little over 1 year. It seems every few months I'll start up my main desktop PC (hooked up via network cable) and it will work just fine. However, upon starting my PC something goes wrong with the router functionality for the hardwired connections. The router seemingly gives my desktop PC a public IP from my ISP and disables the other hardwired ethernet ports on the router except for the WAN connection. My main PC can't communicate to any other device on the network during this period, it acts like its hooked up to its own one port switch and going straight out to the internet, by passing the router completely.

My 2nd desktop PC is also hardwired and while this is happening it can't communicate with the router, rest of the network, or get out to the internet. While the connection status shows as connected in Windows, it can't DHCP to the router for an IP and instead uses a private 169.x.x.x windows DHCP address (both are win 10 devices). I believe the rest of the ethernet ports are the same way and stop functioning. I dug through the Windows event logs and found corresponding DHCP address errors under: Applications and Services Logs> Microsoft> Windows> Dhcp-client> Microsoft Windows-DHCP Client Events/Admin. Numerous eventID 1002's and 1003's errors, showing my PC trying to renew my private IP via DHCP, but having the request passed to my IPS's DHCP server instead of the router (the DHCP req. for a private is denied and a public IP is assigned by my ISP).

The wireless portion of the router seems unaffected as I still get wifi connectivity and can get out to the internet through the router, as well as login to the admin console of the router. Rebooting the router immediately fixes the issue; restoring connectivity to all devices, giving DHCP addresses to all devices and allowing communication.

As of this posting, I've run into this about 5-6 times and my event logs show the associated DHCP IP errors going back to 10/01/18 (logs only go back to July). I'm running the current firmware version: 1.0.2.62. This also happened on the previous version, 1.0.2.60, possibly others. I don't really have any special settings for the configuration of the router. No port forwarding, DMZ setting, no management through wan port, etc. I'm the only one using the router with only a handful of devices.

Sorry for the long-winded explanation, this is a weird scenario. Has anyone run into this before? Is this some kind of bug or is the hardware failing? It's pretty crazy that my Main PC is being exposed publicly on the internet when this happens. It doesn't make me feel too good about using this unit.

 

EventLogForDHCPError.PNGPublicIPBehindRouter.png

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 1 of 7
duckware
Prodigy

Re: R7800 Ethernet port gets assigned Public IP at random. PC is publicly exposed on the internet.

In a web browser, visit the '/debug.htm' web page on your router.  Is "WAN Port mirror to LAN port1" off?

 

(can't see attached photos until NG admins approve).

Message 2 of 7

Re: R7800 Ethernet port gets assigned Public IP at random. PC is publicly exposed on the internet.

@j894 

 

Care to tell us what's in front of your nighthawk, hardware brand/model, how its configutred, your ISP, etc.

 

In addition to @duckware 's question.

 

 

~Comcast 1 Gbps/50 Mbps SB8200 > R8000P
~R8000P FW:1.4.1.68 ~R7000 FW:1.0.9.42
~R6400 FW:1.0.1.52 ~Orbi-AC3000 FW:2.5.1.8
~EX3700 FW:1.0.0.84

Message 3 of 7
j894
Aspirant

Re: R7800 Ethernet port gets assigned Public IP at random. PC is publicly exposed on the internet.

@duckware  The "WAN Port mirror to LAN port1"I just checked and "WAN Port mirror to LAN port1" is set to off Currently, since rebooting the router. I'll try to double check this again before rebooting if the condition happens again. Is it worth turning on the debug logging and leaving it on for weeks, maybe even months?

 

@shadowsports  I have a motorola SB6121 cable modem plugged into the WAN. What configuration info would you be looking for?

 

Debug Info_031619.PNG

 

Message 4 of 7
pec967
Luminary

Re: R7800 Ethernet port gets assigned Public IP at random. PC is publicly exposed on the internet.

Do you have an Xbox connected to a wired Ethernet port on the R7800?

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 5 of 7
j894
Aspirant

Re: R7800 Ethernet port gets assigned Public IP at random. PC is publicly exposed on the internet.

Negative on the xbox. I only have two desktop PC's plugged into the router.
Message 6 of 7
j894
Aspirant

Re: R7800 Ethernet port gets assigned Public IP at random. PC is publicly exposed on the internet.

Bump. Anyone run into this. Anymore suggestions?

This hasn't happened in a while now.

 

Anyone have luck using debug logging for an extended period of time if I were to leave it on till this problem reoccurs?

Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 1102 views
  • 0 kudos
  • 4 in conversation
Announcements

Orbi WiFi 6E