Reply
Highlighted
Sage

Re: R7800 FW 1.0.2.44 Discussion

> The LAN port is needed when in AP mode I believe. The WAN port should
> not be used for AP mode.

   Do you mean generally, or only with a particularly defective firmware
version?  Generally, Netgear routers with a one-step AP mode selection
(ADVANCED > Advanced Setup > Wireless AP, or similar) seem to work just
fine (or, as well as they ever do) when using the WAN port, as
documented in their User Manuals.

> Technically speaking, when AP mode is used on any router or manually
> configured, DHCP services and most if not all WAN port dependent
> services are disabled. So the WAN port should be rendered disabled until
> router mode is re-enabled. So general use of AP mode, think of LAN to
> LAN configurations.

   Technically speaking, AP mode on these routers is supposed to make
the WAN port equivalent to another LAN port, instead of leaving it
useless.

Message 26 of 41
Highlighted

Re: R7800 FW 1.0.2.44 Discussion

Other problems with this firmware revision : ( note that i use the R7800 in AP mode. Did not test in router mode)

 

-Cannot upload a new firmware version by using google chrome (trying to revert to .38 in my case). Have to use Microsoft edge to make it work. With chrome, once you have selected the file and click upload, instead of uploading, it brings you back to the window to select the file. Tried to clear the browser history with no effect. 

 

- There is an option in wifi 2.4ghz that is "Enable 20/40 Mhz coexistence". When it is unselected, normally it would allow you to use a 40 mhz bandwidth,even in interference environment, thus doubling your transfer speed. I confirm that it works by looking at the bandwidth spectrum used with a wifi analyzer software on my android phone and by doing a speedtest. Problem is that when i enable the guest network, the bandwidth drops from 40 to 20 mhz , like if the guest network overrides the fact that Enable 20/40 coexistence option is unselected. Some might argue not to use this option because it is not neighbour friendly but i live in a sector where the higher interference signal that i get from ny neighbours is below -85dbm in the whole 2,4 ghz spectrum. I had an asus router before this one and it did not lower the bandwidth by half because i was using a guest network.

 

- Also, like others in this thread, i cannot set a static IP from a master reset.Have to revert to .38, set it manually and do a firmware automatic update 

Message 27 of 41
Highlighted
Guru

Re: R7800 FW 1.0.2.44 Discussion

It's known that sometimes Chrome doesn't process FW updates correctly or interact with router UIs well. Gooogle keeps changing there browser code frequenty and thus can effect how it interacts with router UIs and FW updates. This has been going on for a long time.

I recommend using IE11 or FF broswers as they are more compatible with router UI and FW updates. Seen issues with Chrome cause routers to be bricked. As a safety measure, use a different browser to do any FW updates. Don't use Chrome. Use chrome to manage the router UI features if it seems to work for you.

 

20/40Mhz may have changed due to Guest Zone. I presume that the wifi standard might not have wanted GZ to have 40Mhz connectifity to help limit bandwidth there so even though you disable 20/40Mhz, guest zone enable probably now overrized this and causes everything to go to 20Mhz. If your wanting to set up some thing for guest, you can always add a separate wireless AP and have them connect to it and keep your main router for just your use. Also some older devices may cause the drop in 20Mhz as well. Possible quanity of devices connected to one router can be another cause.

 

Your last item doesn't make sense. Static IP to master reset? Please re-state your last item. I have reproduced the AP mode issue and setting a static IP address on there, seems to be a problem in AP modem and static IP addressing here.


wrote:

Other problems with this firmware revision : ( note that i use the R7800 in AP mode. Did not test in router mode)

 

-Cannot upload a new firmware version by using google chrome (trying to revert to .38 in my case). Have to use Microsoft edge to make it work. With chrome, once you have selected the file and click upload, instead of uploading, it brings you back to the window to select the file. Tried to clear the browser history with no effect. 

 

- There is an option in wifi 2.4ghz that is "Enable 20/40 Mhz coexistence". When it is unselected, normally it would allow you to use a 40 mhz bandwidth,even in interference environment, thus doubling your transfer speed. I confirm that it works by looking at the bandwidth spectrum used with a wifi analyzer software on my android phone and by doing a speedtest. Problem is that when i enable the guest network, the bandwidth drops from 40 to 20 mhz , like if the guest network overrides the fact that Enable 20/40 coexistence option is unselected. Some might argue not to use this option because it is not neighbour friendly but i live in a sector where the higher interference signal that i get from ny neighbours is below -85dbm in the whole 2,4 ghz spectrum. I had an asus router before this one and it did not lower the bandwidth by half because i was using a guest network.

 

- Also, like others in this thread, i cannot set a static IP from a master reset.Have to revert to .38, set it manually and do a firmware automatic update 


 

 


My Setup (Cable 900Mbps/50Mbps)>CAX80>RBK853 v3.1.16.6(Router Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK50, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 28 of 41
Highlighted

Re: R7800 FW 1.0.2.44 Discussion

Sorry for not being clear. What i means is that after doing a master reset, trying to set a static IP in AP mode does not work in .2.44. I mention "after a master reset" because if you do a firmware ugrade from let's say .2.38 to .2.44 and that you had set a static IP in .2.38, the static ip will still be there.

 

Also, regarding the problem with updating firmware with google chrome, i found that clicking in the center of the upload button causes the problem, moving the cursor a little bit on the right (on the right arrow), resolves the issue. Probably due to HTML coding

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 29 of 41
Highlighted
Guru

Re: R7800 FW 1.0.2.44 Discussion

Thanks for clarifiing. Yes I'm seeing bad behavior with AP mode in v4x FW.

 

Wonder if this button press location is a problem in all browsers or just Chrome. 


wrote:

Sorry for not being clear. What i means is that after doing a master reset, trying to set a static IP in AP mode does not work in .2.44. I mention "after a master reset" because if you do a firmware ugrade from let's say .2.38 to .2.44 and that you had set a static IP in .2.38, the static ip will still be there.

 

Also, regarding the problem with updating firmware with google chrome, i found that clicking in the center of the upload button causes the problem, moving the cursor a little bit on the right (on the right arrow), resolves the issue. Probably due to HTML coding


 


My Setup (Cable 900Mbps/50Mbps)>CAX80>RBK853 v3.1.16.6(Router Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK50, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 30 of 41
Highlighted
Guru

Re: R7800 FW 1.0.2.44 Discussion

For users wanting AP mode to work on v4x FW, do the following: From NetGear Guy.
 
1. Load v1.0.2.38 and set to AP mode with static IP - working
2. Update to v1.0.2.44 (with out doing any factory resets) - working
 
Do not do the following or you will see the problem in AP Mode:
1. Reset to factory running v1.0.2.44
2. Set to AP mode with static IP and receive "site cannot be reached" You get and error or maybe see that you can't access the UI in AP mode router at all or can't find it's IP address on a connected client table like what happened with mine.
 
Hopefully this will be fixed in next OEM FW update for the R7800.

My Setup (Cable 900Mbps/50Mbps)>CAX80>RBK853 v3.1.16.6(Router Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK50, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 31 of 41
Highlighted
Retired_Member
Not applicable

Re: R7800 FW 1.0.2.44 Discussion

Hey,

 

I had exactly this problem today (https://community.netgear.com/t5/Nighthawk-WiFi-Routers/Firmware-IP-AP-MODE-BUG-R7800-version-1-0-2-...).

I ended up doing rollbacks for all our routers and stay at 1.0.2.38 for now.

 

Your solution might work since the routers which were configured before still worked but that workflow you descriped is to unstable for my taste.

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 32 of 41
Highlighted
Guru

Re: R7800 FW 1.0.2.44 Discussion

Yes this issue is known and NG is aware of it:

https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-46sf.44387/#post-380645

and
https://community.netgear.com/t5/Ni...800-FW-1-0-2-44-Discussion/m-p/1504989#M82867


@Retired_Memberwrote:

Hey,

 

I had exactly this problem today (https://community.netgear.com/t5/Nighthawk-WiFi-Routers/Firmware-IP-AP-MODE-BUG-R7800-version-1-0-2-44/m-p/1512695).

I ended up doing rollbacks for all our routers and stay at 1.0.2.38 for now.

 

Your solution might work since the routers which were configured before still worked but that workflow you descriped is to unstable for my taste.


 


My Setup (Cable 900Mbps/50Mbps)>CAX80>RBK853 v3.1.16.6(Router Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK50, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 33 of 41
Highlighted
Aspirant

Re: R7800 FW 1.0.2.44 Discussion

Hi

Interested to read this regarding bridging across from WiFi to wired. I've been chasing a Sonos problem for days and now suspect this is it (router firmware).  My Sonos streams media fine (as it is using Ethernet to do it).  However, controlling it via phones etc is driving me crazy.  Commands either don't make it, or are delayed. Some Sonos kit just shows up randomly or not at all, and metadata isn't updating in time.  It often takes several tries just to "find" the Sonos kit on the LAN.  Happens whether I connect the controller via 2.4GHz or 5GHz.  I wonder if anyone can confirm this potential firmware bug please, and perhaps advise what version I need to roll back to in order to rectify.  I am seriously considering sending this R7800 back to Amazon also, as lost too many hours on this already.  Thought I would try and find the problem first though.  Thanks.

Neil

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 34 of 41
Highlighted
Luminary

Re: R7800 FW 1.0.2.44 Discussion

By any chance do you have a Netgear Ethernet switch with management features connected to the R7800? If so, you might be suffering from the IGMP Snooping bug, which causes similar problems to what you describe with devices using Apple's Bonjour protocol, e.g., Apple TV. The solution is to disable IGMP Snooping on the Ethernet switch.

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 35 of 41
Highlighted
Aspirant

Re: R7800 FW 1.0.2.44 Discussion

Thanks, but no, the Playbar is connected directly via Ethernet to the R7800.  Is there a firmware version that does not do this please?  If I turn the VLAN tagging off then I lose my Internet (PPPOE for T-Online needs it marking all as VLAN7).  If not, I guess I have no option but to return the router and buy another brand

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 36 of 41
Highlighted
Guru

Re: R7800 FW 1.0.2.44 Discussion

Try v3x versions before v4x and see. 

 

Can also see if Voxels R7800 works better:

https://www.voxel-firmware.com/Downloads/Voxel/html/browse.html


@slateronlinewrote:

Thanks, but no, the Playbar is connected directly via Ethernet to the R7800.  Is there a firmware version that does not do this please?  If I turn the VLAN tagging off then I lose my Internet (PPPOE for T-Online needs it marking all as VLAN7).  If not, I guess I have no option but to return the router and buy another brand


 


My Setup (Cable 900Mbps/50Mbps)>CAX80>RBK853 v3.1.16.6(Router Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK50, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 37 of 41
Highlighted
Aspirant

Re: R7800 FW 1.0.2.44 Discussion

Thanks.  Just to be sure, please can you confirm your recommended firmware version number?  I am currently on 1.0.2.44, which as of yesterday was the latest available build from Netgear.  I would put the 3rd party build on, but just concerned that if I decide to return it and can't get it back onto the stock firmware I may have trouble.

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 38 of 41
Highlighted
Guru

Re: R7800 FW 1.0.2.44 Discussion

Voxels FW uses same process to install FW and you can reinstall OEM FW in same way.

 

Try Firmware Version 1.0.2.38


My Setup (Cable 900Mbps/50Mbps)>CAX80>RBK853 v3.1.16.6(Router Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK50, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 39 of 41
Highlighted
Luminary
Luminary

Re: R7800 FW 1.0.2.44 Discussion

in this fw version when u reboot the modem the modem gets back online  and then strangly the router disconnects n u cant get back online cuz the routers confused for several minutes

 

Message 40 of 41
Highlighted
Luminary

Re: R7800 FW 1.0.2.44 Discussion

 

when ever you reboot your modem, you should always reboot your router after the modem is fully online; actually, unplug the router power cable when doing this, let the modem reboot and get on line completely, then plug the router back in

Message 41 of 41
Top Contributors
Discussion stats
Announcements