Reply
Highlighted
Aspirant

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

Hi, I can confirm the exact same problem as you, @Morarr . External DNS works fine, but I installed firmware version 1.0.2.62 today and I am now unable to use an internal server (Pi-hole) when configured as the DNS server for my network.

 

Are there any Netgear support representatives following this thread who can let us know the best way to open a product issue? 

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 26 of 138
Highlighted

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

They do look out for these things Perhaps @DarrenM can say of he has passed it on the technical team.

 

I'll try the backdoor approach.

 

My guess is that this is one of those "esoteric" configuration issues that got  missed in beta testing.

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 27 of 138
Highlighted
Aspirant

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

I have the exact same problem using my own internal DNS. Anything external i.e. Google \ OpenDNS work fine but as soon as I enter an internal range like 192.168.0.26 the internet dies and my DNS server logs go nuts.

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 28 of 138
Highlighted
Tutor

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

I have the exact same issue (and solution) as ^^. 

 

reverted to 2.60 and everything is back up-and-running. sloppy and disappointing they missed this during beta/testing.

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 29 of 138
Highlighted

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62


@r7800NG wrote:

I have the exact same issue (and solution) as ^^. 

 


I have told the Netgear minders about this issue. With luck they will respond.

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 30 of 138
Highlighted
Apprentice

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

Does this internal DNS issue affect the R7800 in AP (Access Point) mode?

 

 

 

Message 31 of 138
Highlighted

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

Is DNS active in AP mode? Wouldn't that be in the hands of the router?

 

Disabled Features on the Router when set to AP Mode | Answer | NETGEAR Support

 

 

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 32 of 138
Highlighted
Sage

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

> Is DNS active in AP mode? Wouldn't that be in the hands of the router?

 

   What, exactly, does "DNS [being] active" mean to you?

 

      https://community.netgear.com/t5/x/x/m-p/1655299

 

> https://kb.netgear.com/26765

 

   Where does "DNS" appear in that document?

Message 33 of 138
Highlighted
Aspirant

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

Well I've now downgraded back to the previous version and everything is now working again.

Message 34 of 138
Highlighted
Apprentice

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

When configuring AP mode on the R7800, you enter an IP address, Subnet Mask, Gateway Address and a Primary and Secondary DNS adddress.

 

The Gateway address and Primary DNS address on my AP are both set to the router, so both are internal addresses.

 

I'm worried that could be a problem given what others are reporting about DNS and internal addresses.

 

While the AP is not used for DHCP or DNS resolving for clients, it must use the specified DNS addresses for something.

 

 

Message 35 of 138
Highlighted
Tutor

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

I believe this threads issue is only when the router is also doing DHCP.
Message 36 of 138
Highlighted
Aspirant

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

@Morarr That's not the case, actually. I've tested with DHCP disabled on my router and my Pi-hole server cofigured as the DHCP server. Systems successfully receive DHCP addresses from the Pi-hole server, but DNS queries still fail.

Message 37 of 138
Highlighted
Tutor

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

Thanks, I could be wrong, I'm not a network engineer. I was under the impression that the DHCP server dictated what DNS ips to use for the clients.

If DHCP is disabled on r7800 then it shouldn't need the pihole IP to be in DNS field, so I assumed the problem wouldn't exist.

But, this is all with just me trying to Google stuff to piece it together. In my setup I always had router doing DHCP, I have never tried AP mode or doing pihole as dhcp just to clarify.
Message 38 of 138
Highlighted
Aspirant

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

Whether you raspberry pi with Pihole connect to the LAN port of the router?

And what do you meaning the "loose internet connection"?  Is it the router's wan port loose the ip?Or only the LAN pc can't identify domain name?

Could you please answer these questions for me?

Thank you in advance.

Message 39 of 138
Highlighted
Aspirant

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

From memory as soon as you set the DNS Server to an internal DNS Server, i.e. on 192.168.0.4, any machines that start using that DNS server seem to get stuck in a feedback loop which overwhelms the DNS Server and the Netgear Router and the Netgear Router tells you its lost its External Connection and tries reconnecting.

 

Any machine that tries to load a webpage just times out whether its picked up the new DNS server or not.

 

As a test on one machine I put Googles DNS enties on the Adaptor settings and left the Netgear DNS as local DNS server. This still fails with page timeouts.

Message 40 of 138
Highlighted

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

This bug has now landed on the desks of the Netgear technicals who fix these things.

 

Heaven only knows when, or if, they will mend it.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 41 of 138
Highlighted

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

Netgear is on the case:

 

Re: Can't reach Internet when I specify DNS - NETGEAR Communities

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 42 of 138
Highlighted
Aspirant

moose4lord@yahoo.com

I also had problems with my pihole after upgrading to v1.0.2.62, although the symptoms seem a little different. On my network both the R7800 and pihole are configured to use my ISP's DNS servers, but individual computers on the network are setup to use the pihole for DNS resolution. This worked fine on v1.0.2.60. After upgrading to v1.0.2.62 the pihole stopped getting DNS requests from the individual computers. It seemed like even though the computer's DNS was configured with the pihole's IP address, the router was intercepting their DNS requests and substituting it's own DNS settings. Very strange. Reverting back to v1.0.2.60 firmware fixed the issue.

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 43 of 138
Highlighted
Luminary

Re: moose4lord@yahoo.com

I have  to say  1.0.2.62 is giving me more bufferbloat on the dslreports speedtest page..

compared to 1.0.2.52.   It is actually dragging down my speed.   1.0.2.52 has lots of bufferbloat also but never dragged my speed down.    I'm going to look into replacing my cablemodem... but after that I'm not sure about NetGear.    No idea how ro report this problem to them...I'm sure they will say its my ISP or the weather..

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 44 of 138
Highlighted

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

I have had an issue with every firmware released after .52. My 5ghz devices stop connecting and drop. I was hopeful with .62 but i have the same issue it just happens slightly less. Looks like im stuck on .52. Not happy. This will probably be my last netgear router.

Message 45 of 138
Highlighted
Aspirant

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

I have upgraded the firmware and  as with the previous vervison I have no 5G wifi recongized on any device.  Not sure if the other problem with previous verison was repaired and that is sudden drops in 2.4g on other devices which required to search for the network and reconnect.

Bought this router in August 2018 with firmware .52 installed and it was excellent with no problems until firmware .60.  I will try to  reinstall .52 again. Of course not satisfied at all with this product or the manufacture support.

After updating firmware today the netgear login page reboots and states I am have a insecure password and I should update.  The page requesting this itself is not secure!

Message 46 of 138
Highlighted
Aspirant

Re: moose4lord@yahoo.com

I have the same problem with my pihole. It's quite frustrating.
Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 47 of 138
Highlighted
Apprentice

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

Voxels vastly enhanced FW based on Netgear 1.0.2.62 does not have the DNS bug:

https://www.snbforums.com/threads/custom-firmware-build-for-r7800-v-1-0-2-63sf.54782/page-2#post-462...

 

Model: R7800|Nighthawk X4S AC2600 WiFi Router
Message 48 of 138
Highlighted
Aspirant

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62

Same problem. Same Pihole local DNS. Same solution: roll back to .60

Model: R6700|Nighthawk AC1750 Smart WiFi Router
Message 49 of 138
Highlighted

Re: R7800 Latest Firmware Issue - DO NOT UPDATE TO V1.0.2.62


@expiredfilm wrote:

Same problem. Same Pihole local DNS. Same solution: roll back to .60


Or read and act on the message above, the one before yours.

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 50 of 138
Top Contributors
Discussion stats
Announcements