Reply

R7800 with Nest Thermostat

Mike09
Follower

R7800 with Nest Thermostat

About 3 weeks ago (~May 1), my 2nd generation Nest thermostat went offline. It's worked and played well with my R7800 router for a couple of years, but now has trouble connecting to Nest through my R7800 router. I've tried:

Reboot (moden, router, and NEST) & router Hard Reset

Changing Wifi channels

Updating the router to using latest firmware (1.02.62) and reverting to older firmware (tried 1.02.58 & 1.0.28)

Disconnecting all other Wifi devices in the house

 

The nest looks like it connects to the R7800, but then can't seem to access the Nest services. Sometimes it says it's online, and other times it returns an error saying it can't connect to the Nest website. I plugged in an older TP-Link router (TL-WR940N) and the Nest connects just fine. I can also connect the Nest using my phone as a hotspot, so the Nest thermostat would appear to be working normally.

 

I have Wave interent and everything else seem to be functioning normally. Any suggestions before I drop money on a new router?

Model: R7800|Nighthawk X4S AC2600 Wifi Router
Message 1 of 3
plemans
Guru

Re: R7800 with Nest Thermostat

The nest 2nd gen functions on 2.4ghz. I know you stated it connects but has trouble connecting to nest server. 

Another thing you can try is changing your 2.4ghz speeds from 800 down to the 347 or 54 mbps setting. I've had smart devices that wouldn't connect to the 800mbps for some reason. Worth a shot.

Have you tried contacting Nest to see what they recommend? If its the only device having issues, I'd start with them. I know nest have issues with a small set of routers but I'm not sure which. 

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
also in AP setup: RAXE500->EAX80
1.4gig download/50mbps upload from Xfinity
We’re members of the public helping out on our own time.
Message 2 of 3
pec967
Luminary

Re: R7800 with Nest Thermostat

I have two 2nd Gen Nest Thermostats connected to 2.4 GHz, 20 MHz channel width, with firmware v. 1.0.2.62 without any problems. I have separate SSID's for 2.4 /5 GHz and SmartConnect disabled, but this is the same configuration I have always used. I believe that v. 1.0.2.62 defaults to SmartConnect On, which sometimes causes problems for IoT devices.

Model: R7800|Nighthawk X4S AC2600 Wifi Router
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 814 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E