Reply

Re: R7900P 2.4Ghz broke completely after recent Firmware Upgrade. I tried all modes and it does not

HolmGear
Initiate

R7900P 2.4Ghz broke completely after recent Firmware Upgrade. I tried all modes and it does not work

NetGear offered a Firmware upgrade which I installed lastnight. It was successful, but 2.4 Ghz band broke completely after the upgrade. I have some devices that can only do 2.4 Ghz and they are all down. I tried every variation including creating a Guest SSID with no password, the radio seems to be not responding. I rebooted several times both the router and computer, but it does not work.

Model: R7900P|Nighthawk X6S AC3000 Tri Band WiFi Router
Message 1 of 6

Accepted Solutions
plemans
Guru

Re: R7900P 2.4Ghz broke completely after recent Firmware Upgrade. I tried all modes and it does not

Its always good to reset a device after a firmware update. As well as making sure to do it over a hardwired connection. Did you try reloading the firmware over a hardwired connection and resetting it post update?

Which firmware did you load?

If this doesn't fix it, you can try downgrading the firmware. You accomplish this in the same route as doing a manual update but using the old firmware. You can find it at the device support page, bottom of the downloads section under +view previous versions. 

 

https://www.netgear.com/support/product/R7900P.aspx

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.

View solution in original post

Message 2 of 6

All Replies
plemans
Guru

Re: R7900P 2.4Ghz broke completely after recent Firmware Upgrade. I tried all modes and it does not

Its always good to reset a device after a firmware update. As well as making sure to do it over a hardwired connection. Did you try reloading the firmware over a hardwired connection and resetting it post update?

Which firmware did you load?

If this doesn't fix it, you can try downgrading the firmware. You accomplish this in the same route as doing a manual update but using the old firmware. You can find it at the device support page, bottom of the downloads section under +view previous versions. 

 

https://www.netgear.com/support/product/R7900P.aspx

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 2 of 6
HolmGear
Initiate

Re: R7900P 2.4Ghz broke completely after recent Firmware Upgrade. I tried all modes and it does not

Thank you very much. I rolled back the software to 1.4.1.30 and now 2.4 Ghz is working fine. The whole experience was very painful. The latest release 1.4.1.42 breaks 2.4Ghz - Netgear, please fix it.
Message 3 of 6
plemans
Guru

Re: R7900P 2.4Ghz broke completely after recent Firmware Upgrade. I tried all modes and it does not

Glad to hear you got it working! If you mark the solution to your problem as solved, it makes it easier for people with the same problem to find the answer. 

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 4 of 6
Bugatti
Initiate

Re: R7900P 2.4Ghz broke completely after recent Firmware Upgrade. I tried all modes and it does not

Netgear - is 2.4Ghz still a problem with the current firmware?

Model: R7900P|Nighthawk X6S AC3000 Tri Band WiFi Router
Message 5 of 6
plemans
Guru

Re: R7900P 2.4Ghz broke completely after recent Firmware Upgrade. I tried all modes and it does not


@Bugatti wrote:

Netgear - is 2.4Ghz still a problem with the current firmware?


its rare to find a netgear employee on here. Its just people from the community helping out. 

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 1172 views
  • 4 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E