Reply

Re: R7900P Firmware 1.2.1.6 problem

JamesGL
Master

Re: R7900P Firmware 1.2.1.6 problem

Message 26 of 110
Davedkv
Aspirant

Re: R7900P Firmware 1.2.1.6 problem

I've been running 1.3.0 firmware for almost a week with no issues so far...
Message 27 of 110
joeave
Guide

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

After seeing that the 1.3.0.8 firmware was out there and installed I gave it a shot...after about 48 hours I had the same symptom all connections time out and I had to reboot the router. That was after running the 1.1.4.6 code without any issue for about a month. I just reloaded the 1.1.4.6 code.

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 28 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

Netgear replaced my original Black Friday Costco router with the same model as my initial unit would lose the Internet EVERY 48 to 49 hours. Seriously, you can set your watch by it.  New router does the same thing.  I have spent hours on the phone with the Netgear support team.  Very good and helpful, but they don't seem aware of the Internet loss problem.  At this time, I am expecting a telephone call from a 'Level 2' support person.   In the meantime, I have reinstalled my old dual band router.

My guess is that the R7900P will be making the trek back to Costco returns.  Too bad because the R7900P has great coverage throughout our house. I will miss it..

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 29 of 110

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

Remember, if ever you have issues after a firmware flash, it makes sense to reset the device to its factory settings. Some new firmware does things to the device's memory that don't play nice with the old settings. A reset doesn't guarantee to restore your sanity, but you would be mad not to try it.

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 30 of 110
joeave
Guide

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

@Ttvbob go back to the 1.1.4.6 firmware and you will no longer have the issue it is the only code that works.

Message 31 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

Two issues/questions here...  First off, how/where would I locate the older firmware?  Item 2, and the most important one is that it seems counterintuitive to  load firmware that my router has never seen.  My unit came with some variant on 1.2 or 1.3 out of the box.  Also, as the 90 day Netgear telephone support clock ticks down, I am not really sure that it is in my best interest to either resolve or workaround a KNOWN Netgear issue.  They can and should do better by the consumer.  A possible suggestion would be to extend the free telephone support for one year.   I know pesonally  that they are capible of manufacturing high quality (commercial) products.  I think that they would (or should) be embarrassed by the usability failures of these units.

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 32 of 110
joeave
Guide

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

Agree with all of your comments. My R7900P from Costco came with the 1.1.4.6 firmware on it and during install I installed the latest code at the time 1.2.1.6 which is when I started having issues consistently after about 24-48 hours. After working with support they suggested downgrading back to 1.1.4.6 which has been working fine.

 

You can get the code here:

 

https://kb.netgear.com/000049483/R7900P-Firmware-Version-1-1-4-6

 

I assumed incorrectly that the 1.3.0.8 code would work but experienced the same issue and again downgraded to 1.1.4.6 which is the only code that works IMHO.

 

Joe

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 33 of 110
steveofsd
Tutor

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

I had this router since black Friday, ever since I down-graded from 1.2.1.6 I haven't have any disconnect issue.  Netgear, if you are reading this don't put out a new firmware that there's problem of disconnecting.  If new firmware requires a factory reset everytime and not a garrentee then you have fail, you will have more returns and people will buy from ASUS and Linksys....ect.  Consumer like us just want auto update and works, we're not IT guys and QC guys to to solve your issues.  

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 34 of 110

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8


@tvbob wrote:

Two issues/questions here...  First off, how/where would I locate the older firmware? 

 

All old firmware, manuals and stuff are, as you would expect, on the support pages for your device:

 

>>>> Nighthawk X6S R7900P | AC3000 Tri Band WiFi Router | NETGEAR Support <<<<

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 35 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

A bit of an update.   My conversation with the Netgear tech support person mentioned that he was escallating thee Internet failure issue to the next tier of support and that I would receive a telephone call from them within 24 hours...That was Friday evening.     As of today (Sunday noontime) no call, no email, no nothing... I sit by my telephone and wait...

Big suprise there!!!!!

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 36 of 110

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

Er, this is the weekend. You expect Netgear techies to ring you on their days off?

 

Silly of the support person to make that promise. Sillier of you not to think "within 24 hours" meant "withing 24 working hours".

 

 

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 37 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

I dunno...  Just kinda assumed that since Netgear's support staff is 24/7 (including Christmas and New Years days),  I just assumed that Netgear's support staff might also have elevated support people there too....  My mistake...

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 38 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

And I forgot to mention that the support person was unable to transfer me to an elevated person at that time as they were all busy with other clients....

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 39 of 110
anksagarwal
Aspirant

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

I had the exact same issue. I got the rouetr replaced from Netgear! The new one was even worse, needed reset every 10-12 hours. Just switch to old firmware as suggested. I hope it works, I will update in a couple days. I am wondering why netgear is not able to fix this issue.

Message 40 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

As today is Wednesday and I still haven't from Netgear's elevated support ("wil call you within 24 hours") from my weekend call, I have decided to solve this issue by returning my router to Costco..   Not worth my time and effort to be a beta tester for Netgear.

 

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 41 of 110
tombatri
Aspirant

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

yes netgear nighthawk r7900p.

recomend to change the name to NIGHTMARE R7900P

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 42 of 110
joeave
Guide

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

After getting the latest security bulletin from Netgear last night recommending the latest frimware, this morning I reset my router to factory default and then upgraded it to 1.3.0.8_1.2.1 and will now wait to see if my internet access stops after 24-48 hours. 

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 43 of 110
JamesGL
Master

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

Hi joeave,

 

Please provide me feedback if the latest firmware resolves the issue for R7900P.

Message 44 of 110
joeave
Guide

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

I can absolutely without a doubt say it is better jury is still out on fixed...my internet both direct and wifi has not stopped totally since resetting to factory default and upgrading to 1.3.0.8. I've seen 2 occassions after about 5 days where things started to slowdown, not 100% stop like before and when I did a constant "ping -t 8.8.8.8" I saw some intermittent response spikes. My consistent 13-15ms response went to 50, 180, 200 and then would come back down very spikey. Powering off/on the router without stopping the ping immediately returned the constant good 13-14ms times once the router came back online. I also noticed there was a new FW update 1.3.0.10 which I installed today so will keep an eye on it. Sorry for the long answer.

 

Message 45 of 110
JamesGL
Master

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

Hi joeave,

 

Update us with your observation with the latest firmware.

Message 46 of 110
cwbunting
Aspirant

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

still the problem remains in .10.... I rolled back. Going to box this up and take back to costco. Enough fooling around, netgear doesn't get it.

Message 47 of 110
TheGuy12
Aspirant

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

I agree with the above this is pretty poor testing of a FW release.

 

The latest FW version has improved the time between reboots, but I still have external conectivity dropping out about every 48 hours.  I can still log into the router and reboot and then everything is back to normal.

 

I am hoping that Netgear can get thier act together on this - keeping with FW version over a year old in this day of security issues is not acceptable.  If this is not fixed in the next version of FW, back to Costco it goes and I will pick up a router with some reliability.

 

Message 48 of 110

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8


wrote:

...keeping with FW version over a year old in this day of security issues is not acceptable. 

 


There has been a flood of firmware since then, three in November and December. (That in itself might be a bit worrying.) Are you saying that you have tried them all and they are all broken for you?

 

I see that you have just signed up – welcome to the funny farm – have you had time to investigate the past history of the R7900P?

 

As a newcomer, you may not be up to speed on things like performing a factory reset when you flash new firmware, and things like doing a full network reboot in the right order.

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 49 of 110
TheGuy12
Aspirant

Re: R7900P Firmware 1.2.1.6 problem and 1.3.0.8

Yes, the last version of FW that has and level of reliability is V1.1.4.6_1.1.85.  Quite outdated in this world of security issues.  There should not be a  tradeoff between basic operation of the router and security updates.

 

Every version I have tried since then has lost external connections within several days.  This is acceptable. 

 

Starting from scratch configuration every time there is a FW update is an unacceptable solution to the problem.  I am fine with some reconfiguration, but factory reset is a bit much.  Port forwarding, static IPs and identification of what devices go with associated MACs would take over an hour.  Maybe if there was a way to store or document this prior to the reset it might be more tolerable, but other than screen shots documenting of your configuration is lacking.

 

 

Message 50 of 110
Top Contributors
Discussion stats
Announcements

Orbi WiFi 6E