Reply

R7900P Firmware 1.2.1.6 problem

Obiwan_
Apprentice

Re: R7900P Firmware 1.2.1.6 problem

I have been running 45 days with the beta firmware and not a problem . I think it is time for Netgear to release a Production Firmware release. What do you think???

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 76 of 110
Brooklynbummer
Aspirant

Re: R7900P Firmware 1.2.1.6 problem

I have been shopping for a new router that is not Netgear simply getting tired of waiting for the last update getting fixed.  I am using old firmware which works fine but exposes me to certain dangers.  7900P routers that are being sold have the same problems.  7900 is first router that does not give me the speed I am paying for, all others gave me more speed than I paid for.


@Obiwan_ wrote:

I have been running 45 days with the beta firmware and not a problem . I think it is time for Netgear to release a Production Firmware release. What do you think???


 

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 77 of 110
JamesGL
Master

Re: R7900P Firmware 1.2.1.6 problem

Hi All,

 

Please check this new firmware for R7900P.

 

https://kb.netgear.com/000058266/R7900P-Firmware-Version-1-4-0-8-Hot-Fix

Message 78 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem

Just installed it...  With any luck at all, this will be the culmination of 6 months of patience.

Hopefully, this  learning experience not lost on  the Netgear team.

 

Bob

 

Message 79 of 110
Obiwan_
Apprentice

Re: R7900P Firmware 1.2.1.6 problem

Me Too!. So far so good no problems. I do hope this is the final solution and they can put out a production firmware
Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 80 of 110
Brooklynbummer
Aspirant

Re: R7900P Firmware 1.2.1.6 problem

 
Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 81 of 110
Brooklynbummer
Aspirant

Re: R7900P Firmware 1.2.1.6 problem

I am glad that the R7900P has been updated but those of us poor souls who have the R7900 appear to be left out in the cold.  My R7900 is not even a year old and it appears that Net Gear has not created a new update to their buggy 1.02.10 software.  I searched the site without any luck and the R7900P upgrade is not available for the R7900.

 

Who ever pushed Net Gears buttons to fix the R7900R I wish would do the same for the R7900.  I am about ready to switch router companies in the next few weeks and I am getting tired of waiting for the miracle of Net Gear fixing their software.  Right now, my R7900 is underperforming in about all aspects and I am using older updates so the router does not have to be rebooted all day long.

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 82 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem

Call tech support and ask to speak with or contact Joy in Level 2 tech support. She has been very helpful in the past with firmware issues.

Bob

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 83 of 110
JamesGL
Master

Re: R7900P Firmware 1.2.1.6 problem

Hi All,

 

Please check this new firmware.

 

https://kb.netgear.com/000058266/R7900P-Firmware-Version-1-4-0-8-Hot-Fix

Message 84 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem

Hi gang,

Just a bit of a heads up.   I am using the new V1.4.0.8_1.2.12.  Router crashed after 4 days.

Rebooted (repowered) router and all is well.  Had the same indictions as the old crashing version.  Dashboard said that the Internet connection was good.

 

Since this is the first crash with the new firmware, I want to confirm that it is the firmware and not something at my end.

Joy at Netgear L2 tech support was notified.

 

Bob

 

Message 85 of 110
natrlhy
Tutor

Re: R7900P Firmware 1.2.1.6 problem

On the beta firmware I referenced, I was needing to reboot it after 24 hours. I've given up on the R7900P and will be returning it to Costco. I got the Synology RT2600ac and so far I really like it. I've used their 5 Bay NAS device for a very long time and the SRM interface is very comfortable to use.

Message 86 of 110
Obiwan_
Apprentice

Re: R7900P Firmware 1.2.1.6 problem

The newest BETA firmware started dropping. I had not gone through the tedious MASTER RESET as I have many custom settings, port forwarding (6ea), static IPs (5ea), static WAN IP, custom LAN settings.IT IS A MAJOR PITA to master reset and reload.

But I have reloaded and will let you know.


How is it that Netgear, with over a month since we let them know that the TEST firmware was solid, cannot release a BETA firmware that is solid. This PROBLEM with the R7900P has been going on for at least SIX MONTHS or MORE!!!!!!

I do IT work and have been using Netgear routers primarily for the last few years. I am returning the second R7900P that I was going to sell and try and figure out how to make one work for me at home. I will NOT be selling NETGEAR equipment to my clients in the future. I cannot afford to service my clients and lose money trying to make them work. I had to replace two R7900P that I installed in November.

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 87 of 110

Re: R7900P Firmware 1.2.1.6 problem


@Obiwan_ wrote:

The newest BETA firmware started dropping. I had not gone through the tedious MASTER RESET ..

.


Mistake number one.

 

Either live with the problems, go back to the older firmware, or bin your hardware.

 

The need for a reset is a pain that all hardware makers inflict on us.

 

Never rebuild a configuration from scratch again! - NETGEAR Communities

 

It is just a part of the modern world that probably tracks back to the people who make the chipsets for network stuff.

 

Refusing to even contemplate a reset is nuts, especially when you have such wondrous IT credentials.

 

Go on, backup your settings. Reset the thing. See if it fixes your problem. If it does, reload the settings. Problem still fixed? Great. No? You have proved that the reset is what you need.

 

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 88 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem

 Happy Sunday one and all.

The new Beta Firmware (V1.4.0.8_1.2.12) crashed a second time.  This time it ran for only 2 days.  It seems to be the same bad news as the original firmware that started this thread.

I have just reinstalled the test firmware that worked solidly.

Netgear notified of the issue.

 

Bob 

 

p.s. to Michael...  This is a consumer  grade router purchased at Costco by non computer types.  It should require skills greater than than jsut following the Netgear Genie for any firmware upgrade.   Just my opinion.

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 89 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem

UPDATE TO MY PREVIOUS P.S.

 

It is a consumer grade router purchased at Costco. The firmware upgrade skills, and anything else for that matter) shouldn't require a degree in Computer Science to get it updated and working properly

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 90 of 110
Obiwan_
Apprentice

Re: R7900P Firmware 1.2.1.6 problem


@tvbob wrote:

UPDATE TO MY PREVIOUS P.S.

 

It is a consumer grade router purchased at Costco. The firmware upgrade skills, and anything else for that matter) shouldn't require a degree in Computer Science to get it updated and working properly


Suckered in again by Netgear's < stellar support. I did a MASTER RESET, inputed all of my settings and 24 hours later, NO INTERNET twice. Pinging www.yahoo.com got me one return. Because I am using other equipment in my personal installation, I will roll back my installed router to TEST firmware and return the other one to COSTCO. Thank goodness for their return policies.

I work with routers every day in my course of business and enjoyed Netgear products for reasonable cost consumer installations for a long time. It is products tike these that make me money but makes me sad that companys sell this stuff as consumer installable.

 

I am on the hunt for another supplier. GOOD LUCK ALL. Bye

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 91 of 110
JohannesK
Aspirant

Re: R7900P Firmware 1.2.1.6 problem

I have the exact same issue. Was running 1.2 for 6 months with no issues. Upgraded to 1.4 and the router reset all my settings in the upgrade process. Now it behaves ok for ~2 days before start dropping traffic and needs to be rebooted. Into my 4th reboot cycle - it’s so predictable I can schedule reboot reminders into my calendar.

I have virtually no special settings (just a custom admin pwd and using a 10.x.x.x IP range internally instead of 192.168) but I am still pissed about the extra 15 min of configuration as both the Web and iOS app interfaces suck.

Anyone have a resolution to this yet? Where can I download a working older stable firmware?!
Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 92 of 110
Brooklynbummer
Aspirant

Re: R7900P Firmware 1.2.1.6 problem

Do not hold your breath for Net Gear to do a fix soon.  I went several months using older software and had no problems.  Decided to try again but installed older router, then installed mt 7900, updated to latest software version and went to a total reset.  For some reason, my 7900 has been running decently.  It may be just luck but previously had tried for months to get my router to work right.  


@JohannesK wrote:
I have the exact same issue. Was running 1.2 for 6 months with no issues. Upgraded to 1.4 and the router reset all my settings in the upgrade process. Now it behaves ok for ~2 days before start dropping traffic and needs to be rebooted. Into my 4th reboot cycle - it’s so predictable I can schedule reboot reminders into my calendar.

I have virtually no special settings (just a custom admin pwd and using a 10.x.x.x IP range internally instead of 192.168) but I am still pissed about the extra 15 min of configuration as both the Web and iOS app interfaces suck.

Anyone have a resolution to this yet? Where can I download a working older stable firmware?!

@JohannesK wrote:
I have the exact same issue. Was running 1.2 for 6 months with no issues. Upgraded to 1.4 and the router reset all my settings in the upgrade process. Now it behaves ok for ~2 days before start dropping traffic and needs to be rebooted. Into my 4th reboot cycle - it’s so predictable I can schedule reboot reminders into my calendar.

I have virtually no special settings (just a custom admin pwd and using a 10.x.x.x IP range internally instead of 192.168) but I am still pissed about the extra 15 min of configuration as both the Web and iOS app interfaces suck.

Anyone have a resolution to this yet? Where can I download a working older stable firmware?!

 

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 93 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem

In an effort to brighten up everyone's day, the latest Costco mailing (beginning June 28) has the Netgear router featured on sale.  From the picture and description,I suspect that it is the R7900P.   If you think that Customer Support was swamped before..........

 

I would be curious if and how Costco tracks product returns and if the R7900P shows a spike in return activity?

 

Message 94 of 110

Re: R7900P Firmware 1.2.1.6 problem


@JohannesK wrote:
I have the exact same issue. Was running 1.2 for 6 months with no issues. Upgraded to 1.4 and the router reset all my settings in the upgrade process. Now it behaves ok for ~2 days before start dropping traffic and needs to be rebooted. Into my 4th reboot cycle - it’s so predictable I can schedule reboot reminders into my calendar.

The router should not reset after a firmware flash, merely reboot. Maybe that reset was only partial, more a case of losing settings than a proper reset.

 

So I would try forcing your own factory reset. You have nothing to lose.

 


@JohannesK wrote:

I have virtually no special settings (just a custom admin pwd and using a 10.x.x.x IP range internally instead of 192.168)


 

Is there any reason why you don't have the default IP range? If this is how the router has configured itself, that can be a sign of a conflict on the network with your modem and that the modem is also a router. What is the model number of the  modem?

 

If this is the case, it can be useful to work out how to put the modem into modem only (bridge) mode.

 

Remember, when playing around with your network you should reboot it all in the right order.

 

Be sure to restart your network in this sequence:

 

  • Turn off and unplug the modem.
  • Turn off the modem router and computers.
  • Plug in the modem and turn it on. Wait 2 minutes.
  • Turn on the modem router and wait 2 minutes.
  • Turn on the computers.

 

 


@JohannesK wrote:
 Where can I download a working older stable firmware?!

 


There is a support for the R7900P, including a manual and older firmware, at the end of this link:

 

>>>> Nighthawk X6S R7900P | NETGEAR Support <<<<

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 95 of 110
Blanca_O
NETGEAR Moderator

Re: R7900P Firmware 1.2.1.6 problem

Hi All, 

 

A new firmware is available that believed to address the Internet connection or intermittent connection issue. Please update the firmware to 1.4.1.24. 

 

https://kb.netgear.com/000059558/R7900P-Firmware-Version-1-4-1-24

 

Regards,

Blanca  

Community Team

 

 

Message 96 of 110
Sbrkich
Aspirant

Re: R7900P Firmware 1.2.1.6 problem

I have updated to this and still the same drop issue every 2 to 3 days.  Returning to Costco and reverting back to my old AT&T Uverse wifi.  Never had the issue of having to reset all the time.  

Model: R7900P|Nighthawk X6S Smart WiFi Router with MU-MIMO
Message 97 of 110
steveofsd
Tutor

Re: R7900P Firmware 1.2.1.6 problem

I've been monitoring this thread since I purchased this router from Costco in 2017/11, I'm still running v1.1.4.6 as of today after I downgraded from 1.2.1.6 in 2017/12.

 

So it sounds like v1.4.1.24 still not good and solid like v1.1.4.6, OK...I'll wait for the next one or the next one until they get it right.

Message 98 of 110
natrlhy
Tutor

Re: R7900P Firmware 1.2.1.6 problem

I went with the Synology RT2600ac. I love the DSM/SRM interface and capabilites. SRM 1.2 has even better parental controls. And I'm getting the MR2200ac mesh router to fully cover my home. So glad I returned my Netgear router for the Synology RT2600ac

Message 99 of 110
tvbob
Apprentice

Re: R7900P Firmware 1.2.1.6 problem

I have been running 1.4.1.24 for over 60 days.  SOLID.  No issues.  Not sure what issues that you have had with the current version?    

Just as background, I have ben working with Netgear as a beta tester for almost a year and have gone thru all of the failure iterations.   This current version seems to be OK..

Message 100 of 110
Top Contributors
Discussion stats
Announcements