Reply

Re: R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

RedSevens
Guide

R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

Hi,

 

I have scoured the net trying to find a solution, but there seems to be no common solution. I upgraded my speed from 100/5 Mbps to now 400/10 Mbps. Did this yesterday.

 

For a while my speed was the same. After working with Xfinity, they said the tech forgot to push a file to my modem (i don't now; just saying what I was told). So the new tech pushed it through and then the speed increased to 470/12 Mbps... only if I'm connected with a cable.

 

The speed I'm getting on wifi is about 100 to 150 Mbps (and I am literally right next to the router while doing this testing.... regular use does not have me this close). Before the upgrade I was getting about 110-115 Mbps. 

 

I have done many hard resets, power cycles, reflashed the current firmware, disabled QoS (enabled and disabled it a few times, even after having it do a speed test and saving, then disabling it), uncheckmarked the WMM, enabled MIMO, enabled beam forming, cursed a lot, and nothing is working.

 

Is there something I'm missing doing? I am getting less than half the download speed that my hard wired connection is getting (470 vs around 110 to 150 Mbps).

 

I know I have had firmware issues with this router in the past (has been a while though). I have been able to work and fix past issues but this I just cannot figure out.

 

Help would be appreciated. 

 

Thank you! 

Model: R7900P|Nighthawk X6S AC3000 Tri Band WiFi Router
Message 1 of 11

Accepted Solutions
plemans
Guru

Re: R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

so your wired device is getting full speed. 

you didn't list much specs for the testing devices. 

What actual phone is it? 

What wireless chip is in the laptops you're testing in? (a 1x1 wireless card will perform at half the speed a 2x2 will)

 

 

If you're going to try a different firmware, the one I'd recommend for that router would be 1.4.1.42

Its the version prior to netgear armor. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->

View solution in original post

Message 6 of 11

All Replies
plemans
Guru

Re: R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

Are you testing over the 2.4ghz or the 5ghz?

Try disabling smart connect and test the 5ghz channels. 

what device are you speedtesting on? 

What website are you using for testing? 

 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 2 of 11
RedSevens
Guide

Re: R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

Hi Plemans,

Thank you for taking time to help!

Are you testing over the 2.4ghz or the 5ghz?
(Both. The 1 of 2.4 GHz bands and 2 of 5 GHz. The 5 GHz bands are getting the 100-150, but the 2.4 has been insanely bad even before the upgrade at about 35 GHz and that started about a year ago. The area I'm in got really congested with people using 2.4 GHz so I pretty much abandoned that one)

Try disabling smart connect and test the 5ghz channels.
(I'm not a fan of smart connect so that is always disabled... had so many problems with that early when I bought the router in early 2018)

what device are you speedtesting on?
(Speed test have been done on my cell phone and 2 different laptops, within about 4 ft from the router... not my usual distance but I try to test near routers to just make sure I have gotten rid of distance as a factor)

What website are you using for testing?
(various such as the Speedtest.Xfinity.com speed test site, fast com, and Ookla. My prior ISP package was 120 Mbps and my wifi speed on 5 GHz was about 112... But as of yesterday I upgraded to 400... And my speed is often hitting the same range of around 110 or rarely close to 150...)
Message 3 of 11
plemans
Guru

Re: R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

What actual modem do you have? 

What firmware version are you on? 

Try this. 

Factory reset the router 1 more time. During the reinstall, leave everything at the defaults. 

Once installed, test the hardwired speeds and then the 5ghz speeds. 

Report back what they are. 

 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 4 of 11
RedSevens
Guide

Re: R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

Hi Plemans,

Here's the info and thanks.

What actual modem do you have?
(Modem is Arris SB6183
https://www.surfboard.com/products/cable-modems/sb6183/ )

(Router is Netgear Nighthawk R7900P
https://www.netgear.com/support/product/R7900P.aspx )


What firmware version are you on?
(Netgear Firmware Version
V1.4.1.68_1.3.28 )

Try this.

Factory reset the router 1 more time. During the reinstall, leave everything at the defaults.

(Done. Tried two ways this time. 1 time with usual hard reset and also 1 time with the 30-30-30 method of hard reset.... But ended up with about the same results below... Did not adjust any settings from the defaults)

Once installed, test the hardwired speeds and then the 5ghz speeds.

(Hard wired speed is roughly 460 Mbps.
5Ghz_1 hit about 136 Mbps.
5Ghz_2 hit around 137 Mbps. So the 5ghz are roughly the same).
Message 5 of 11
plemans
Guru

Re: R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

so your wired device is getting full speed. 

you didn't list much specs for the testing devices. 

What actual phone is it? 

What wireless chip is in the laptops you're testing in? (a 1x1 wireless card will perform at half the speed a 2x2 will)

 

 

If you're going to try a different firmware, the one I'd recommend for that router would be 1.4.1.42

Its the version prior to netgear armor. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->

View solution in original post

Message 6 of 11
RedSevens
Guide

Re: R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

so your wired device is getting full speed.
(Correct)

you didn't list much specs for the testing devices.
(Good point. Something I totally didn't consider)

What actual phone is it?
(Moto G7 Power
https://motorola-global-portal.custhelp.com/app/answers/prod_answer_detail/a_id/137728 )

What wireless chip is in the laptops you're testing in? (a 1x1 wireless card will perform at half the speed a 2x2 will)

(The Surface Pro 2 has a Marvel 350N. I'm speculating that 350 means the max speed is 350... theoretical. I can't find any good info on the chipset on web searches. The manufacturer also has no info on it.

The Moto G7 Power cell phone link above shows the phone has a Snapdragon 632 chipset... From reading the below link I learned that the chip also does the WiFi.
https://www.qualcomm.com/products/snapdragon-632-mobile-platform
The below has the specs on the WiFi.
https://en.wikichip.org/wiki/qualcomm/snapdragon_600/632#Connectivity
WiFi
Integrated 802.11ac 2 x 2 with MU-MIMO
Peak Speed: 364 Mbps)

If you're going to try a different firmware, the one I'd recommend for that router would be 1.4.1.42

(Tried it per your recommendation, also with hard reset and no config tweaks, and no luck so I reflashed to the newest firmware).

Its the version prior to netgear armor.
Message 7 of 11
plemans
Guru

Re: R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

Not sure whats causing the wireless slow down. That router is capable of quite a bit more provided the devices can (from the sounds of it they should)

any chance you have an old gigabit router sitting around? 

You could try connecting that router to the modem and putting the r7900P in access point mode and testing it

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 8 of 11
RedSevens
Guide

Re: R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

Thank you so much. You got me thinking about chipsets of the devices I was using for testing. The 2 laptops are from around 2014. The Moto G Power phone is from around 2 or 3 years ago. My wife's phone is a newer and more capable Google Pixel 3A. Just finished trying my wife's phone and she's getting about 350 Mbps, which is what I would think the other devices should be getting.

My Nintendo Switch is getting some slow speed in the dock that is next to the router (around 50 Mbps). The 2 laptops and my Moto G Power are getting around 100-150 Mbps. So now I'm suspecting there is something not playing nice between some of the chipsets and the router.

I am not sure if there is a router setting that can be tweaked as a workaround (so I should keep trying the Router) or if each device needs some odd config tweaks since each has chipsets capable of far more speed than they're receiving (meaning I should be tackling device drivers or registry settings .... though there are no newer drivers for either laptop I'm using ... and the cell phones don't usually have wifi related updates ... though I'm not sure if there are any android config settings that can unlock or enable something that is for some reason off ... And about the Nintendo Switch that's a big I don't know haha).

If there's nothing left to try on the router configuration side then I guess this is for the most part resolved ... with an asterisk about possible router compatibility with specific chipsets.

I might have an old router laying around that I'd have to find, to try out, and might give that a try for the sake of just trying to see if the same result with the speeds on the devices. Off the top of my head I'm not sure of that router limitations on speed since it's older but is worth a try if it's above 400 Mbps.

Message 9 of 11
plemans
Guru

Re: R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

I think I usually warn people about, most devices don't need a lot of bandwidth. It only takes 25-40mbps for 4k streaming/gaming. 

the faster speeds are great for doing larger downloads but shouldn't impact streaming/gaming, etc. 

 

there really shouldn't be much for configuration changes other than disabling smart connect and optmizing what channel you're on. 

Some people believe in optimizing mtu but I've never seen much difference from stock. 

https://www.techrepublic.com/article/how-to-optimize-the-mtu-setting-on-your-router-for-better-perfo...

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 10 of 11
RedSevens
Guide

Re: R7900P - Upgraded Internet Package - Wifi Barely Improved or Same

Thank you for the responses.

I've not had a chance to find the spare old router. Though I've researched and tried and tried again my existing devices further. I'm pretty sure now it's the dated WiFi cards that are being used in the older devices that are bottlenecked or just bad drivers (like the complaints I see for the Marvell chipset in the Surface Pro 2 ... And similar for the Moto G7 Power), or slow device speed for unknown reasons (i.e. Nintendo Switch... heck I bought a USB to CAT connector to try and get fast speeds... and learned that many people get way under expected speeds or even slower than WiFi speeds... I got slower than WiFi...).

Thankfully my gaming laptop WiFi speed is proper after this experience, so that is a plus (about 425+ Mbps wireless or 460ish wired).

Lots of lessons learned. Thanks!
Message 11 of 11
Top Contributors
Discussion stats
  • 10 replies
  • 557 views
  • 4 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E