Reply
Highlighted
Aspirant

R7960P Speedtest Not Working

Hi. The speed test function in the NightHawk mobile app has stopped working for my R7960P router. When I try to run a speed test, it just says "connection failed. reboot your router." I have rebooted the router several times with no change. All of my network devices can get to the internet through the router, and I am able to access speedtest.net from devices on my network. Any ideas?

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 1 of 6
Highlighted

Re: R7960P Speedtest Not Working

What firmware version do you have on the R7960P device?

A number is more useful than "the latest". (It may not be by the time people read this.) There can also be newer versions, or "hot fixes", that do not show up if you check for new firmware in the browser interface.

It might also help if you told people what the modem is in front of this router, if there is one. The model number could be useful. Is it, by any chance, also a router, with a set of LAN ports on the back?

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 2 of 6
Highlighted
Aspirant

Re: R7960P Speedtest Not Working

Hi. The firmware on the router is

V1.4.1.50_1.3.10

 

It is sitting behind a Netgear CM1100 cable modem (which is not a router) running firmware 

V6.01.07

 

Thank you!

Model: R7900P|Nighthawk X6S AC3000 Tri Band WiFi Router
Message 3 of 6
Highlighted
Initiate

Re: R7960P Speedtest Not Working

I have the same issue now after my R7800 updated its firmware. It worked fine before that. I logged into the router and the speedtest works under  the Quality of Service tab. 

firware version V1.0.2.74

Message 4 of 6
Highlighted
Initiate

Re: R7960P Speedtest Not Working

I have the same router and firmware and I've been having the same exact issue since upgrading the firmware. I confirm that the speed test only works through the browser QoS.

Model: R7800|Nighthawk X4S AC2600 Wifi Router
Message 5 of 6
Highlighted

Re: R7960P Speedtest Not Working

This has been passed on to the Netgear tech team.

 

No idea when, or even if, they will fix the problem for the R7960P and the R7800, the two routers known, so far, to suffer from this disease.

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 266 views
  • 7 kudos
  • 4 in conversation
Announcements