Reply

R7960P upgrade from 1.4.1.50_1.3.10 does not work

Pebkac
Aspirant

R7960P upgrade from 1.4.1.50_1.3.10 does not work

My Nightwawk R7960P router display "upgrade available" message, but when I try to upgrade, nothing happens, the version stays at  1.4.1.50_1.3.10. So far I tried:

 

1. UI upgrade - it goes through reboot cycle and comes back with the same version as before.No error messages, just no upgrade happening.

2. Download the file and upload it through the UI - again, goes through the motions and at the end, nothing happened. 

3. TFTP route - TFTP does not connect, and it looks like the server is enabled only for a split second before going down again. 

4. Tried to factory-reset the router and try all the above - same luck, nothing happens. 

 

Any ideas how I could make my router upgrade? The release notes say there are security upgrades, so it makes me worry to run it un-upgraded. I could return it to the store and buy a newer model, which might work better, but I'd prefer to solve it on existing one if it's possible. 

 

Thanks!

Model: R7900|Nighthawk X6 AC3000 Tri-Band WiFi Router
Message 1 of 2
Pebkac
Aspirant

Re: R7960P upgrade from 1.4.1.50_1.3.10 does not work

Update for those who may find this in search: 

 

Talked to the Netgear support, they basically said "oh, we need to replace it", then since it was older than a year (bought it 1.5 years ago) they said "oh, too late, go away, you're on your own". So looks like it's a defective product which has no fix and Netgear has no solution for it and no intent to stand behind it. You have yourself to blame for being so easy a mark. Let it be my lesson for the future. 

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 135 views
  • 0 kudos
  • 1 in conversation
Announcements

Orbi WiFi 6E