R8000P Router won't save device settings


I have a R8000P router with the most recent firmware ( and quite a few devices connected.  There are two SAVE issues:


1) In order to identify devices I like to name them.  So, go to Advanced/Administration/Attached Devices, select a device, edit it, name it, and it appears to save in the list until you navigate to another page and come back.  The device type, device model, and device name are all editable, but do not persist with the values entered.  The same is true when you try to edit a device from Advanced/Security/Access Control.


2) This one is a big deal and extremely frustrating:  

I open an RDP port to a machine on my network so I can access it remotely.  In Advanced/Advanced Setup/Port Forwarding / Port Triggering, add a row to the Port Forwarding rules to pass requests on port 3389 to the machine required.  This will work for a short period of time but then spontaneously lose the setting.  But worse yet, it THINKS the rule still there because it won't allow you to enter it again (gives an error that a rule on that port exsists).  Yet there is no rule listed in the UI ... the grid is empty.  That forces me to create another incoming rule on some other port, and pass that request to the RDP machine on 3389.  But, after a while that one will also quit.  Sometimes after hours of use, and other times it might be a couple of weeks.  Again, that rule on that port cannot be re-entered because of an error that it already exists. How can I trust that I have access to a machine to work remotely with this kind of functionality (or lack thereof)??


Those issues and other disconnect issues, or problems finding devices on the network such as chromecast devices are so frustrating that I am tempted to sell this thing and go with another brand.   I really thought the firmware update would fix these nonsense errors but it has made it worse!  How can that be?   


Is anyone having the same probelm? Because this just isn't working the way it should and I can't rely on it.


Thanks for the help.




Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 1 of 8

Re: R8000P Router won't save device settings

   A settings reset (and manual reconfiguration) is worth a try.  No
bets, but it can resolve some kinds of scrambled settings.

Message 2 of 8

Re: R8000P Router won't save device settings

I've considered that.  Thanks for the suggestion.  I will give it a try and post back the results.


Message 3 of 8
NETGEAR Moderator

Re: R8000P Router won't save device settings

Hi lenardp, 


We’d greatly appreciate hearing your feedback letting us know if the information antinode provided has helped resolve your issue or if you need further assistance.


Community Team

Message 4 of 8

Re: R8000P Router won't save device settings


Hi there,

This response is later than anticipated but I didn't have a chance to test this option until a month ago and I wanted it to run for a few weeks to see how it turned out.


The result, at first, was positive.  I factory reset the router and upgraded the firmware to the latest version.  One by one I entered Access Control settings to block all devices and allow only specific ones.  This worked for the first 2 or 3 weeks but then started to exhibit undesired behavior again. 


For example.  The list of connected, allowed but not connected, and blocked devices, is simply wrong.  There are connections in the 'allowed but not connected' list that are clearly connected. 

- My alarm's panel has been connected for weeks and the router still doesn't recognize it as connected

- Other devices such as gaming consoles show up in the same unconnected list, yet have access to the internet

- When I change a device name to something I recognize, the name either doesn't save, or it saves then gets lost at a later date

- And most recently, and a deal breaker, when I select a row to edit in one of the Access Control lists, the WRONG ROW GETS EDITED.  Hence, I can no longer edit my devices because I get a random row ... 


And so on.  There are many more issues.  It is behaving as it was before in my original post. 


So, need another solution (different router perhaps?).  The frustration with this device is way to high, not to mention completely unnecessesary for something that costs $350.  I just can't rely on it.  If this is an isolated issue to me only, how do I approach netgear for a new device for something that was purchased back in January?


Any suggestions?




Message 5 of 8

Re: R8000P Router won't save device settings

Aaaaaand ... I rebooted the router today because devices couldn't connect, and it lost my port forwarding rules.  I try to re-add them, and it throws an error because it says that duplicate rules exist, yet they are not listed (the list is empty), nor does it run the rules that is says exist. 



I am at a loss.  



Message 6 of 8

Re: R8000P Router won't save device settings

I am having the exact same issues with my X6s. I change device settings and it will constantly reset. Ive factory reset 3 times to no avail and tried changing settings through (wired port) and through the genie app (wifi). Its very frustrating.
Message 7 of 8

Re: R8000P Router won't save device settings

Is the r8000p within the return window? If so return and get something else. Netgear, IMHO, has never put out a good firmware for this router. I sold my r8000p a couple of months ago after frustration with firmware issues. I am not sure they are ever going to the the firmware right for this router. 


To be honest I am seriously looking at Ubiqiti products. Have their Unifi Security Gateway in place acting as a router and gives lots of traffic stats. Support for PoE so that the AP's only need a Ethernet connection and everything is managed from a central manager, no logging into individual devices. Reviews are very positive. 

ISP Comcast, Modem-Netgear CM1150V, Router-Unifi Security Gateway-Pro4, AP-2 Unifi AP-LR
Tesla > Edison
Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 2 kudos
  • 5 in conversation