Reply

R800P WD 4TB drive not recognized

mlund74
Aspirant

R800P WD 4TB drive not recognized

So I had a NAS that died and switched to the Western Digital Easystore 4TB USB drive. It was in the USB2.0 port on the router and it worked for the most part. A couple of times when transfering large amount of pictures, it stopped working.  The router even locked up, i.e. the wireless didn't work anymore. I had to reboot the router. The other day, I was moving some videos over and it did it again. Everything lost wireless access except 1 computer.  I rebooted the R8000 and everything restored, but now the WD drive wasn't recognized. It seemed to work fine on a laptop.  But the router no longer recongnized the drive. When I plug it in, it starts up (the drive) and the light was on but the the router USB lights never turn on and it always says no USB attached. I updated the firmware to V1.4.1.30_1.2.26 and that didn't help. I got a new drive and it still didn't work. Rolled back to V1.4.1.24_1.2.20 and that still didn't help. I put a 16GB thumb flash drive into both the 2.0 and 3.0 ports and it worked fine.  So, I went back to 1.4.1.30 still no go. Looked at the list of drives and you can't buy the WD ones anymore. So, I got a 4TB MyBook since the My Book is on the list of approved drives and tried this morning. No go.  Doesn't even show up in the logs that I tried to attach a USB drive.  Does this thing just not like 4TB drives?  Is it the firmware?  Bought router in Nov 2017.

 

I have not factory defaulted my router.

Drive is exFAT formatted. I have not tried to reformat the drive to NTFS

Part # WDBBGB0040HBK-NESN

Model: R8000P|Nighthawk X6S—AC4000 Tri-Band WiFi Router
Message 1 of 3
IrvSp
Master

Re: R800P WD 4TB drive not recognized

@mlund74 , you have some different things happening here.

 

I've got an R8000 with a 2TB drive (WD My Book, new version) in the USB 2.0 port.

 

" I rebooted the R8000 and everything restored, but now the WD drive wasn't recognized. " (of course you meant R8000P).

 

I've hit this randomly. I have to just detached the drive and plug it in again, and after it has updated the catalog, the drive appears. I've on V1.0.4.28. I do not recall this being a problem on V1.0.4.18 though?

 

So for this I suspect the Router Firmware. However it seems you do rollback with no help.

 

Now onto the next part... as it could be the drive.

 

I do NOT think the Filesystem is as robust as a PC's would be. Hangs, power drops, and lockups might not be recovered. I've had that happen on  occasion and taking it to a Windows PC usually would indicate the drive needed to be checked. Once CHKDSK fixed problems taking it back to the router and it worked fine. However that drive continued to have problems, and causing lockups for me. Everytime I took it to the PC it needed to have CHKDSK run. A few weeks later that didn't even work. Drive problem.

 

Now onto the NEW MyBook. My 4TB MyBook is model WDBBGB0040HBK-NA. Same as your's (I assume the stuff after the - indicates where purchased, US for me, North America?). It works fine, NOW...

 

I had some BIG troubles with that drive. It is 'new' in that it is formatted when purchased for both the MAC and Windows. Worked will on my Dell, until I powered off the Dell. Next morning it would NOT boot! Since it was the only thing added to my PC I removed it and the Dell booted. Seems the Dell BIOS couldn't read the drive? Hmm... the format.... I put it back on the PC and it worked fine? Took it to the USB 3.0 port on my R7000 I had at the time. It was NEVER recognized? Back to the PC, saved the files off, reformatted it into NTFS, put the files back. Dell and the R7000 had NO problems with the drive.

 

I can't promise you this will fix it. I can't tell for sure the original drive was dead/dying either.

 

Filesystem seems 'picky' on drives, formats, number of partitions on drive, as to what works and what doesn't? Not seen one report of a drive over 4TB working either.

 

I'd suggest a reformat as I can tell you that 4TB I have formatted to NTFS works... and probably all routers have the same filesystem to some degree.

 

Message 2 of 3
mlund74
Aspirant

Re: R800P WD 4TB drive not recognized

Thank you for the Information. Yes, it's an R8000P.  

 

So, come to find out it's the router's issue.  Seems to be an issue with the USB ports and compatibility with drives.  Formatting the 4TB drive to NTFS didn't help. Although my old Asus router saw it just fine.  Now, I'll just pony up and get a NAS again.  I knew better than to buy a Netgear router! This will be the last one for sure!  Thing is 1 year, 2 months old!   P.O.S. in my opinion. 

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 688 views
  • 0 kudos
  • 2 in conversation
Announcements