Re: R8500 USB Hard drive disconnects from network regularly


R8500 USB Hard drive disconnects from network regularly

I've seen other posts with a similar problem for other model numbers but I figured I'd start one here for the R8500.


I have an R8500 with up to date firmware (V1.0.2.54_1.0.56) and an external USB 3.0 hard drive connected to the USB 3.0 port of the router.


I configured readyshare and made the HD available on the network. However, when I go to copy large amounts of files, the hard drive "disappears" from the network very regularly. Many times the copy times out telling me the network location is not available. 


I have tried copying from 2 different Windows 10 computers that are both connected to the router via gigabit lan connections (not Wifi) so this is not a wifi issue.


I am currently using a tool called "SyncToy" to try to copy my documents folder (8.4GB) from my PC to the HD and it gets maybe 50 files in, STOPS, if I go to windows explorer and under Network, the drive looks disonnected (X next to the name) and it's not accessible. Maybe 60 seconds to 2 minutes later, it reappears and my sync continues. 


The HD DID have the feature that when the computer went to sleep, the HD would automatically go to sleep, I thought originally that was the problem and the HD manufacturer gave me a firmware update to disable the sleep function. They told me their HD would go to sleep if they detected the USB connection from the PC (or router) was no longer live. The firmware successfully made the HD NOT ever go to sleep but the router is still "disconnecting" from the HD it seems or at least making it disappear from the network.


Model: R8500|Nighthawk X8 Tri-Band AC5300 WiFi Router
Message 1 of 2
NETGEAR Employee Retired

Re: R8500 USB Hard drive disconnects from network regularly

Hello @jducharme


Welcome to the community!


Let's try to isolate this further by using a different HD.

Use the same file size and see if you'll still get the same problem.

Also, another thing you may try is to use a different computer. Mapped the HD and try to transfer the files.

By the way, how do you copy documents? Just drag and drop when it's mapped or you're using a special feature on the HD?

What's the exact model of the HD?

NETGEAR Community Team
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 0 kudos
  • 2 in conversation