Discussion stats
  • 23 replies
  • 5990 views
  • 4 kudos
  • 5 in conversation
Announcements

Top Contributors
Reply
Highlighted
Star

R9000 VPN not working.

My VPN was working fine before I had the 2.4ghz channel stop sending a SSID. Restored router to original settings then setup the same way before. 2.4ghz is back but now VPN is not working. I re download the client.ovpn file for phone with no luck. Getting connection time out like OpenVPN is not running on router but everything is enabled.
Message 1 of 24

Accepted Solutions
Highlighted
Star

Re: R9000 VPN not working.

*******Update*********

Swapped router today for a new one and setup everything the same except Plex Media Server. VPN is now working perfectly on iPhone and no issues with 2.4ghz channel. Hopefully I will not have any issues with this unit. If I do I will change brands and not look back. Thanks for those of you who offered help.

View solution in original post

Message 23 of 24

All Replies
Highlighted
Star

Re: R9000 VPN not working on iPhone

Bumping this back up, spent hours trying to get this working on my iPhone. 

 

DynamicDNS Setup - Yes

OpenVPN Enabled - Yes

Tested on Mac with Tunnelblick and worked fine. 

 

Getting NotReachable error in log.

 

Message 2 of 24
Highlighted
NETGEAR Employee Retired

Re: R9000 VPN not working on iPhone

Tried reinstalling the firmware? 

If you did, I suggest that you contact support for them to log a case for you. 

ElaineM
NETGEAR Community Team
Message 3 of 24
Highlighted
Star

Re: R9000 VPN not working on iPhone

Not going to put up with it, going to go swap it out where I bought it since its only a few weeks old and already having issues. 

Message 4 of 24
Highlighted
Aspirant

Re: R9000 VPN not working on iPhone

I am having simiar issues and netgear support is really unresponsive i am planning to send mine back as well

 

case #27803851

Message 5 of 24
Highlighted
Guide

Re: R9000 VPN not working.

Just a quick thought, when you test VPN, you are turning off your Wifi on the iPhone right?  Just to make sure you are going over the cellular network only before you VPN into your router.

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 6 of 24
Highlighted
Star

Re: R9000 VPN not working.

Yes, wifi is off on phone. Installed the latest firmware with same result.
Message 7 of 24
Highlighted
Guide

Re: R9000 VPN not working.

Seems like you have done everything right on your side.

 

By chance, you don't have any conflicting port forwarding?  That's the last and only thing I can even think of.

 

Mine is working, but yes, i did initially have problems.  

Ohhh this reminds me of one thing...  how did you copy the file to the OpenVPN client?  Don't send through email.  Something goes wrong for me when I do that.

 

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 8 of 24
Highlighted
Guru

Re: R9000 VPN not working.


@TonyPHX wrote:

Ohhh this reminds me of one thing...  how did you copy the file to the OpenVPN client?  Don't send through email.  Something goes wrong for me when I do that.

 


For iOS (ipad) I combine the files in the netgear zip to a unified ovpn file.  I find that is easier.  If you google OpenVPN unified format you will find the information you need on the syntax.

 

I don't know why Netgear doesn't use the unified format.

Message 9 of 24
Highlighted
Guide

Re: R9000 VPN not working.

Yes, Sorry Stephen.  I should have been clear, I know how to move the files.  I should have just said, I suggest not emailing the indiviual files to the device.

 

Also, for the R9000, the smartphone is the unified opvn file that you retrieve from the router interface.

 

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 10 of 24
Highlighted
Guru

Re: R9000 VPN not working.


@TonyPHX wrote:

 

Also, for the R9000, the smartphone is the unified opvn file that you retrieve from the router interface.

 


Glad they changed that, but I wish they'd apply it to other Nighthawk routers.  I get a zip file when I download with separate files (ca.crt, client.crt, client.key, and client3.opvn).  It's a nuisance.

Message 11 of 24
Highlighted
Guide

Re: R9000 VPN not working.

Agreed.  That never made sense to me.

 

Incidentally, the unified opvn file is the only "generated" one that worked for me using Tunnelblick on Mac.  The others for windows and non-windows did not build a working package.  Thus why we see a lot of people say VPN isn't working for them on the R9000.  I did speak with Netgear support, and tried to help, but they concluded there is no problem.  : )

 

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 12 of 24
Highlighted
Star

Re: R9000 VPN not working.

I used a mac and pc to transfer the files to OpenVPN using iTunes with no change. This all started after I had to restore the router because of my 2.4 band not displaying an SSID on any of my devices. After that I set everything back up the same way I had it and re downloaded a new opvn file to my phone. I have tried changing ports, moving from auto, to internet and home, to home only and still no connection.

Here is the error I am getting in my log.

2016-12-22 17:20:12 NET WiFi:NotReachable/WR t------
2016-12-22 17:20:12 NET Internet:ReachableViaWWAN/WR t------
Message 13 of 24
Highlighted
Guide

Re: R9000 VPN not working.

By all means it seems like you did everything right, and it seems like you have thought to check everything.  I also think you are solid technically and my bet is you have found a bug in the router somewhere.

 

Just really stretching my feeble brain -

 

1.  you have had vpn working with other router models before right? 

2.  your isp is not blocking this type of inward traffic?

 

Don't take my questions to be that it's your issue.  I really think you have done everything right.  I had problems too that I still have a hard time explaining.  (And it is unreliable for me.)

 

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 14 of 24
Highlighted
Guru

Re: R9000 VPN not working.

One last thing you could try - delete openVPN from the iOS device altogether, and then reinstall it using the new opvn profile.

Message 15 of 24
Highlighted
Star

Re: R9000 VPN not working.

StephenB I also did that along with trying 10 different configs with different ports etc. I used to use VMware to run a OpenVPN access server on my desktop along with plex media server. I wanted an all in one solution is the reason I switched from a linksys ea9500. I have a theory that IPv6 routing maybe the cause of my headache as ATT has recently been deploying in their network. I have also tried using OpenDNS and Google DNS servers to rule out DNS conflicts.
Message 16 of 24
Highlighted
Guide

Re: R9000 VPN not working.

I think Hammer is who I want the next time I have to troubleshoot. : ) Good luck- I think you will figure it out. I am truly out of ideas.
Message 17 of 24
Highlighted
Guru

Re: R9000 VPN not working.


@Hammer68 wrote:
StephenB I also did that along with trying 10 different configs with different ports etc.

Frankly, I'm not surprised - you've been quite thorough.  I just threw it out there just in case.

 


@Hammer68 wrote:
 I have a theory that IPv6 routing maybe the cause of my headache as ATT has recently been deploying in their network. 

Could be.  

 

Does your router still have an ipv4 wan address?  Can you ping if over the internet using its ddns name?

 

 

Does Plex still work over the internet?  

Message 18 of 24
Highlighted
Star

Re: R9000 VPN not working.

StephenB,

 

Yes, my ISP has not upgraded to IPv6 yet, and I can ping my ddns name successfully.

Message 19 of 24
Highlighted
Guru

Re: R9000 VPN not working.

Maybe try some other service (open a port for an FTP server on the desktop perhaps), and see if that routes successfully.  If it does, it seems to me that would say that the internet routing to the R9000 isn't the issue.

Message 20 of 24
Highlighted
Star

Re: R9000 VPN not working.

My other thought is that something is not correct on the OpenVPN server side or the router is not correctly opening up the port for it. You can not manually add a port forward in to you routers ip so this has to be handled somewhere else. Of course we don't have access to manually change settings on the server side nor can we assign it as another IP address.

At this point troubleshooting any further would only waste more of my time. I realize things don't always work as they should and that we are all beta testers. You would think they would have engineers working this forum to find and fix issues with their product, especially when you pay a good chuck of change for it. I don't need to wait 6 months for a firmware fix when it could be address in a matter of weeks. It's sad to say other manufacturers are guilty of this same issue. I will probably stick with the R9000 as it has the strongest wifi signal of any router I have used. Hopefully swapping it out will resolve my VPN issue and I will move Plex over to my Nvidia Shield.
Message 21 of 24
Highlighted
Guide

Re: R9000 VPN not working.

Good points.  The weird thing of course is why it is only your router, since theoretically we all have the same firmware.     Looking forward to hearing if a swap does it or not.  

 

 

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 22 of 24
Highlighted
Star

Re: R9000 VPN not working.

*******Update*********

Swapped router today for a new one and setup everything the same except Plex Media Server. VPN is now working perfectly on iPhone and no issues with 2.4ghz channel. Hopefully I will not have any issues with this unit. If I do I will change brands and not look back. Thanks for those of you who offered help.

View solution in original post

Message 23 of 24
Highlighted
Guide

Re: R9000 VPN not working.

Excellent outcome!  Well, it shows that bad hardware can and does happen.  

 

I bet your heart skipped a beat when it connected followed by a "I knew it!"  : )

 

Nicely done. 

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 24 of 24