Reply

R9000 not syncing time behind Uverse GigaPower modem

CWafflesTX
Aspirant

R9000 not syncing time behind Uverse GigaPower modem

I am experiencing the exact same issue with the time and date not synching on my R9000 (using the latest firmware version V1.0.1.36) as outlined in this thread on the R8000 - https://community.netgear.com/t5/Nighthawk-WiFi-Routers/R8000-not-syncing-time-behind-Uverse-GigaPow...

 

I am also on UVerse with Gigapower and my Uverse router is the 5268AC (as outlined in the R8000 thread)

 

Is there any way for Netgear to address this issue for the R9000 as they did the with R8000?

 

Thanks!

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 1 of 35
TheEther
Guru

Re: R9000 not syncing time behind Uverse GigaPower modem

Point the DMZPlus feature on the 5268AC at your R9000.  This will bypass NAT on the 5268AC, which may be interfering with NTP.

Message 2 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

I've already put the R9000 in the DMZPlus.

 

This seems to be a known issue (as pointed out int he thread I linked to) and Netgear was able to address it with a different version of firmware.

Message 3 of 35
gfsiii
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

Just wondering if you have tried the beta fw for the R9000 that was just posted this month?

 

 

Message 4 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

Not yet.  Just got the router yesterday and noticed the beta firmware earlier today.  Was hoping someone from Netgear would respond to this thread and tell me if the beta firmware resolves the issue or if it would take another firmware.  I know the notes on the beta say I may have to factory reset the router if it starts acting weird and that kind of gave me pause at installing the beta firmware.

Message 5 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

I'm going to try and install the beta firmware today and see what happens.  Still hoping someone from Netgear see's this thread since this problem seems to have existed since the R7000 routers but people have been able to get the time issue address with a firmware patch directly from Netgear.

Message 6 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

Installed the beta firmware.  No change with the time problem as outlined in the link in my original post.

 

This is also causing issues with gettng Plex running.  It wont even download to install as I think it needs the correct time.  Every time I reset the router the time goes back to Wednesday, Dec 31, 1969 18:00:00  as its default.

 

Help! :-)

Message 7 of 35
schumaku
Guru

Re: R9000 not syncing time behind Uverse GigaPower modem

Can't help with more thna just a volatile setting. Access the R9000 debug page (ie. http://192.168.1.1/debug.htm), tick "Enable telnet", open a terminal wiht a telnet session and access the shell ... then set a date and a time

 

root@R9000:/# date --help
BusyBox v1.4.2 (2017-03-03 16:52:49 UTC) multi-call binary

Usage: date [OPTION]... [MMDDhhmm[[CC]YY][.ss]] [+FORMAT]


root@R9000:/# date 032722472017
Mon Mar 27 22:47:00 GMT 2017

 

...if you are in an experimental mood...

 

root@R9000:/#
root@R9000:/# /etc/init.d/ntpclient stop
Terminated
root@R9000:/#
root@R9000:/# /etc/init.d/ntpclient start
time zone index is : 1
Run NTP Client with setting: pri:time-g.netgear.com sec:time-h.netgear.com
root@R9000:/#
root@R9000:/# Smiley Sad ntpst - (offset 0x00040000 bytes in POT partition) one NTP Sync Timestamp existed: 16:18:58, Mar 25, 2017

 

...after a while, the ntpst does write an NTP sync timestamp into the POT partition in case there is nothing useful...

 

Now check the date and time is still fine...

 

root@R9000:/# date
Mon Mar 27 23:06:10 GMT 2017
root@R9000:/#
root@R9000:/# ntpst get
root@R9000:/#
root@R9000:/# Smiley Happy ntpst - (offset 0x00040000 bytes in POT partition) first NTP synchronized date/time: 16:18:58, Mar 25, 2017

 

 

 

Message 8 of 35
schumaku
Guru

Re: R9000 not syncing time behind Uverse GigaPower modem

In fact ... there seems to be some systematic issue wiht AT&T Uverse GigaPower modem -> https://forums.att.com/t5/AT-T-Fiber-Equipment/Pace-5268AC-in-DMZplus-blocks-UDP-123-NTP/td-p/501459... (as explained before in the community)

 

What I expect to see on starting the ntpclient might be something like this 

...

root@R9000:/# recvfrom: Connection refused
recvfrom: Connection refused
recvfrom: Connection refused

...

 

(FWIW ... I've forced the R9000 to use a custom simple NTP server (which does not exist))

 

The problem seems to be that this modem/router does not accept talking to an NTP server with a source port 123/UDP. No idea on how to change this by manipulating the nvram configuration. 

 

One day I might understand why developers not implement a darn standard ntpd instead of this ntpget or ntpclient *****.

Message 9 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

Correct, this problem is on AT&T's end and only if you are running on "Gigapower" (fiber).  Somehow, Netgear has been able to address this issue in previous verions of the Rx000 router as outlined here - https://community.netgear.com/t5/Nighthawk-WiFi-Routers/R8000-not-syncing-time-behind-Uverse-GigaPow...

 

What I am hoping is that Netgear will see this thread and issue me a firmware to address this issue as they have in the previous thread.  In the mean time, I'll at least try and telnet into the router itself to set the date and time which will be perfectly fine with me (until I have to reboot the router, of course).  We will see if this at least fixes my Plex issue until I have a chance to talk with Netgear directly.

Message 10 of 35
schumaku
Guru

Re: R9000 not syncing time behind Uverse GigaPower modem

@ElaineM ...can we have an update on this ... on how to configure a high, non-privileged port (>1024) optionally for the time service (or even better implement a fall-back if the standard 123/UDP does not succeeed because of the ISP are deplyoing **** poor CPE software?

Message 11 of 35
schumaku
Guru

Re: R9000 not syncing time behind Uverse GigaPower modem

Just dropped an email to the R9000 product manager ... let's see what is coming back,

Message 12 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

Thank you!

Message 13 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

So Plex not downloading is absolutely a problem relating to the NTP issue.  After manually setting the date based on your instructions, the router now shows the correct date and time.  But, when I plug the USB device into the router and go to the Plex Media Server setting, now I see "NTP time is not ready. Make sure that your Internet is ready."  So, manually setting the date and time does not resolve the Plex not downloading issue.  Apparently I need to actually be able to use NTP.  It will be interesting to see what Netgear says since they have seen and addressed this exact issue in their other Nighthawk routers.   I really appreciate all the assistance and you dropping an email to them.

 

 

Message 14 of 35
ElaineM
NETGEAR Employee Retired

Re: R9000 not syncing time behind Uverse GigaPower modem

@CWafflesTX One user reported getting that "NTP time is not ready..." and he mentioned that resetting the unit resolved that issue. 

ElaineM
NETGEAR Community Team
Message 15 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

@ElaineMI've reset the router at lest a dozen times already.  This is literally the same issue as outlined in this post - https://community.netgear.com/t5/Nighthawk-WiFi-Routers/R8000-not-syncing-time-behind-Uverse-GigaPow... and it is apparently a issue that you have been able to work around previously in reading that post.

Message 16 of 35
ElaineM
NETGEAR Employee Retired

Re: R9000 not syncing time behind Uverse GigaPower modem

Ok. I have escalated it to engineering. 

ElaineM
NETGEAR Community Team
Message 17 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

Awesome.  Thank you!!!  Hope they can resolve this for me!

Message 18 of 35
schumaku
Guru

Re: R9000 not syncing time behind Uverse GigaPower modem

...you can even consider to run the ntpclient (not used on the Nighthawk, but ususally in place, ...) to set and sync the clock:

 

root@R9000:/# ntpclient -?
ntpclient: invalid option -- ?
Usage: ntpclient -h hostname [-b second_hostname]
[-i min_interval -m max_interval (0<=min_interval<=max_interval)]
[-c count] [-p local_port] [-d] [-s]

 

ntpclient -h "time-g.netgear.com" -b "time-h.netgear.com" -i 60 -m 480 -p 1234 -s

 

This will start it as a service, and the time will be synched between avery one and four hours from the very same NTP servers - but using a different source port (1234 in my example). 

Message 19 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

@schumakuSo If I try the steps you outlined above, and by chance they work, then in the router, I would go to the NTP settings and put in the router IP address as the server to get the time from?

 

And in the event I needed to stop this for whatever reason (say if Netgear gets me a fix) how would I stop this service?

 

Thanks!

Message 20 of 35
schumaku
Guru

Re: R9000 not syncing time behind Uverse GigaPower modem

Each launch of the ntpclinet will create a new process. A reboot will get rid of them. If you play around, subseuent processes attempting to use the same port will spill an error to the console.

 

ps | ntpclient

 

...will issue a list of processes

 

root@R9000:/# ps | grep ntpclient
15036 root 224 S ntpclient -h time-g.netgear.com -b time-h.netgear.com
16018 root 224 S ntpclient -h time-g.netgear.com -b time-h.netgear.com

 

You can safely kill them individually using the PID - this is the first number to the left:

 

root@R9000:/# ps | grep ntpcli
15036 root 224 S ntpclient -h time-g.netgear.com -b time-h.netgear.com
16018 root 224 S ntpclient -h time-g.netgear.com -b time-h.netgear.com
16927 root 112 S grep ntpcli
root@R9000:/#
root@R9000:/# kill 15036
root@R9000:/#
root@R9000:/# ps | grep ntpcli
16018 root 224 S ntpclient -h time-g.netgear.com -b time-h.netgear.com
25002 root 112 S grep ntpcli
root@R9000:/#
root@R9000:/# kill 16018

 

Aside, you can run the ntpclient with the debug flag, - this will not create a process:

 

root@R9000:/# ntpclient -h time-g.netgear.com -b time-h.netgear.com -d -s
Configuration:
-c probe_count 1
-d (debug) 1
-h hostname time-g.netgear.com
-b second hostname time-h.netgear.com
-i interval(min) 15
-m interval(max) 15
-p local_port 0
-s set_clock 1
Configuration:
Probe count 1
Debug 1
NTP server time-g.netgear.com
Interval 15
Local port 0
Set clock 1
Listening...
Sending ...
packet of length 48 received
Source: INET Port 123 host 209.249.181.21
set time to 1490784842.921567
LI=0 VN=3 Mode=4 Stratum=3 Poll=4 Precision=-23
Delay=41534.4 Dispersion=5538.9 Refid=169.254.0.1
Reference 3699773585.0475237741
Originate 3699773642.3258540139
Receive 3699773642.3957666075
Transmit 3699773642.3958162757
Our recv 3699773642.3957309842
Total elapsed: 162695.00
Server stall: 115.64
Slop: 162579.36
Skew: 81488.26
Frequency: 0
day second elapsed stall skew dispersion freq
57841 39242.921 162695.0 115.6 81488.3 5538.9 0
Smiley Sad ntpst - (offset 0x00040000 bytes in POT partition) one NTP Sync Timestamp existed: 16:18:58, Mar 25, 2017

 

Bet this could give some more insight if it does not work...

Message 21 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

Well holy smokes!  The command you suggested I use - "ntpclient -h "time-g.netgear.com" -b "time-h.netgear.com" -i 60 -m 480 -p 1234 -s" works perfectly.  It set the date and time in the router and now Plex realizes there is a valid, working NTP server and I can actually launch it. Smiley Happy

 

I can only assume that this is how Netgear's engineer's have resolved this issues for others (making it stick so it wont go away after a reboot) so I am hopeful they will issue me a patch to address this since @ElaineM sent this on to engineering. 

Message 22 of 35
schumaku
Guru

Re: R9000 not syncing time behind Uverse GigaPower modem

The key is not using the NTP default port as a source port - because the **** at your (and probably one more one in Sweden) ISP does block 123/UDP outgoing for whatever **** reason. Give a try to a debug run (it won't hurt the other process) on the default port, and you will see:

 

 

root@R9000:/# ntpclient -h time-g.netgear.com -b time-h.netgear.com -d -s

 

Now, for whaever reason, Netgear or their ODM does not make use uf the ntpcliend daemon itself.

 

Please note: This test idea was not grown on my tree - it's much more a collection of more or less vague information here and on some ISP and ATT fora. Considering on how long Netgear has to address this ... and think about there are many different routers requiring an update or a smart enhancement (that would be probing a random high USB port if the standard 123/UDP does fail) ... coding effort some minutes. 

Message 23 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

Cannot tell you @schumaku how much I appreciate all of the info and a fix that will at least hold me over until I or @ElaineM hear back from engineering.  In looking over the forums, I can see where this was also an issue for people using the R7000 and R8000 on U-Verse Gigapower (fiber) with the Rx000 in DMZPlus mode on the AT&T router.  Nobody else had a work around like you came up with, they just had to wait for Netgear to issue them a patch to install to resolve the issue.  At least this "band-aid" fix that I have allows me to use all of the features of my router since it now has a working NTP server.  I'm fine with having to telnet back into the router after a reboot to redo that command until Netgear fixes it (which hopefully will only be a matter of days like ti was in previous threads).

 

Thanks again!!

Message 24 of 35
CWafflesTX
Aspirant

Re: R9000 not syncing time behind Uverse GigaPower modem

Just pinging @ElaineM on this to see if there is any information from engineering yet.  @schumaku fix works for the time being, but I have to redo it any time the router restarts.

 

Thanks!

Message 25 of 35
Discussion stats
  • 34 replies
  • 4975 views
  • 8 kudos
  • 7 in conversation
Announcements