Reply

Remote Desktop Connections

Coolmankimo
Aspirant

Remote Desktop Connections

I'm trying to figure out if Netgear provides a way to set up remote desktop to my home PC while I'm away?
If so how would I go around doing it?
Model: R6800|Nighthawk AC1900 Smart WiFi Router
Message 1 of 8

Re: Remote Desktop Connections

What are you trying to achieve? File access? Remote control?

 

There is a manual for the R6800 somewhere at the end of this link:

 

R6800 | Product | Support | NETGEAR

 

You can see what you can do by investigating Remote Access.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 2 of 8
antinode
Guru

Re: Remote Desktop Connections

> I'm trying to figure out if Netgear provides a way to set up remote
> desktop to my home PC while I'm away?
> If so how would I go around doing it?

   One way would be to configure port forwarding on the router
(Netgear's or anyone else's).  You'd need to:

   0. Decide on an external port number, and collect some information.
   1. Fix the IP address of your target Windows system.
   2. Configure a suitable port-forwarding rule.
   3. Test.

   I would:

   0.1.  Decide which external port number you wish to use.  The default
for Remote Desktop Protocol would be 3389, but you might see fewer
break-in attempts if you choose some other number, like, say, 5389 or
13389 (or almost anything else).  If you choose a port other than 3389,
then you'll need to specify this external port number along with your
external IP address when you configure your Remote Desktop client
connection.

   0.2.  In the router's web-browser interface, go to BASIC > Attached
Devices, and find your target Windows system.  Record its MAC address.

   The port-forwarding rule contains the IP address of the target
Windows system, so that address must be fixed.

   1.1.  Shrink the DHCP address pool, to leave some addresses outside
the pool.  Go to ADVANCED > Setup > LAN Setup, and change the DHCP pool
range ("Starting IP Address", "Ending IP Address") from the usual
default range of ".2" - ".254" to some smaller range, like, say,
".2" - ".199".  This ensures that the DHCP server won't accidentally
issue an address from the ".200" - ".254" range to some random client
device.

   1.2.  Reserve one of these non-pool addresses (your choice) for your
target Windows system.  ADVANCED > Setup > LAN Setup : Address
Reservation.  You'll need the MAC address of that system (recorded
above).

   2.1.  Add the port-forwarding rule.  ADVANCED > Advanced Setup > Port
Forwarding / Port Triggering : Add Custom Service.  Define a new rule
("Service") for this service.  Specify the desired external port number
("External port range"), the internal port number ("Internal port
range", presumably 3389), and the (reserved) IP address for your target
Windows system.  (If you're not using the same port number for external
and internal, then uncheck the "Use the same port range [...]" box.)
Apply the port-forwarding rule, and the router should be happy.

   3.1.  Restart the target Windows system.  When it comes up, it should
have its new, reserved IP address.  Check the BASIC > Attached Devices
report.  Alternatively, open Windoes a Command Prompt (CMD.EXE) window,
and run an "ipconfig" command.  The "IPv4 Address" should be the new,
reserved address.

   3.2.  Try a Remote Desktop client connection from some system on your
LAN to a "PC name [Host name or IP address]" like
"<your_target_Windows_system_LAN_IP_address>" or
"<your_target_Windows_system_LAN_IP_address>:3389".  Such a local
connection doesn't use the port forwarding.  If that doesn't work, then
a connection which does use port forwarding doesn't have much of a
chance.

   3.3.  Try a Remote Desktop client connection from some system on your
LAN to a "PC name [Host name or IP address]" like
"<your_external_IP_address>:<your_external_port_number>".  That uses the
"NAT loopback" feature of your router and the port-forwarding rule.

   3.4.  Finally, try a Remote Desktop client connection from some
system in the outside world to a "PC name [Host name or IP address]"
like "<your_external_IP_address>:<your_external_port_number>".

   What could go wrong?

   Of course, you'll need to know your router's external (public) IP
address.  If your ISP changes that address from time to time, then you
may want to configure dynamic DNS to make it easier to find.  There's a
section in the R6800 User Manual on that ("Manage Dynamic DNS and Access
Storage Devices Through the Internet").

Message 3 of 8
Blanca_O
NETGEAR Moderator

Re: Remote Desktop Connections

Hi Coolmankimo, 

 

We’d greatly appreciate hearing your feedback letting us know if the information provided has helped resolve your issue or if you need further assistance.

 

Regards, 
Blanca 
Community Team
 

Message 4 of 8
ryanjbow
Aspirant

Re: Remote Desktop Connections

Thanks for this detailed explanation. I found this while troubleshooting an RDP setup on my C6300. I've done all the steps and double-checked. I've done this before successfully with an Asus router and ATTT router so I'm familiar with the process.

 

I am able to connect within the LAN but I cannot connect from outside the network with the public IP. I also setup a dynamic DNS name and tested that. I am using port forwarding and believe that is setup correctly. I'm using #### as the external port and 3389 as the internal and using [public ip/domain]:#### to connect but it keeps giving an error.

 

To be clear, I am able to connect according to item 3.2 in your instructions by doing <your_target_Windows_system_LAN_IP_address>:#### but I cannot connect with 3.3 or 3.4 in your instructions which is what I would need to connect from another network.

 

Any other settings I may be missing? I tried disabling AVG virus as well but no luck.

Message 5 of 8
antinode
Guru

Re: Remote Desktop Connections

> [...] I've done all the steps and double-checked. [...]

   You may think that that conveys some useful information, but you're
wrong.

> [...] I also setup a dynamic DNS name and tested that. [...]

   You "tested" _what_, exactly, how exactly?  Does the DDNS name get
resolved to your external (public) IP address?  That would be nice, but
you can test the port forwarding using the external (public) IP address,
whether or not any DDNS stuff works.

> [...] I am using port forwarding and believe that is setup correctly.
> [...]

   With my weak psychic powers, I can't see all the significant data in
your port-forwarding rule, or your server's LAN IP address, or any of
what you believe to be your external (public) IP address (the first two
octets of which would be more helpful than nothing), or any of what the
router says that its WAN/Internet IP address is (where, again, the top
half would be more helpful than nothing).  So, I really have no idea if
any of those missing data are reasonable.  "3389" sounds reasonable.
Otherwise, copy+paste is your friend.

> [...] but it keeps giving an error.

   What might that "an error" be?

> Any other settings I may be missing?

   Based solely on "####" and "3389", how would I (or anyone else) know?

> [...] I tried disabling AVG virus as well but no luck.

   If you could reach the server from the LAN, then that's not amazing.

   I've never touched a C6300 (firmware version?), so I can't say from
my own experience that its port forwarding works, but about all that I

can say about what you did is that: "3389" sounds reasonable.

Message 6 of 8
ryanjbow
Aspirant

Re: Remote Desktop Connections

 

Sounds like you need to call it a day 🙂

 

I figured out my issue. I forgot that I changed my listening port from 3389 to something else years ago. So since I was port forwarding to 3389 it wasn't working.

Message 7 of 8
antinode
Guru

Re: Remote Desktop Connections

> [...] I forgot that I changed my listening port from 3389 to something
> else years ago. [...]

   And yet:

> I am able to connect within the LAN [...]

   To me, that suggests that you must have been specifying the proper
port number when that worked.  But, with my weak psychic powers, all I
have to guide me is what you actually report.  Relying on your readers
to assume correctly the crucial information which you omit can waste
everyone's time and effort.  In many cases, simply providing an
accurate, detailed description of what you did, and what happened when
you did it, will show you what you're doing wrong without actually
needing to post a question.

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 8686 views
  • 2 kudos
  • 5 in conversation
Announcements

Orbi WiFi 6E