Reply

Remote Desktop Setup

kylesouza
Luminary

Remote Desktop Setup

I would like to setup my network so that the amchien with IP address 192.168.1.40 can be accessed with a static IP provided by my ISP, let's call that one 50.149.12.741.  On my last router (a sonicwall) there was a way to tell the router that an RDP request (either on our LAN or from an outside computer) to 50.149.12.741 should be routed to 192.168.1.40; but I cannot find how to do that one this Nighthawk R7000.  Is this type of setup possible with the router I've chosen?

Message 1 of 5

Accepted Solutions
TheEther
Guru

Re: Remote Desktop Setup

You can't set the external address. It is implicitly assumed to be the IP address of R7000's WAN port.

If your R7000's WAN port address is not 50.149.12.741 (BTW, this is not a valid IP address, but I know you were using it as an example), then your modem is doubling as a router. If possible, put your modem into bridge mode. This will move the ISP IP address to your R7000, which will use it as the external address and you should be good to go.

If you are unable to enable bridge mode on the modem, then you may have to set up a separate port forward on your modem. The port forwarding rule on the modem would point to the R7000's WAN IP address. In effect, the modem will forward all RDP traffic to the R7000. In turn, the R7000 will forward it to the internal machine. If you are lucky, this will simply work, but it's not ideal. If you want to know why, do a web search on "double NAT".

View solution in original post

Message 4 of 5

All Replies
TheEther
Guru

Re: Remote Desktop Setup

Log into the R7000 and go to Advanced > Advanced Setup > Port Forwarding. Then click on Add Custom Service.

The default port for RDP is 3389 but double check that the machine at 192.168.1.40 is listening on that port. If so, enter that port number as the internal port number. Use the same port number as the external port, or change it if you don't want to make it do obvious that you have an RDP server on your home network.

Enter 192.168.1.40 as the Internal IP address and click Apply to save.

Message 2 of 5
kylesouza
Luminary

Re: Remote Desktop Setup

Thank you for te quick response!  I've tried that, but I see nowhere to enter in the IP adress for external access.  Where do I tell it what 50.149.12.741 "means"?  I also have more than one computer I'd like to do this with - with different external static IPs.

Message 3 of 5
TheEther
Guru

Re: Remote Desktop Setup

You can't set the external address. It is implicitly assumed to be the IP address of R7000's WAN port.

If your R7000's WAN port address is not 50.149.12.741 (BTW, this is not a valid IP address, but I know you were using it as an example), then your modem is doubling as a router. If possible, put your modem into bridge mode. This will move the ISP IP address to your R7000, which will use it as the external address and you should be good to go.

If you are unable to enable bridge mode on the modem, then you may have to set up a separate port forward on your modem. The port forwarding rule on the modem would point to the R7000's WAN IP address. In effect, the modem will forward all RDP traffic to the R7000. In turn, the R7000 will forward it to the internal machine. If you are lucky, this will simply work, but it's not ideal. If you want to know why, do a web search on "double NAT".
Message 4 of 5
kylesouza
Luminary

Re: Remote Desktop Setup

Thank you, that makes sense.

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 25361 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi WiFi 6E