Reply

Re: Slow internet when connected to Wifi

R2dTOO
Luminary

Slow internet when connected to Wifi

I just got AT&T 1000Mbps fiber internet, as well as an R7000 Nighthawk router. The AT&T RG is in passthrough mode, and the Nighthawk is in router mode. Nighthawk is running firmware version 1.0.9.60_10.2.60. 

 

When I connect my laptop via ethernet to the Nighthawks, I'm getting 900Mbps or higher download. However, when i connect via wifi, I'm luck if I break 100Mbps (usually, it's in the 60s). The only think I've changed from the efault Netgear setup is I did enable Smart Connect.

 

Does anyone know what I can do to fix this?

 

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 1 of 14

Accepted Solutions
R2dTOO
Luminary

Re: Slow internet when connected to Wifi

OK. I think I have solved the problem. Here is what I did:

 

  1. I got rid of the AT&T Gateway. It's now just the Nighthawk connected to the AT&T ONT via a switch in the middle. Instructions here if anyone is interested.
  2. After getting rid of the gateway, I factory reset the router again. I set the SSIDs up again, changed the 2.4GHz and 5GHz channels from "Auto" and whatever the default 5GHz channel was to "06" and "161" (looking at a wifi analyzer, revealed that channel 6 was the least congested in my area for 2.4GHz. Channel 161 was not used at all in the 5GHz spectrum).

After doing both of these things, I am now getting between 350Mbps and 525Mbps on the 5GHz network.

 

I had done step 2, with the gateway in place, several times before. I think the combination of the two together is what solved my issue. 

 

Thank you everyone for the help.

 

View solution in original post

Message 14 of 14

All Replies
microchip8
Master

Re: Slow internet when connected to Wifi

Disable smart connect, lots of issues with it

 

on which band are you testing? 2.4 or 5 GHz?

Routing: NETGEAR RAX43 - Firmware: V1.0.11.112 (1 Gbps down, 50 Mbps up)
Switching: 2x NETGEAR 8-ports (GS108v4) / 1x NETGEAR 16-ports (JGS516v2)
Desktop: AMD Ryzen 7 3700X - Server: Intel Core i7-7700K - NAS: Intel Pentium G4400, 20 TB
Message 2 of 14
IrvSp
Master

Re: Slow internet when connected to Wifi

Besides turning off Smart Connect, did you ever have faster wireless speeds? If so, how fast, on what device and what band?

 

What was your ISP speed before? 100Mbps or slower? Did/do you have QoS enabled? If so, turn it off.

Message 3 of 14
R2dTOO
Luminary

Re: Slow internet when connected to Wifi

OK. I disabled Smart Connect, and speeds went up a little. I'm now getting around 150-175. I'm testing from both my phone (Samsung Galaxy S9), and my laptop. Before I put the Router in place, and just tested with the AT&T gateway, I would get 400-500+ on wireless.
Message 4 of 14
IrvSp
Master

Re: Slow internet when connected to Wifi

Are you running two wireless networks???

 

Define what you mean by " just tested with the AT&T gateway"?

Message 5 of 14
R2dTOO
Luminary

Re: Slow internet when connected to Wifi

No. I only have one wireless network running. The AT&T Gateway has wireless built in to it. When I first got the service, I do not have the Nighthawk. So, I ran on the AT&T wireless for a couple of days until the Netgear got here from Amazon. One I installed the router I turned off wireless kn the gateway.
Message 6 of 14
sktn77a
Virtuoso

Re: Slow internet when connected to Wifi

The 400-500mbps is the fastet you'll get on WiFi.  Don't know why the netgear is so slow.  Try a factory reset.  Then check speeds without security and then with security (dont change any other settings).  If that doesn't work, try downgrading the firmware to v042.  If you're still only getting 100mbps, send it back, something is wrong.

Keith

(3xWNCE2001, FS116, GS116, 6xR7000, EX7000, EX6400)
Message 7 of 14
IrvSp
Master

Re: Slow internet when connected to Wifi

Do you have a wired device you can check with? What about the SPEED TEST on the QoS page, what does that show?

 

Did you turn off the modem before connecting the router, then power up in sequence the modem and once fully up the router?

Message 8 of 14
R2dTOO
Luminary

Re: Slow internet when connected to Wifi

Here are speed tests from my laptop. The first is wired. The second is wireless (connected to 5G).  I also downgraded the firmware to V1.0.9.42_10.2.44.

 

WiredWiredWirelessWireless

 

 

Message 9 of 14
R2dTOO
Luminary

Re: Slow internet when connected to Wifi

Also, when I do a speed test from the Nighthawk app, the download number keeps resteeting itself. It never goes to upload. Here's a video:

https://youtu.be/C73clHY__kw
Message 10 of 14
IrvSp
Master

Re: Slow internet when connected to Wifi

When you reset the f/w to V1.0.9.42 did you actually RESET the router and MANUALLY reentered all settings?

 

The video seems normal on d/l side. Mine does 14 (maybe 15) repeats and when done it does pop out an upload number.

 

Suspect it had a reason not to display that?

 

A 'reset' is not a power cycle, but using the recessed button in the back. Use a pen, paper clip, or the thin object to depress it and hold it for about 30 seconds WITH the power on. LED's should start flashing. Once released the router will reboot with setting erased. Then reenter your settings (userID and PW may reset to default values). Can also do that using the router GUI in a browser on the BACKUP SETTINGS page using the ERASE button.

 

That could possibly fix it.

Message 11 of 14
R2dTOO
Luminary

Re: Slow internet when connected to Wifi

Yes. I did a factory reset.
Message 12 of 14
IrvSp
Master

Re: Slow internet when connected to Wifi

Last question/guess?

 

When you connected to the modem Wif and the Router Wifi, do you use the SAME SSID? If so, forget the network on the device and connect again.

 

 

Message 13 of 14
R2dTOO
Luminary

Re: Slow internet when connected to Wifi

OK. I think I have solved the problem. Here is what I did:

 

  1. I got rid of the AT&T Gateway. It's now just the Nighthawk connected to the AT&T ONT via a switch in the middle. Instructions here if anyone is interested.
  2. After getting rid of the gateway, I factory reset the router again. I set the SSIDs up again, changed the 2.4GHz and 5GHz channels from "Auto" and whatever the default 5GHz channel was to "06" and "161" (looking at a wifi analyzer, revealed that channel 6 was the least congested in my area for 2.4GHz. Channel 161 was not used at all in the 5GHz spectrum).

After doing both of these things, I am now getting between 350Mbps and 525Mbps on the 5GHz network.

 

I had done step 2, with the gateway in place, several times before. I think the combination of the two together is what solved my issue. 

 

Thank you everyone for the help.

 

Message 14 of 14
Top Contributors
Discussion stats
  • 13 replies
  • 56253 views
  • 2 kudos
  • 4 in conversation
Announcements

Orbi WiFi 6E