Reply

Slow wireless speeds

nhgrumpy
Aspirant

Slow wireless speeds

I am about to throw this in the river and try another brand.

I have a R7000 for a router with a netgear adsl2+ modem.

When I am hard wired to the modem I get 12-15mpbs for download speed according to speedtest.net. When I go wireless I get .19 to 2.3.

Signal strength is 5 bars. Doesn't matter which laptop or pc I use I get the same results.

I figure it is in the router settings somewhere.

Anyone have any advice on what to try?

Thanks

PS my old modem and router was leased from my dsl company and it worked fine. I was just tired of adding to my monthly bill.
Message 1 of 10
jmizoguchi
Virtuoso

Re: Slow wireless speeds

Did you test PC wired to the router and speed is fine?
VPN Case Study

VPNCASESTUDY.COM

"Our Second To None VPN Related Setup Case Study[/COLOR][/URL]

"One Stop Solution To Your Netgear VPN Connectivity"

*Visit the site for Non-VPN related Doc & Links* [Windows & Mac user/support]





June Mizoguchi-
Message 2 of 10
nhgrumpy
Aspirant

Re: Slow wireless speeds

yes. After playing around with different settings I think I figured it out. I changed the Fragmentation Length (256-2346) and CTS/RTS Threshold (1-2347) both to 2304. I am now getting 13 down wireless and 15 down wired
Message 3 of 10
Redtulips7
Apprentice

Re: Slow wireless speeds

Sometime changing Channel makes a difference...
Nighthawk AX12[RAX120]
Nighthawk X10[R9000]
Message 4 of 10
bobcageon
Guide

Re: Slow wireless speeds

You're on ADSL so I would look at your MTU setting in ADVANCED > SETUP > WAN SETUP & change 1500 to 1492. That is usually what most ADSL isp's advise for router settings. You should see snappier web page loads and over all throughput. While you re there, Disable SIP ALG & select OPEN under NAT Filtering. I disable port scan & dos protection as well to maximize speed throughput.
Message 5 of 10
bobcageon
Guide

Re: Slow wireless speeds

So anyways default v1.0.3.60 firmware, on 30/10 cable isp using: Settings stock, unless: 2.4ghz band, Channel: auto Mode: up to 600 Short Preamble selected Enable 20/40 MHz Coexistence is unchecked http://www.speedtest.net/my-result/a/883291629
Message 6 of 10
RogerSC
Virtuoso

Re: Slow wireless speeds

bobcageon wrote:

2.4ghz band,
Channel: auto
Mode: up to 600
Short Preamble selected
Enable 20/40 MHz Coexistence is unchecked



You got to be careful with that 20/40 MHz Coexistence thing. If you leave it unchecked, you may find it switching back and forth between 20MHz. and 40MHz. channel width if you're in an area that has at least a few competing wireless networks. If it really forces 40MHz. channel width in an are with several other neighboring networks, they may get upset with you for taking up half the 2.4GHz. band *smile*.

If you leave it checked, yes, your maximum speed will be lower, but operation will be more stable and friendly *smile*.
Message 7 of 10
bobcageon
Guide

Re: Slow wireless speeds

Please continue to chime in b/c I can't believe how well versed and friendly you are with this router, networking, and the individual settings. It's always a benefit to know the breadth of any situation & I, and certainly others, appreciate it. I'm going to read up on this signal hogging. I'm really sure exactly why my neighbors would be affected.
Message 8 of 10
Retired_Member
Not applicable

Re: Slow wireless speeds

I believe most find the dual 40mhz option over time to be problematic and eventually disable it due to neighboring routers.
Message 9 of 10
Retired_Member
Not applicable

Re: Slow wireless speeds

Yeah, you should really only use 40Mhz in the 2.4Ghz band if you have ZERO neighbors.
Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 31944 views
  • 0 kudos
  • 7 in conversation
Announcements

Orbi WiFi 6E