Reply

Smartconnect difficulties

FirestormX
Tutor

Smartconnect difficulties

So I didn't see any recent topics on this.. so I'm curious if my experience is typical.  I have an R8000 X6 router; it's several years old and out of warranty, and the most expensive router I've purchased by far.  The firmware is up to date and otherwise works fine.  A few days ago I enabled Smartconnect and it's just not working well.

 

In most circumstances, my devices insist on connecting to the 2.4 Ghz radio, even AC clients 3 feet from the router (including Chromebook and smartphones).  Since enabling smartconnect, I've started getting random connectivity drops on all sorts of different devices like Windows 10 and MacOS laptops.  I have one Macbook Pro (wireless n) that worked albiet with occassional drops, and today refuses to connect at all.

 

This feature is.. terrible.  I'm about to throw in the towel.

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 1 of 8
schumaku
Guru

Re: Smartconnect difficulties

Can only talk for non-Broadcom Netgear routers (like the R9000) with Smart Connect: Works top solid and as expected! It's in fact the smallest subset of what every business wireless AP can do.

 

The Macbook Pro does only support 11n? Check this: Hold down the Option key, click on the Apple menu, choose "System Information" -> Network -> Wi-Fi ... scroll through the interfaces to the active wireless card, and check the Supported PHY Modes.

Message 2 of 8
IrvSp
Master

Re: Smartconnect difficulties

Doesn't sound like the R8000 I have? Smart Connect works, but I'm on V1.0.4.28 and that release did change the operation of Smart Connect for only the 5Ghz bands to all 3 bands.

 

What f/w are you on?

 

What DEBUG have you tried? Rebooting and/or a complete RESET of the router?

 

Of course, the problem could be related to a device I guess or a faulty power supply.

Message 3 of 8
FirestormX
Tutor

Re: Smartconnect difficulties

I'm using V1.0.4.28_10.1.54.

 

When I first turned on SmartConnect, everything connected to 2.4.  I rebooted the router, started seeing devices connect to the upper 5 Ghz radio, and thought that was that.  A day later, everything is back to 2.4 Ghz again.

 

I haven't tried restoring factory defaults yet.  I did that about a year ago when I was having throughput issues.  QoS, metering were also disabled around that time.

Message 4 of 8
IrvSp
Master

Re: Smartconnect difficulties


@FirestormX wrote:

I'm using V1.0.4.28_10.1.54.

 

When I first turned on SmartConnect, everything connected to 2.4.  I rebooted the router, started seeing devices connect to the upper 5 Ghz radio, and thought that was that.  A day later, everything is back to 2.4 Ghz again.

 


I gave up on Smart Connect on that release.

 

Smart Connect just wasn't working well for me. First, it uses 'load leveling'. It means it will try to keep the load on each of the 3 radio's even. What that means is some 5Ghz capable devices will wind up on the 2.4Ghz band. On top of that, it is the 'dynamic' implementation but a 'static' one. That means it will not move a device once set to a radio, no matter how many devices disconnect.

 

Even before this 'upgrade' to the .28 release it wasn't the best operational mode. What I 'like' is all AC devices on the higher speed 5Ghz band and the N speed devices on the lower. I did find them mixed on the bands in the prior f/w too but tolerated it.

 

No I control what device connect to which SSID manually. Suggest you do that.

Message 5 of 8
tadswana
Guide

Re: Smartconnect difficulties

Same issue with my macbook pro, have turned off Smart Connect and just justing 5G-1 at lower channel, seems to have fixed.

Message 6 of 8
FirestormX
Tutor

Re: Smartconnect difficulties

I disabled Smart Connect, and it turns out the issue is with my upper 5 Ghz radio.  Now that I'm able to manually select the network, my devices work fine with 2.4 and the lower 5Ghz, but all devices have problems with the upper 5 Ghz disconnecting or not connecting at all.

 

It doesn't seem to be outside interference;  if I get bored I may try resetting to defaults and restoring the config.  Otherwise it wouldn't be surprising if I end up with another Netgear with a dead radio.

Message 7 of 8
IrvSp
Master

Re: Smartconnect difficulties


@FirestormX wrote:

I disabled Smart Connect, and it turns out the issue is with my upper 5 Ghz radio.  Now that I'm able to manually select the network, my devices work fine with 2.4 and the lower 5Ghz, but all devices have problems with the upper 5 Ghz disconnecting or not connecting at all.

 

It doesn't seem to be outside interference;  if I get bored I may try resetting to defaults and restoring the config.  Otherwise it wouldn't be surprising if I end up with another Netgear with a dead radio.


It might not be the 2nd 5Ghz radio? You'll see that works at higher frequency channels. Usually AC devices, but it also can have cordless phone Interference with the 2 highest bands. Also the width of those bands might mean some older devices might not work.

 

I'd try different channels and see if it makes a difference.

 

Interesting reading, https://tidbits.com/2009/12/14/improve-wi-fi-performance-in-the-5-ghz-band/

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 3481 views
  • 2 kudos
  • 4 in conversation
Announcements