Reply

Re: USB 3.0 detection and indexing hang failure on R7900 R8000 ReadySHARE - root cause is NTFS issue

USB 3.0 detection and indexing hang failure on R7900 R8000 ReadySHARE - root cause is NTFS issue

I found a workaround for a problem with getting USB devices which use NTFS to be detected on the USB 3.0 port on my R7900.

 

Symptoms:

- USB device not detected.  Drive spins up and light comes on but it never shows in ReadySHARE menu.

- Router hangs 10-30 minutes after plugging drive in - unable to access internet on wired or wireless

- USB 3.0 light will be on but not blinking, ReadySHARE admin web page does not detect drive.

- USB light off even when drive is plugged in and activity/power light on drive is on.

- The sqlite 3 .db file written to the USB storage device has blanks at the bottom of the file.

- Plugging drive into PC (Ubuntu or Windows 10) works.

- Same files copied to other USB 3.0 or 2.0 drives/enclosures and connected to router also causes failure.

 

Root cause:

NTFS is not fully supported on the R7900 and R8000. The kernel, the NTFS driver, the version of sqlite, or the indexing process itself could be root cause for being unable to read/index NTFS drives which have long paths plus long file names or files with special characters such as ( or {.

 

Verify this by checking to see if the following folders are created 10-15 minutes after the drive is first plugged in:

01/01/2016  09:09 PM    <DIR>          .ReadyDLNA

01/01/2016  09:08 PM    <DIR>          netgear_downloader

 

The sqlite database file as well as media image files are written to the .ReadyDLNA folder when the drive is initially connected to the router.

The database files are stored in the following path:

Directory of D:\.ReadyDLNA

 

01/01/2016  09:09 PM    <DIR>          .

01/01/2016  09:09 PM    <DIR>          ..

01/01/2016  09:09 PM    <DIR>          art_cache

01/01/2016  09:18 PM        40,685,568 files.db

 

There are gaps/blanks towards the bottom of files.db.  It appears the file does not get completely written when the process hangs.

 

Workaround:

  1. Plug the drive into a PC after the router fails to recognize it.
  2. Edit files.db and at the end of the file there are references to the last path/file names the indexing process was trying to index.  Check the path and filename for the last few files on a PC.  The path and files that sqlite was operating on will give an indication as to which directory was being processed.  Look in that directory or the next directory that would have been processed to find files whose path plus file name are too long.  Too long = >200+ characters.  I’ve had failures with files whose path plus file name are 239 and 248 characters.
  3. Shorten the number of characters by moving long paths to root.  (e.g.move any long directory tree >200 characters to the first directory to shorten the overall length of path+file names)
  4. Shorten file names.  Rename files which are 40+ characters to something shorter.
  5. Rename files which have symbols characters.
  6. Delete the .ReadyDLNA and netgear_downloader folders and files before plugging the drive back into the router.
  7. Plug the drive into the router and wait 10-30 minutes for the indexing process to finish.  The drive will make read/write noises during indexing.  The indexing process is complete once these noises stop. Check the USB 3.0 light on the router - it should be blinking while the indexing is happening.
  8. Check the router web page and confirm the drive is recognized.

 

I confirmed that all files on the USB 3.0 storage device are accessible via PC and web browser after fixing my path/file name to be less than 200 total characters.  I feel this is a workaround and not a fix since the path/file names are valid in Windows 10 and Ubuntu 15.10.

 

I've asked Netgear for a fix via support Case # 26259071.

Message 1 of 5
mabdelraheem
Guide

Re: USB 3.0 detection and indexing hang failure on R7900 R8000 ReadySHARE - root cause is NTFS issue

Hi Mike,

 

Did you get any response regarding your case?

Message 2 of 5
Dominik123123
Aspirant

Re: USB 3.0 detection and indexing hang failure on R7900 R8000 ReadySHARE - root cause is NTFS issue

 Long Path Tool. It allows you
to rename, copy or delete any file regardless its path ore name.

Message 3 of 5
Chimpster23
Aspirant

Re: USB 3.0 detection and indexing hang failure on R7900 R8000 ReadySHARE - root cause is NTFS issue

Mike,

 

First off great job on the work around, so far I am 3 days in without it hanging.

 

Couple of questions for you,

 

Have you received any update on the case you submitted to netgear?

Do you think this is something that can be "fixed" by a firmware update on their end, or is this issue always going to occur?

When you say that rename files with symbol characters like ( and {, is it only those characters or all symbols?

 

Regards, 

Message 4 of 5

Re: USB 3.0 detection and indexing hang failure on R7900 R8000 ReadySHARE - root cause is NTFS issue

I did not receive a fix in the time frame I needed so I returned the device and bought a different brand.

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 4030 views
  • 1 kudo
  • 4 in conversation
Announcements

Orbi WiFi 6E