Discussion stats
  • 2 replies
  • 20777 views
  • 1 kudo
  • 2 in conversation
Announcements

Top Contributors
Reply
Highlighted
Initiate

Updating R7000 Firmware taking forever

Last night, I read an article online about the security issue with my router (https://www.yahoo.com/tech/may-time-turn-off-router-215115643.html).

 

This morning, I logged into my Router's local interface and initiated the firmware update from within that system.

 

The power light immediateluy began blinking amber... and has remained in that state for over 15 hours.

 

Should it take that long to update? I am afraid to touch anything because I do not want to damage the router.

 

I can no longer login to the router interface. I would appreciate any help/direction.

 

Thank you!

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 1 of 3

Accepted Solutions
Highlighted
Initiate

Re: Updating R7000 Firmware taking forever

It appears that I just had to manually reboot the router. The firmware update is applied and I did not lose any seetings. I was so afraid to reboot because the power light was still blinking amber, which made me think it was stuck somewhere in the download/update process. But after a coupl eof days with no change in the status, I powered down then powered up the router and all is working fine, now.

View solution in original post

Message 3 of 3

All Replies
Highlighted

Re: Updating R7000 Firmware taking forever

No, installing a new firmware through the router interface should not take that long at all. It took a couple of minutes last time I did it.

 

Note that for updating to fix the security issues, the procedure was to to download the new firmware first and then to install it (you might have done it like this, it is not clear from your description).\

 

In any case, I think it is best you contact Netgear support to sort you out.

 

Frank

Message 2 of 3
Highlighted
Initiate

Re: Updating R7000 Firmware taking forever

It appears that I just had to manually reboot the router. The firmware update is applied and I did not lose any seetings. I was so afraid to reboot because the power light was still blinking amber, which made me think it was stuck somewhere in the download/update process. But after a coupl eof days with no change in the status, I powered down then powered up the router and all is working fine, now.

View solution in original post

Message 3 of 3