Discussion stats
  • 9 replies
  • 5591 views
  • 0 kudos
  • 3 in conversation
Announcements

Top Contributors
Reply
Highlighted
Aspirant

VPN on Nighthawk R7800 not working, probably due to incorrect time

The VPN connection to my R7800 is not working. In the log i can see that a login was attempted, but it failed. I now noticed that the time in the router is incorrect, it's 1970, and it resets every time i reboot the router. My guess is, that the incorrect time causes the certificates to be invalid.

I have installed the newest firmware and i also set the DNS server manually to 8.8.8.8 and 8.8.4.4

Model: R7800|Nighthawk X4S AC2600 Wifi Router
Message 1 of 10
Highlighted
NETGEAR Moderator

Re: VPN on Nighthawk R7800 not working, probably due to incorrect time

Hi Naryoril,


Reset the router to factory default and reconfigure manually. Check the time after the reset.

 

JamesGL

Community Team

Message 2 of 10
Highlighted
Aspirant

Re: VPN on Nighthawk R7800 not working, probably due to incorrect time

sorry for the late reply, i was on holidays (which was why i wanted to use the VPN in the first place)

 

I used the factory default settings reset in Advanced > Administration > Backup Settings and set the WiFi networks again manually, i didn't make any other changes.

 

The router's time, displayed under Advanced > Administration > Logs is still incorrect (it says "Current Time: Thursday, Jan 01, 1970 02:17:59")

Message 3 of 10
Highlighted
NETGEAR Moderator

Re: VPN on Nighthawk R7800 not working, probably due to incorrect time

Hi Naryoril,

 

1. What is the firmware version of the router?\

2. Can you check with the ISP to make sure that the NTP is not being blocked.

 

JamesGL

Community Team

Message 4 of 10
Highlighted
Aspirant

Re: VPN on Nighthawk R7800 not working, probably due to incorrect time

I'm not at home right now so i'm not 100% about the firmware version number, 1.2.04 or 2.1.04 i think. When i check for a firmware upgrade, it says that i have the newest version.

 

As for blocking NTP: i just called them and they told me it's not blocked.

And yesterday i tried this command from the windows command line:

w32tm /stripchart /computer:us.pool.ntp.org

 

And i got replies.

What NTP server is the router using? And does it have any fallbacks?

Message 5 of 10
Highlighted
Aspirant

Re: VPN on Nighthawk R7800 not working, probably due to incorrect time

The firmware version is 1.0.2.04

Message 6 of 10
Highlighted
NETGEAR Moderator

Re: VPN on Nighthawk R7800 not working, probably due to incorrect time

Hi Naryoril,

 

Please check your inbox.

 

JamesGL

Community Team

Message 7 of 10
Highlighted
Aspirant

Re: VPN on Nighthawk R7800 not working, probably due to incorrect time

Hello,

I have had the same issue with the date. My router is brand new and I noticed this time issue. Many clients are unable to connect to my router because of the issue. I have the X4S and updated to the latest firmware which I think is 1.0.12. Can you help. It has been quite a frustrating time setting this up. Only my windows laptop is working with this router.
Message 8 of 10
Highlighted
Aspirant

Re: VPN on Nighthawk R7800 not working, probably due to incorrect time

I didn't have any problems connecting any device to my router, i only had issues with the VPN. So i don't think the time issue is the cause for your problems. The way the problem was solved in my case was by getting a beta firmware version.

 

If your router is brand new, you are still in the 90 day period where you have support, so why not contact support directly?

Message 9 of 10
Highlighted
Aspirant

Re: VPN on Nighthawk R7800 not working, probably due to incorrect time

Did the beta work for you?

I did contact them. Spoke to literally 10 people in technical support and no resolution yet. Final thing is to just return the router.

So my windows PC was fine but my iOS devices would not work properly. YouTube app on my iOS devices wouldn't receive data but other apps like whatsapp were fine. Whatsapp would have issues in downloading images and videos.

My Sony TV simply rejected the connection saying the time is out of sync. This router has unbeatable coverage but unfortunately the software is really not up to the mark.

One thing that "might" be an issue is that I bought the router in US and installed in India. There isn't a way to change the region from North America to any other region. The region seems to be hard coded into the firmware which I find weird. I say this might be an issue because I haven't seen too many of such issues.

Thanks,
Kamlesh.
Message 10 of 10