Reply

Re: Wake On Lan with R7000

TheEther
Guru

Re: Wake On Lan with R7000

Great. Thanks for posting the solution.
Message 26 of 52
tw9855
Aspirant

Re: Wake On Lan with R7000

ViperGeek, Hi, I just got the r7000 last week and have been testing it out. WOL is important to me and I know I have to set up a static arp entry to make it work. I've run into a problem though. Even after running the 'new' telnetenable successfully I still can't access the router using telnet. I get an error saying "cannot open connection to host on port 23, connect failed when I try to telnet in. The r7000 is on firmware v1.0.4.18_1.1.52.
Message 27 of 52
ViperGeek
Apprentice

Re: Wake On Lan with R7000

Hello.

I'm running V1.0.4.30_1.1.67 and just tried it again after a fresh reboot (which resets the telnet listener). Worked again:

C:\>telnet 192.168.0.1
BusyBox v1.7.2 (2015-05-26 08:38:17 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

#



Here's the MD5 of the telnetEnable.exe I'm using:

C:\>md5 telnetEnable.exe
MD5(telnetEnable.exe)= 90186d9b6dfe7f414af099f7663e53e4



I'm also directly adjacent to the Ethernet and used the MAC address of the Ethernet port of the R7000, as reported by 'arp -a'.

- Dave
Message 28 of 52
ViperGeek
Apprentice

Re: Wake On Lan with R7000

ViperGeek wrote:

Here's the MD5 of the telnetEnable.exe I'm using:

C:\>md5 telnetEnable.exe
MD5(telnetEnable.exe)= 90186d9b6dfe7f414af099f7663e53e4



I'm also directly adjacent to the Ethernet and used the MAC address of the Ethernet port of the R7000, as reported by 'arp -a'.


I'm not sure if this was obvious from the openwrt.org post, but the new syntax for new telnetEnable is:

C:\>telnetEnable 192.168.0.1 <MAC without colons or spaces> admin <admin password>


The old Gearguy/Geardog stuff is long gone (thankfully).

- Dave
Message 29 of 52
tw9855
Aspirant

Re: Wake On Lan with R7000

Thanks. Redid everything from the start and got it to work. Don't know what happened the first 10x I tried it.
Message 30 of 52
cpufox
Aspirant

Re: Wake On Lan with R7000

Anyone able to telnetEnable on R7000 with lastest firmware?
Post above is recent, I am using latest telnetEnable.exe x.x.x.x mac
Firmware Version V1.0.4.30_1.1.67, but always getting

send failed: 10057

Tried all kinds of variations, mac with or with '-', ip without mac, old Gearguy ... no luck. mac ip verified with arp -a any suggestions?

My goal was to setup perm arp, to enable Wake over internet for various devices from the solution here http://forum1.netgear.com/showthread.php?t=90065&page=3

Any ideas on acomplishing this task in the GUI, or how to get telnet enabled on recent R7000 firmware?

Trying to perform this command:

# arp -i br0 -s x.x.x.x mm:mm:mm:mm:mm:mm
where x.x.x.x is the WoL destination IP address (not .255) and mm... is
the WoL destination's MAC address
Message 31 of 52
ViperGeek
Apprentice

Re: Wake On Lan with R7000

Hi cpufox.

You're running the exact version that worked for me in Post #28, so it's known to work in that release. The "send failed" error makes me think it's on the PC side, rather than the router side.

Two wild guesses off the top of my head:

 

  1. Are you running as Administrator in Windows?
  2. Can you try another NIC (network card) or even Wi-Fi?

Good luck. It should just "work" if you're running the latest version of telnetEnable.exe.



    - Dave
Message 32 of 52
BigBrosMo
Aspirant

Re: Wake On Lan with R7000

Anyone can tell me how to run the telentenable command from win 7 x64? It says its incompatible with 64 bit version. There is no link to a 64 bit version anywhere...

Thanks
Message 33 of 52
ViperGeek
Apprentice

Re: Wake On Lan with R7000

BigBrosMo wrote:
Anyone can tell me how to run the telentenable command from win 7 x64? It says its incompatible with 64 bit version. There is no link to a 64 bit version anywhere...

I'm running the new TelnetEnable.exe under Win 7 x64 and it works fine:

Did you download the binary from here:

https://github.com/LuKePicci/NetgearTelnetEnable/blob/master/binaries/windows/telnetenable.exe

Click View Raw to save it as a .EXE.

C:\UTIL>set PROCESSOR_ARCHITECTURE
PROCESSOR_ARCHITECTURE=AMD64

C:\UTIL>telnetenable.exe

Version: 0.4, 2015/02/12
Modified to work with newer Negear routers R7000 R7500 by insanid

Usage:
telnetenable.exe

C:\UTIL>


- Dave
Message 34 of 52
BigBrosMo
Aspirant

Re: Wake On Lan with R7000

ViperGeek wrote:
I'm running the new TelnetEnable.exe under Win 7 x64 and it works fine:

...

Click View Raw to save it as a .EXE.



Oh man, thanks a lot Dave. I just right clicked on the exe and "saved link as". Didn't realize I had to go into it and click and Raw. You learn something everyday. All is good, arp entry added and WoL working across the interwebs.
Message 35 of 52
leforban
Aspirant

Re: Wake On Lan with R7000

Hi !

WoW has been working fine for months and suddenly stop working after a firmware update... So I 've been reading this post very carefully.

I did run the "telenetenable.exe" successfully but I still can't wake my PC over internet...

I set a static LAN IP
I opened a port for this IP
My no-ip ddns is running fine


So i'm lost... A little bit of help would be really nice Smiley Very Happy
Message 36 of 52
leforban
Aspirant

Re: Wake On Lan with R7000

Ok !

I finaly managed to get perm entry in my router's arp talbe for the computer I want wake up thru internet but it still doesn't work !

I'm sure that i'm forgetting something really stupid Smiley Tongue

- Perm entry in ARP table
- Fixed local IP
- Port is open (at least it should be but this tool keep saying that the port is closed http://www.yougetsignal.com/tools/open-ports/ )

What am I doing wrong ? Is there a way to know where the magic packets are stuck ?

Thx ! Smiley Happy
Message 37 of 52
ElaineM
NETGEAR Employee Retired

Re: Wake On Lan with R7000

Hi @leforban

 

Did you check your firewalls? Double NAT? You may also want to try looking for a sniffer particularly for WOL.

 

 

Regards,

 

ElaineM
NETGEAR Community Team
Message 38 of 52
riker
Aspirant

Re: Wake On Lan with R7000


@ViperGeek wrote:
Thanks for the quick reply. I actually had a reserved DHCP address for my WoL destination, but the ARP cache entry times out anyway.

However, I did find a solution:



      Now I have PERM entry, confirmed via the 'arp' shell command, for the WoL target.


    - Dave

Could you please post your solution again. It looks it was deleted.

Thanks

Message 39 of 52
ViperGeek
Apprentice

Re: Wake On Lan with R7000

Mods,

 

Was my solution removed on purpose, or did a forum update perhaps wipe out my formatted text by mistake?

 

- Dave

 

Message 40 of 52
Babylon5
NETGEAR Employee Retired

Re: Wake On Lan with R7000

ViperGeek, I can see several posts made by you in this thread, and none deleted, so are you referring to a solution within this thread or another thread?

____________________________
Working on behalf of Netgear
My name is Andy
Message 41 of 52
ViperGeek
Apprentice

Re: Wake On Lan with R7000


@Babylon5 wrote:

ViperGeek, I can see several posts made by you in this thread, and none deleted, so are you referring to a solution within this thread or another thread?


Thanks for the response, Andy.  My posts survived, but some of the juicy content was removed.  For example, Message 25 had detailed steps for using TelnetEnable and creating static ARP entries, and Message 32 had possible solutions for another customer's problems that were seemingly removed.  Finally, another user's quote of my original solution in Message 35 was converted to "...".

 

I'm OK with the edits if they were purposeful.  It's just unfortunate that the most effective, viable solution was removed from this forum thread.

 

- Dave

Message 42 of 52
Babylon5
NETGEAR Employee Retired

Re: Wake On Lan with R7000

Dave,

 

I can see that those posts are clearly truncated, but even though these forums allow limited editing now, an edited post is tagged as ‘Edited’. I can only assume that text was lost in the transfer, but it seems too selective. Short of me asking everyone capable of such edits, we will have to wait and see if someone has an answer, but my guess is that no one had an issue with what you had posted.

____________________________
Working on behalf of Netgear
My name is Andy
Message 43 of 52
ViperGeek
Apprentice

Re: Wake On Lan with R7000

Hi Riker.

 

Now that I've confirmed that the removal of my solution was a moderation, I'll try repeating it from memory (I was actually using this thread, bookmarked, to remember how to do it).

 

  1. Download TelnetEnable from here: https://github.com/LuKePicci/NetgearTelnetEnable/blob/master/binaries/windows/telnetenable.exe?raw=t...
  2. Open a DoS/Command Prompt on a PC directly connected to the same LAN and type 'telnetenable.exe <router-IP> <router-MAC> admin <admin-password>'
  3. Telnet to the router
  4. Type 'arp -i br0 -s x.x.x.x mm:mm:mm:mm:mm:mm' where x.x.x.x is the WoL destination IP address (not .255) and mm... is
    the WoL destination's MAC address

You should then have a static ARP entry in your router.  Set up forwarding of port 9/UDP to your device you want to wake and it should work.

 

- Dave

View solution in original post

Message 44 of 52
KennethL
NETGEAR Employee Retired

Re: Wake On Lan with R7000


@Babylon5 wrote:

Dave,

 

I can see that those posts are clearly truncated, but even though these forums allow limited editing now, an edited post is tagged as ‘Edited’. I can only assume that text was lost in the transfer, but it seems too selective. Short of me asking everyone capable of such edits, we will have to wait and see if someone has an answer, but my guess is that no one had an issue with what you had posted.


The original postings used [List] .. [/List] ie. numbered listing,. appears to be lost in transfer.   Original postings have been updated with original content.   

 

Regards,

Kenneth

Message 45 of 52
riker
Aspirant

Re: Wake On Lan with R7000

Hi Dave,

 

thanks for posting your solution again. It works excellent for me.

One more matter. Is it safe to keep telnet console open? Because once you open telnet console to router there is no way to disable it till router is rebooted, but when router is rebooting we are loosing all settings.

Thanks

Message 46 of 52
ViperGeek
Apprentice

Re: Wake On Lan with R7000

You're very welcome.  I'm glad the solution worked for you as well.

 

There is a risk from keeping the telnet listener enabled, but the risk is mitigated by the fact that it's only accessible from the LAN side.  Assuming you don't have a hostile local network and your LAN (including wireless) is fairly well controlled, you should be OK leaving telnet enabled.  I'm unaware of a way to re-disable the telnet listener without rebooting.

 

- Dave

Message 47 of 52
millertime23
Aspirant

Re: Wake On Lan with R7000

This solution works perfectly. Thanks for sharing ViperGeek. The only issue is the new ARP PERM entry gets cleared every time the router is rebooted. Then I have to go back and re-do all the entries. This could be a hassle after a power failure. Are you aware of a way to save these settings permanently? I'm running an R7000 on 1.0.4.30_1.1.67 firmware

Message 48 of 52
ViperGeek
Apprentice

Re: Wake On Lan with R7000


@millertime23 wrote:

 Are you aware of a way to save these settings permanently? I'm running an R7000 on 1.0.4.30_1.1.67 firmware


Hi MillerTime.

 

Unfortunately, I've found no way to have these commands auto-execute on boot.  I messed around with /etc/init.d, but I believe the R7000 uses a volatile filesystem in that everything is recreated based on config at startup.  Nothing written to /etc, for example, will survive a reboot either.

 

- Dave

Message 49 of 52
millertime23
Aspirant

Re: Wake On Lan with R7000

I was worried that might be the case. Maybe a workaround would be to write a .bat file that will execute in windows task scheduler

Message 50 of 52
Top Contributors
Discussion stats
Announcements

Orbi WiFi 6E