Reply

X4 Nighthawk 2350 5G band is unstable

adagosto
Follower

X4 Nighthawk 2350 5G band is unstable

Has anyone has problems getting the 5G band of the X4 Nighthawk to reliably connect and maintain connection?  I have found that the signal is strong and has great connectivity and a few minutes later the signal will be dead, lost or low.  Then when reconnecting, the 5G band will not reconnect.  Cycling the router will often get the 5G band to reconnect, but never sure for how long.

 

Any thoughts on how I might improve that performance?

 

Thanks!!

Message 1 of 12
mediatrek
Virtuoso

Re: X4 Nighthawk 2350 5G band is unstable

Are you having the issues with the original R7500 or the newer R7500v2 model in the X4 Nighthawk AC2350?

I have been having the 5G band SSID disappear every few days and it requires a reboot of the R7500v2 I have. The 5G band usually disappears when I have Broadcom-based chipset wireless devices connecting to the 5G band (ie- the Netgear EX6200 I use as a wireless bridge). This issue has happened for me from the firmware it shipped with to the newest v1.0.2.2 that is out now for the R7500v2.


I also know it is not a hardware defect, but a firmware one, as I have used 3 R7500v2 units and they all had the same issue.

Message 2 of 12
JamesGL
Master

Re: X4 Nighthawk 2350 5G band is unstable

Hi All,

 

Have you tried changing channels for your wireless network?

Have you performed a factory reset on the device?

Message 3 of 12
mediatrek
Virtuoso

Re: X4 Nighthawk 2350 5G band is unstable

Yep. I always do a hard reset after each firmware update, and never use any saved config files to restore desired configuration. As for changing channels, I have of course tried that as well; having used all lower and upper band channels for 5G.

Message 4 of 12
JamesGL
Master

Re: X4 Nighthawk 2350 5G band is unstable

Hi mediatrek,

 

Do you experience the same problem with other firmwares aside from the v1.0.2.2?

Message 5 of 12
mediatrek
Virtuoso

Re: X4 Nighthawk 2350 5G band is unstable

Yes I have. From the initial v1.0.0.24 all the way threw the other releases to v1.0.2.2.

Prior to the R7500v2 I was using the Linksys EA8500, which uses the same QCA9980 chip for the 5G radio as the R7500v2, and never had the issue with the Linksys unit. I switched to the R7500v2 units due to the Dynamic QoS based on Qualcomm’s Streamboost engine. Otherwise, I would be going back to the EA8500.

Message 6 of 12
JamesGL
Master

Re: X4 Nighthawk 2350 5G band is unstable

 

Hi mediatrek,

 
 
Please check your inbox.
Message 7 of 12
mediatrek
Virtuoso

Re: X4 Nighthawk 2350 5G band is unstable

JamesGL I have. Nothing in private messages via this forum, nor anything in my email (yes I checked my mail server and Outlook mail client junk folders too). Perhaps whatever you were going to send, try again?

Message 8 of 12
JamesGL
Master

Re: X4 Nighthawk 2350 5G band is unstable

 

Hi mediatrek,

 
 
Please check again your inbox. My apologies.
Message 9 of 12
mediatrek
Virtuoso

Re: X4 Nighthawk 2350 5G band is unstable

JamesGL thank you for passing this issue onto Netgear support. I wanted to share with you and the forum community my unresolved expereince with Netgear L2 support to date:

 

I have been dealing with Netgear support (Case #26514518) for over a month now over the 5G radio dropping and disappearing every few days on the R7500v2 units I have. This has happened on all 3 different R7500v2 units I have used; with 2 still in my possession. The past few weeks L2 support staff have been useless and simply put; completely inapt. The L2 support staff take a week to reply to anything in terms of follow-up, and when they do they just request information and debug files I already provided a week or 3 weeks prior that are attached to the case file or I have given links to the materials on Google Drive in the case messages! Last week after waiting a week for a reply, the tech said in a their reply to me:
"You didn't follow the steps 4 and 5 on the User Guide that we provided to you..."
 
Did you even look at the materials I sent to you before typing that statement out?!? I followed the steps verbatim in the user guide. The evidence was right in the debug files I provided a week ago! Did the tech even look at the files!?!? Apparently not. I've participated in a number of beta projects for Netgear in the past and have worked with those beta project reps to debug numerous issues in the past, so it is not like I do not know what I am doing and have to provide.
Message 10 of 12
mediatrek
Virtuoso

Re: X4 Nighthawk 2350 5G band is unstable

Still can not close of this threads. Going into month 4 with this open case and still ZERO progress with support and the Taiwanese product "engineering team" I submitted debug zip log from beta firmware for the R7500v2 via http://routerlogin.net/debug.htm Two weeks go by and I get zero follow up. So I sent a message asking for an update. It took almost another week to get a reply to only be told there are two log files were not in the debug archive. Specifically "console-log.txt" and "basic_debug_log.txt."
 
I generated 10+ debug archives with the firmware and not a single time were those .txt files apart of the debug archive. I tried with my R7800 running v1.0.1.30. Same deal.
 
With June around the corner, I will be going into the 4th month with zip progress on this case. I have requested a SWAP RMA a few times already for a R7800 for the two R7500v2 I have and no reply to that either. This is freaking NUTS.
 
I do consumer and small business network installs and have been using Netgear products for just about all my jobs the past 3 years; up till two months ago. With this crappy service I have switched to using mostly Linksys routers (mostly the EA8500 and EA7500) for install jobs. So far Netgear has lost the sale of 34 units because of this.
Model: R7500v2|Nighthawk X4 AC2350 Smart WiFi
Message 11 of 12
mediatrek
Virtuoso

Re: X4 Nighthawk 2350 5G band is unstable

While it did take 5 1/2 months, the resolution Netgear saw to my 5G R7500v2 support case (opened in 02/2016) was to replace my two R7500v2 units with R7800 units as firmware development for the R7500v2  was "not going to happen."

I got my 2 replacement routers this week via FedEx. I saw a few weeks ago Amazon.com posted a new SKU for the R7500v2 on their site. My guess is it will be a part of the upcoming Amazon Prime sale event. If so, I feel for the suckers who will buy it knowing that they will not be getting fixed firmware updates with the newer Qualcomm chip drivers integrated into the product firmware. I know there are newer Wi-Fi drivers Netgear's Taiwanese-based product engineers could integrate into new R7500v2 firmware builds, as Qualcomm has told me so, but Netgear's overseas engineers and programmers are keeping the old stuff in the firmware.

Message 12 of 12
Top Contributors
Discussion stats
  • 11 replies
  • 2452 views
  • 0 kudos
  • 3 in conversation
Announcements