Reply
Highlighted
Initiate

X6 R8000 WiFi Smart Connect feature not connecting Apple devices

Nighthawk X6 R8000 

Firmware Version
V1.0.4.46_10.1.63

 

My Nighthawk X6 R8000 WiFi Smart Connect works great on Android devices, but not Apple devices such as iPhones, MAC laptop.

All of our Apple devices receive "Incorrect password" whenever attempt to connect to the wifi with Smart Connect turned on on the router. Intermittently, a device may successfully connect after making numerous attempts (sometime may take 10 tries). If I turnoff the "Smart Connect" function on the router. Every of the Apple devices connect fine to each of the WiFi bands (2.4G, 5G-1, 5G-2).

Anyone having this issue?

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 1 of 3

Accepted Solutions
Highlighted
NETGEAR Moderator

Re: X6 R8000 WiFi Smart Connect feature not connecting Apple devices

You may want to try and disable this feature see if that helps the apple devices connect.

 

https://kb.netgear.com/30228/How-to-disable-20-40-MHz-Coexistence-on-a-NETGEAR-router

 

DarrenM

View solution in original post

Message 2 of 3

All Replies
Highlighted
NETGEAR Moderator

Re: X6 R8000 WiFi Smart Connect feature not connecting Apple devices

You may want to try and disable this feature see if that helps the apple devices connect.

 

https://kb.netgear.com/30228/How-to-disable-20-40-MHz-Coexistence-on-a-NETGEAR-router

 

DarrenM

View solution in original post

Message 2 of 3
Highlighted
Initiate

Re: X6 R8000 WiFi Smart Connect feature not connecting Apple devices

Darren,

Thank you for responding. 

Followed your instruction disabled "20/40 MHz Coexistence" option. Turned "Smart Connect" back on on the router. We tested on my wife's iPhone 11 connects to the WiFi right away everytime. 

 

Randy C

 

 

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 1348 views
  • 2 kudos
  • 2 in conversation
Announcements