Reply

forwarding HTTP

replabrobin
Aspirant

forwarding HTTP

Hi,

I'm trying to configure my new R7000 to forward port 80 to an internal machine, but it doesn't seem able to do so. When I connect from outside the connection just hangs. As an experiment I added port forwarding from port 8001 to 192.168.1.x port 80 and that works fine. Is Genie unable to forward port 80?

tia

Robin
Message 1 of 8
jmizoguchi
Virtuoso

Re: forwarding HTTP

If you use port translation work correct?


Public IP:8001 <--->192.168.1.x:80 (Server)

I would check your ISP make sure it does not block port 80 first
VPN Case Study

VPNCASESTUDY.COM

"Our Second To None VPN Related Setup Case Study[/COLOR][/URL]

"One Stop Solution To Your Netgear VPN Connectivity"

*Visit the site for Non-VPN related Doc & Links* [Windows & Mac user/support]





June Mizoguchi-
Message 2 of 8
replabrobin
Aspirant

Re: forwarding HTTP

My isp is plusnet here in the uk; they claim not to block ports. I looked at my ISP settings and it claims not to have the free firewall turned on.

This all used to work under tomato on the wndr3500l. I have port 22 open and that works fine. I don't think it can be the no-ip being pwned by Microsoft as I fail even while using the ip address itself; my xxx.no-ip.biz resolves fine and I can use 22 and 8001-->80 ok. If all else fails I will try putting the wndr3500l back in place to see if it is only the r7000 that fails.
Message 3 of 8
jmizoguchi
Virtuoso

Re: forwarding HTTP

Also readyshare http uses 80 so that also could be an issues
VPN Case Study

VPNCASESTUDY.COM

"Our Second To None VPN Related Setup Case Study[/COLOR][/URL]

"One Stop Solution To Your Netgear VPN Connectivity"

*Visit the site for Non-VPN related Doc & Links* [Windows & Mac user/support]





June Mizoguchi-
Message 4 of 8
replabrobin
Aspirant

Re: forwarding HTTP

I didn't think of that although I don't use readyshare. I tried turning off all the things in the usb advanced settings and it makes no difference. If this were true it would be a pretty bad bug as it would mean the router's ports override those on the external WAN; ie if required I could easily use port forwarding to map port 80 on the router to some external port, but the port number (and ftp) on the USB storage area seem to be fixed.
Message 5 of 8
jmizoguchi
Virtuoso

Re: forwarding HTTP

Very possible it is reserved in the firmware therefore it may able to use it
VPN Case Study

VPNCASESTUDY.COM

"Our Second To None VPN Related Setup Case Study[/COLOR][/URL]

"One Stop Solution To Your Netgear VPN Connectivity"

*Visit the site for Non-VPN related Doc & Links* [Windows & Mac user/support]





June Mizoguchi-
Message 6 of 8
replabrobin
Aspirant

Re: forwarding HTTP

replabrobin wrote:
This all used to work under tomato on the wndr3500l.


I have checked connectivity again with the wndr3500l (toastman's tomato firmware) and that combo is certainly able to forward port 80 so my ISP is not blocking HTTP. It seems as though Genie on the R7000 is broken in this respect. It will allow you to try and port forward port 80, but that doesn't do the right thing. It seems port 80 is reserved for 'ready share' :mad:
Message 7 of 8
jmizoguchi
Virtuoso

Re: forwarding HTTP

If you test with older router do not have readyshare USB ports probably will work fine.

In that case you have to use port transition and use 8001 like you did
VPN Case Study

VPNCASESTUDY.COM

"Our Second To None VPN Related Setup Case Study[/COLOR][/URL]

"One Stop Solution To Your Netgear VPN Connectivity"

*Visit the site for Non-VPN related Doc & Links* [Windows & Mac user/support]





June Mizoguchi-
Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 4984 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E