Reply

nighthawk ac1900 2.4 G not working properly

cyclone7963
Follower

nighthawk ac1900 2.4 G not working properly

Need help with this AC1900 wierless router. Been working fine for over almost 2 years. Rencently, it started to have issue with connection. Did a factory reset and updated the newest firmware. Today, the 2.4 G suddently stopped working properly. It is fine when the devices are close on the same floor. But it failed to connect when I moved to another floor in the house. The signal is still strong. But PC just failed to connect. And all mobile devices keeps on asking for password. Everything worked again when moved to the same floor. Have to change all the mobile device to 5G. 

Model: R6900|Nighthawk AC1900 Smart WiFi Router
Message 1 of 5
plemans
Guru

Re: nighthawk ac1900 2.4 G not working properly

the newest firmware for the R6900 enabled support for netgear armor. It hasn't been the smoothest transition to Armor.

Did you factory reset prior to upgrading firmware? If so, I'd try the reset again. The firmware change was quite significant and they've responded well to resetting after the firmware change.

doesn't fix it? I'd try downgrading the firmware to prior to netgear armor. Make sure to do it over a hardwired connection and to reset the device again after the downgrade. 

 

Still having issues?

have you tried changing wifi channels? maybe there's interference on your channel. 

You can also try "forgetting" the network on your devices and reconnecting. 

What modem are you using? shouldn't matter the the 2.4ghz but maybe its a dhcp issue. 

 

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 2 of 5
altjx
Tutor

Re: nighthawk ac1900 2.4 G not working properly

Not sure how to subscribe since it's greyed out, but also having the same issue. Will await responses here to see how this goes.

Message 3 of 5
plemans
Guru

Re: nighthawk ac1900 2.4 G not working properly

@altjx did you try the methods mentioned?

It doesn't hurt to start your own thread because everyone situation can be different based upon home, wifi interference, etc. 

Current setup: CAX80->Trendnet TEG-S380->GS716T-> RBK752->pi-hole
1.4gig download/50mbps upload
We’re members of the public helping out on our own time.
Message 4 of 5
altjx
Tutor

Re: nighthawk ac1900 2.4 G not working properly

Yes I've tried those methods and then some, and still isn't working. Also started my own thread several days ago with no luck.

Just wanted to subscribe to see if this one turned out differently. Looks like I'll be calling Netgear.
Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 720 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E