Reply
Aspirant

www.routerlogin.net says no disk !

R6700V3

Firmware Version V1.0.2.66_10.0.48

 

GUI Language Version V1.0.2.66_2.1.38.1

Windows 10

 

second attempt on USB function

I have tried to use a

8GB flash drive

4GB flash drive

256Mb flash drive

250GB Western Digital Powered "My Book"

all drives are know good working formatted drives. NTFS then also tried FAT32. 

 

Afer a few minutes of recognizing time, the only one that I can get to recognize is the 256MB flash drive. 

 

I have a readycloud account. I have readyshare storage enabled. 

The account is registered (the unregister button is available)

 

I cannot get this router to recognize any drives of any substantial size. 

This is my second router ordered. NG tech support didn't know after an hour+ on the phone. 

 

What in the world...???

Do I send this one back too? Or is it something I am not checking?

 

Thanks in advance. 

 

Model: R6700|Nighthawk AC1750 Smart WiFi Router
Message 1 of 28
Master

Re: www.routerlogin.net says no disk !

2 router's, same problem? Sort of makes one think the problem is either in the Router f/w or the drives themselves?

 

A picture would have been nice, but...

 

Disks do not sometimes appear immediately. If you have DLNA turned on, that catalog must be created. The time to do this would be content related. Maybe why the 256Mb drive showed up? Other problems could be a 'damaged' disk? Running CHKDSK on them all to check them out. Also the disk layout could be involved. Router's usually use drives with a single partition only.

 

Besides using READYSHARE, can you 'see' the drive with W10? In a CMD prompt enter NET VIEW. Now if you get an error 53 you'll need to enable SMB1 to see the shares. Windows Explorer should also see it. If you do NOT what to enable SMB1, use the Router's IP Address in the NET VIEW cmd (NET VIEW \\192.168.1.1) or enter \\192.168.1.1 in the URL line in Windows Explorer (use your Router's IP Address if not 192.168.1.1).

 

Surprised NG Support couldn't try this?

Message 2 of 28
Aspirant

Re: www.routerlogin.net says no disk !

 

I tried to wait on the 8GB again after changing SMB1. No resolve. 

I tried to use the 256MB again. It will not recognize now in the new router. 

 

Also, all of these drives have been formatted and have no data on them. 

 

Both times when setting up the router, I opted to update the firmware. I wonder if that is an issue?

 

I downloaded the older firmware R6700v3-V1.0.2.62_10.0.46.chk

to roll back the driver as a last resort. I mean... what the world am I doing wrong?

jaf.png

Message 3 of 28
Aspirant

Re: www.routerlogin.net says no disk !

In Basic, it shows no USB device. jj.png

Message 4 of 28
Aspirant

Re: www.routerlogin.net says no disk !

256MB installed...

Ran Setup Wizard under Advanced and now if I go to Basic, the 256MB USB recognized in the ReadyShare. 

Removed that drive. 

 

8GB installed...

Ran Setup Wizard under Advanced and now if I go to Basic, the NO USE DRIVE in the ReadyShare. 

 

I ran checkdisk on the 8GB. All the drives have been single partitions. 

df.png

Message 5 of 28
Master

Re: www.routerlogin.net says no disk !

No drive showing as connected, you will NOT see anything with NET VIEW...

 

Also had a 'typo', need a space after VIEW:

 

============

C:\Users\ispal_000>net view\\192.168.1.1
The syntax of this command is:

NET
[ ACCOUNTS | COMPUTER | CONFIG | CONTINUE | FILE | GROUP | HELP |
HELPMSG | LOCALGROUP | PAUSE | SESSION | SHARE | START |
STATISTICS | STOP | TIME | USE | USER | VIEW ]

C:\Users\ispal_000>net view \\192.168.1.1
Shared resources at \\192.168.1.1

readyshare

Share name Type Used as Comment

---------------------------------------------------------------------------
Movies Disk read:all-no password;write:all-no password
USB_2.0_Storage Disk read:xxxxx;write:xxx
The command completed successfully.

====================

 

As for the 1231 error, check this out, https://community.netgear.com/t5/Nighthawk-WiFi-Routers/Problem-with-NET-VIEW-W10-R7000-most-recent-....

 

What version are you running? W10? I ask because your ADD FEATURES looks different from mine for SMB1? See capture on right.

Message 6 of 28
Guru

Re: www.routerlogin.net says no disk !

FWIW under "Available Network Folders" there is none listed - so no shared folder to access overt the network:

 

no available network folder.PNG

 

Unclear why there wasn't one created/propagated automatically pointing to the USB device root - worth to create one - example taken from a local R9000 here:

available network folders r9000.PNG

Message 7 of 28
Aspirant

Re: www.routerlogin.net says no disk !

@IrvSp 

Sorry, forgot to mention, I did also notice our SMB options looked different. I will have to check my W10 version. It is supposed to "auto update". 

But, nonetheless, 256MB vs any other verified valid drive that is larger. 

Message 8 of 28
Aspirant

Re: www.routerlogin.net says no disk !

 

@schumaku 

 

That is precisely my complaint. Mine is barren if I plug in anything other than that small drive. Your's shows your available network folder (931GB). 

Mine looks the same, with only 256MB. 

 

I am almost to the point of downgrading the firmware. But it is really aggrevating because NG Customer Service can't get this fixed. They were more of a flow chart fix than an expert. I hate to keep messing with it, literally 3 days and 2 routers of trying to get it to work. What are the chances it is somethign wrong with all the other formatted, blank, single partition drives... that Windows can't detect?

 

I thought NG products were solid. Now... not so much. Smiley Frustrated

 

Message 9 of 28
Master

Re: www.routerlogin.net says no disk !

Sorry, but I just NOTICED something. You have a R6700v3, right.

 

Only ONE USB port, right? It is USB 3.0. Drives not showing USB 2.0?

 

I've seen some other routers with really odd workings... like the USB 2.0 drive can't be read on some routers that have a USB 3.0 drive unless some USB 3.0 device is in the USB 3.0 port. When any USB 2.0 (or 3.0 for that matter) does the LED on top for USB 3.0 turn-on when it isn't showing in Readyshare?

 

Contact NG support if this is the case, the USB 3.0 port is NOT backwards compatible (and it wouldn't surprise me at all if this was true)?

Message 10 of 28
Aspirant

Re: www.routerlogin.net says no disk !

Correct. R6700V3. 

One Blue USB port in the front of the router. 

 

I think though however, the old 256MB flash drive I have is old... like USB1.0

I am not sure how to ascertain if the 8GB flash is USB1/2/3. 

The Western Digital I have, I is USB2. 

However, I have a 2TB Western Digital I know is USB3. But it has a load of data on it. May be worth a shot. 

 

 

I also saw this post: 

https://community.netgear.com/t5/Nighthawk-WiFi-Routers/Problem-with-NET-VIEW-W10-R7000-most-recent-...

 

powershell cmd:

Set-SmbServerConfiguration -EnableSMB1Protocol $false

 
 
Message 11 of 28
Master

Re: www.routerlogin.net says no disk !

@millcreekdr, that referenced link is mine Smiley Wink

 

USB 3.0 is easy to determine, the USB bar in the plug is BLUE, USB 2.0 are WHITE.

 

Putting in a LARGE drive might not be visible immediately. Seems the router had to build a catalog, FILES.DB in the .READYDLNA folder (not sure if it always does or only if DLNA is on (I think this is the default in the DLNA Server tab?).

 

SMB1 is required on W10 PC's to see the shares with native Windows Commands and Windows Explorer. I was all W10 and ALL PC's had to have it enabled to make the shares useable.

Message 12 of 28
Aspirant

Re: www.routerlogin.net says no disk !

How do I determine if my flash drive is USB2 or USB3. The USB port on the router is blue. 

Windows 10 Pro

Version 1803

OS Build 17134.523

Installed on 5/21/2018

 

Still not recognizing 8gb flash drive. 

smb.png

Message 13 of 28
Aspirant

Re: www.routerlogin.net says no disk !

plugged in wd 2tb drive. USB3.0. powered on. Computer recognizes. Plugged in to the router, and nothing. 

Message 14 of 28
Master

Re: www.routerlogin.net says no disk !

Simple, on the FLASH DRIVE, is the CONNECTOR BLUE inside like the USB 3.0 port or white or black? If  BLUE, USB 3.0, USB 2.0 could be either WHITE or BLACK, I've got both types.

 

Also, USUALLY there are marking on the flashdrive stating it somewhere.

 

Can't see the picture until a moderator approves it, can take a day or so possibly. Want it to be seen with your post, use the BROWSE button below the input area, locate the file, attach it, and it appears when the post does.

Message 15 of 28
Aspirant

Re: www.routerlogin.net says no disk !

downgraded firmware to R6700v3-V1.0.2.62_10.0.46

Still not resolved. 

After the downgrade of fw, my settings were all still valid. I "saved a copy of current settings" to my C:/... but did not need it. 

 

Plugged in USB3 WD 2TB (blue)

Nothing. 

Plugged in 8GB generic flash (black)

Nothing. 

Plugged in 256MB (white) flash. It works. 

 

The image shows SMB 1.0/CIFS File Sharing Support (Both Client and Server are checked)

 

 

 

Message 16 of 28
Aspirant

Re: www.routerlogin.net says no disk !

wd drive 30.png

Message 17 of 28
Aspirant

Re: www.routerlogin.net says no disk !

256 ok.png

Message 18 of 28
Master

Re: www.routerlogin.net says no disk !

Details please, this is useless to understand what you did (other than plugged it in), "Plugged in to the router, and nothing. ".

 

Surely it did something? Did the LED light go on?

 

How did you determine "nothing" happened?

Message 19 of 28
Aspirant

Re: www.routerlogin.net says no disk !

I plugged in my different USB devices to the USB3 port in front of the router. 

256MB works fine. I can create a network drive. I can access it. 

When I plug in any other USB drive (flash or external powered), no USB light. Also, going into the ReadyShare setup, it says NO USB DRIVE. Nothing shows up in the "available network folders" setup. If I click on Create Network Folder, a popup message comes up and says "www.routerlogin.net says No Disk."

 

Plug in the 256MB, I do get a USB light. And am able to setup network folder. 

 

It did nothing. Like the router does not recocnize any other usb device I have. 

 

It is perplexing. I have the theory and method down (proven by the 256MB)... but the router ignores every other usb drive. 

 

??????

Seems like it should just work like the 256MB, but it doesn't !

So confused. 

Message 20 of 28
Master

Re: www.routerlogin.net says no disk !

Router filesystem is not as robust as the PC's. Usually a drive over 4TB will not work. Picky about disk formats too. NTFS usually will work, other formats, hit or miss.

 

The fact the LED doesn't turn on either indicates to me the disk is NOT recognized. Either the disk format or partitioning. Router's only work it seems with single partition disks. Also will not read disks that are 'damaged', that is needs CHKDSK run on it. Take those that don't work to a PC and run CHKDSK /F on it. Might work after that.

 

Only self-powered disks (those with an external power supply) usually work, although Flashdrives don't have power supplies, they usually work. I've got 32GB models that work fine, in both USB 2.0 and 3.0.

 

Bottom line, it the LED doesn't turn on, the disk isn't read, and then nothing else can work or been seen on the router, including setup.

 

I guess you could have a damaged disk cable, but then it should not work with that cable on a PC? Possible port connnector on router problem? Bent pin or contact? Something stopping it from going all the way in?

 

Might have to contact NG support, could even be a faulty router I guess?

Message 21 of 28
Guru

Re: www.routerlogin.net says no disk !

Beyond of what @IrvSp  already mentioned, it could be USB power (router hardware, cable, ...) or the existence of some odd factory partitions (like the sometimes existing ISO partition holding some more or less useful software to control or "secure" the external USB disk.

 

Granted, what is supposed to be a reliable way for consumers to share a simple USB device is ways off from the reliability and simplicity required for this purpose.  

Message 22 of 28
Aspirant

Re: www.routerlogin.net says no disk !

Thanks. 

I have formatted the disks prior. I believe it was FAT. I will change to NTFS and see if that resolves it.

Actually

256MB unformatted and had some info on it. 1 single JPG. 

8GB formatted FAT. unrecognized when plugged in router. 

4GB with no data on it. Not sure of format. 

250GB with no data on it. 

 

So, my next step will be to format the 8GB again to NTFS (not quick format) then run chkdsk/f. 

If that doesn't work, format the 250GB external powered WD drive to NTFS and then run chkdsk/f

 

Each of these drives I had previously verified by putting some data on them via my PC. So I would expect the cables are good for the WD external drive. The flash drives obviously don't have cables and all appear to plug fully into the routers port. 

 

When I plug in the 8GB drive to the router, I did notice on the flash drive itself (not the router), has a very small red led that will flash a few times within 2 seconds. But the router USB light does not light or even blip a flash. 

 

I wonder if I copied over the files that are on the 256MB drive (.DNLA folder, etc), just copy everything that is on that drive to the 250GB WD powered external drive, then plug that it (NTFS)... if that would trick the router into thinking about it more (so to speak). 

 

 

Message 23 of 28
Guru

Re: www.routerlogin.net says no disk !

Possible issues are coming from potential hidden partitions - just formatting what appears to the common computer to be the "only" volume does not change much.

Just in case - there is no exFAT support available.
Message 24 of 28
Master

Re: www.routerlogin.net says no disk !

Don't bother running CHKDSK after  a FORMAT. Should NEVER fail CHKDSK.

 

When running CHKDSK use the '/F' parameter only. The result WILL show you the FileSystem used:

 

========

C:\>chkdsk p:
The type of the file system is NTFS.
Volume label is P_Drive.

==========

 From a CMD prompt that is running as an Administrator you can issue DISKMGMT and see the drive (connected to the PC of course) like the one in the capture on the right. That is my 4TB USB 3.0 MyBook I use on the router occasionally.

 

Also in that Administrator CMD promp you can run DISKPART which enters the program. Enter LIST DISK to see what is assigned to the disk as a number:

 

======

DISKPART> list disk

Disk ### Status Size Free Dyn Gpt
-------- ------------- ------- ------- --- ---
Disk 0 Online 931 GB 42 MB *
Disk 1 Online 111 GB 1024 KB *
Disk 2 Online 931 GB 0 B
Disk 3 No Media 0 B 0 B
Disk 4 No Media 0 B 0 B
Disk 5 No Media 0 B 0 B
Disk 6 No Media 0 B 0 B
Disk 7 Online 3726 GB 0 B *

=========

 

The select that disk and list the partitions:

 

===============

DISKPART> select disk 7

Disk 7 is now the selected disk.

DISKPART> list part

Partition ### Type Size Offset
------------- ---------------- ------- -------
Partition 1 Primary 3726 GB 1024 KB

===============

 

For a 'bad' example, this is my BOOT drive:

 

=====

DISKPART> sel disk 1

Disk 1 is now the selected disk.

DISKPART> list part

Partition ### Type Size Offset
------------- ---------------- ------- -------
Partition 1 Recovery 450 MB 1024 KB
Partition 2 System 100 MB 451 MB
Partition 3 Reserved 16 MB 551 MB
Partition 4 Primary 110 GB 567 MB
Partition 5 Recovery 460 MB 111 GB

==============================

 

Would NOT work in the router if I were to use it there.

 

With those two commands you should be able to tell what is each drive like. Drives must be physically attached to the PC, can not be Network Attached drives.

 

Message 25 of 28
Top Contributors
Discussion stats
  • 27 replies
  • 2693 views
  • 0 kudos
  • 3 in conversation
Announcements