× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Orbi WiFi 7 RBE973
Reply

GUI language file is invalid

ChuyLupita
Follower

GUI language file is invalid

I am having an issue updating the Nighthawk RAX50 AX6 6-Stream AX5400 WiFi 6 Router and getting the error "GUI language file is invalid".

 

Current GUI Language Version: 1.0.2.20_2.1.46.1
New GUI Language Version: 1.0.2.28_2.1.46.1
Current Firmware Version 1.0.2.20
New Firmware Version 1.0.2.28

 

How can i the router to update without having to manually do it?

Message 1 of 3
Christian_R
NETGEAR Employee Retired

Re: GUI language file is invalid

Hi ChuyLupita, 

 

You may use the Nighthawk app to update the firmware on your router.

 

Christian 

Message 2 of 3
phomazing
Aspirant

Re: GUI language file is invalid

I encountered the same issue trying to update the router firmware through the web browser as well.

Used the Netgear iOS app and was able to get the update to work.

Annoying bug, but at least the workaround worked.

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 4822 views
  • 2 kudos
  • 3 in conversation
Announcements

Orbi 770 Series