× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Orbi WiFi 7 RBE973
Reply

Nighthawk AX2400 (RAX30) not forwarding port 8123

Psyonic
Aspirant

Nighthawk AX2400 (RAX30) not forwarding port 8123

My old N600 (which has been great for the last 12 years) decided that yesterday was it's last day in my service (she died) so I brought a Nighthawk AX2400.

 

I have a Home Assistant server running and need to set up port forwarding to it.

It uses port 8123 natively but setting up the router to take port 8123 as the external port does not work. If I choose a different port, say port 9000 as the external port it works just fine.

 

This does not work:

Psyonic_0-1660127998615.png

 

This does work:

Psyonic_1-1660128074040.png

 

Does anyone know what's happening? The logs look as though the connection is made, but the browser trying to make the connection eventually just times out.

Psyonic_2-1660128235539.png

I have set up port forwarding many times on different routers in the past and never encountered this, perhaps it's a bug in the firmware when both external and internal ports are the same??

When I do an nmap scan with port 9000 open it gets reported as open, but configured for port 8123 it does not.

 

Secondary question:

nmap shows several ports open that I cannot find any setting that would cause them to be open, I know I can explicitly block them, but why are they open without my consent? Am I simply missing a setting somewhere that enables their service?

I understand why some are open automatically, but others I should have control over, or is this just how things are done these day? (I'm oldskool)

Ports in question:

22/tcp filtered ssh
23/tcp filtered telnet
139/tcp open netbios-ssn
445/tcp open microsoft-ds
8200/tcp open trivnet1

 

Thanks 😊

 

Firmware version: V1.0.6.74_1

 

 

Message 1 of 6

Re: Nighthawk AX2400 (RAX30) not forwarding port 8123

I'm a bit puzzled by where the internal IP address in there came from.

 

I wouldn't expect to see 192.168.0.1.

 

By default your router likes to squat on 192.168.1.1.

Something carried over from your anonymous N600 device?

 

 

 

 

 

 

 

 

 

 

Message 2 of 6
Psyonic
Aspirant

Re: Nighthawk AX2400 (RAX30) not forwarding port 8123

Hey @michaelkenward 

The internal address is the address of my Home Assistant server, it's where I want any data that comes into the router from the outside world on port 8123 to be forwarded to

Message 3 of 6
Psyonic
Aspirant

Re: Nighthawk AX2400 (RAX30) not forwarding port 8123

@michaelkenwardOh, I should read better 🤣

192.168.0.1 is the address I've always given my routers, I change it from default coz most of my devices have static IPs... Just a thing in my head from setting up Linux PC's as modem/LAN/firewalls from back in the dial-up days. Not wise these days?? Didn't think it mattered? But I haven't done much networking since those days

Message 4 of 6

Re: Nighthawk AX2400 (RAX30) not forwarding port 8123

Makes sense. I was just a bit puzzled by the "out of the ordinary" setting.

 

That IP address has sometimes revealed extra devices on the network that get in the way of the router.

 

I also fix IP addresses on various devices on the network.

 

 

Message 5 of 6
Psyonic
Aspirant

Re: Nighthawk AX2400 (RAX30) not forwarding port 8123

Thanks man...

Any thoughts on why 8123 would not be aloud to be open? makes no sense to me and it's worked on other routers

Message 6 of 6
Discussion stats
  • 5 replies
  • 1009 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi 770 Series