× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Orbi WiFi 7 RBE973
Reply

RAX20|AX 1800 v1.0.4.100_2.0.64 routing getting getting blocked at the switch (static routes)

knite
Aspirant

RAX20|AX 1800 v1.0.4.100_2.0.64 routing getting getting blocked at the switch (static routes)

Goal:

Connect a private network setup on Hyper-v to local lan & Internet.

 

Diagram:

Internet {
    RAX20 (10.0.0.0/24) {
        RAX20:       10.0.0.1
        desktop_pc:  10.0.0.10
        gatewayvm:   10.0.0.100 - 1st nic
                     192.168.100.1 - 2nd nic
    }
}

Note:  additional vms on 192.168.100.0/24 subnet use 192.168.100.1 as gateway (these are on the private network setup with hyper-v)

 

Previous experience:

I set this up before with another Netgear router and everything worked perfectly.

 

Expected behavior:

I documented all the steps and performed the same steps this time.  Expected the same result

 

Actual behavior:

All systems on the LAN work and can communicate.  All systems on the private lan can communicate with each other and the local LAN.  However they are unable to route past the RAX20.  For example, if I use "curl http://google.com" it times out.  If I use tracepath it stops at the RAX20.

 

Static Route:

Active:                        checked

Destination IP:            192.168.100.0

IP Subnet Mask:         255.255.255.0

Gateway IP Address:  10.0.0.100

Metric:                         3 (have tried 2, 3, & 10)

 

gatewayvm:

$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         _gateway        0.0.0.0         UG    25     0        0 eth1
10.0.0.0        _gateway        255.255.255.0   UG    25     0        0 eth1
10.0.0.0        0.0.0.0         255.255.255.0   U     101    0        0 eth1
192.168.80.0    0.0.0.0         255.255.255.0   U     100    0        0 eth0

Request:

I think everything might actually be setup correctly as far as the static route, and the systems on the private network, however since the packets are stopping at the RAX20 I feel like there may be an option to enable/disable on the RAX20 that is needed to get this working.

 

Link to howto instructions:

https://www.travisloyd.xyz/2021/09/04/a-separate-ip-range-for-each-onprem-kubernetes-cluster/

 

Message 1 of 4

Accepted Solutions
knite
Aspirant

Re: RAX20|AX 1800 v1.0.4.100_2.0.64 routing getting getting blocked at the switch (static routes)

Set netmask on internet ip to one that includes the subnet of the private network, e.g. 255.255.0.0 .

View solution in original post

Message 4 of 4

All Replies
knite
Aspirant

Re: RAX20|AX 1800 v1.0.4.100_2.0.64 routing getting getting blocked at the switch (static routes)

Unable to edit the question, that 80 was a typo, should be 100.

Message 2 of 4
knite
Aspirant

Re: RAX20|AX 1800 v1.0.4.100_2.0.64 routing getting getting blocked at the switch (static routes)

Additional notes:

  • From within the private network I am able to join the system to the domain which exists on the local lan, this shows ip_forward is working on the gateway system (the system with two nics, one connect to the RAX20 and one connected to the private network)
  • I am able to maintain a connection from the local LAN to a system on the private lan > 1 minute, this shows there is no multipath issues.
  • Noticed tracepath is blocked when using its default settings (it must be that th RAX20 is blocking UDP), using -T makes it work.
  • Tracepath from within the private network stops at the RAX20.  This traceroute from within the private network should be reaching the Internet providing switch website which the RAX20 is connected to, but is unable to.
    [192.168.100.10]
    $ sudo traceroute -T 192.168.1.1 traceroute to 192.168.1.1 (192.168.1.1), 30 hops max, 60 byte packets 1 _gateway (192.168.100.1) 0.688 ms 0.680 ms 0.676 ms 2 10.0.0.1 (10.0.0.1) 1.598 ms 1.670 ms 1.667 ms 3 * * *
  • Here is the same tracepath running on the gateway system (the system with two nics connected to both the RAX20 and the private network):
    [10.0.0.100 & 192.168.100.1]
    $ sudo traceroute -T 192.168.1.1 traceroute to 192.168.1.1 (192.168.1.1), 30 hops max, 60 byte packets 1 _gateway (10.0.0.1) 1.007 ms * * 2 192.168.1.1 (192.168.1.1) 2.012 ms 2.018 ms 2.010 ms
  • The previous trace shows the gateway system (the system with two nics connected to both the RAX20 and the private network) knows how to reach 192.168.1.1 and is able to.  In the trace before that a system on the private network reaches the RAX20 via the gateway system but gets stopped at the RAX20 for some reason.
Message 3 of 4
knite
Aspirant

Re: RAX20|AX 1800 v1.0.4.100_2.0.64 routing getting getting blocked at the switch (static routes)

Set netmask on internet ip to one that includes the subnet of the private network, e.g. 255.255.0.0 .

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 1108 views
  • 0 kudos
  • 1 in conversation
Announcements

Orbi 770 Series