× Introducing the Orbi 970 Series Mesh System with WiFi 7 technology. For more information visit the NETGEAR Press Room.
Orbi WiFi 7 RBE973
Reply

Re: RAX20 - Certain Devices Taking Forever to Connect

birdwing
Aspirant

RAX20 - Certain Devices Taking Forever to Connect

I have had this RAX20 router for a few months now. It's gotten to the point where I have to reset it daily in order for my WiZ smart bulbs to connect in less than 5-10 minutes (not an exaggeration). 

 

Firmware Version V1.0.11.112_2.0.77

Modem Connected: Arris SURFboard SB6190 in Bridge mode 

 

On my RAX20 I have DHCP turned off because I am running Adguard home on my network as the DHCP server.
All my IoT devices have a reserved DHCP lease through Adguard.

 

If I turn off the smart bulbs and turn them on within 5-30 minutes they reconnect just fine to the network.
However if I turn them off and go to bed for 6-8 hours when I get up in the morning they take about 5-10 minutes to connect.

If I restart the modem while the bulbs are struggling to connect, they connect in seconds after the router comes back on.

 

The only thing I see in the logs for this is:
[WLAN access rejected: incorrect security] from MAC address **:**:**:**:**:**, Sunday, Aug 20, 2023 07:16:50

 

I did have Access Control turned on as I was using that to setup schedules for turning devices off.
I have tried turning of Access Control and it doesn't help. Even after turning off Access Control I am still getting the WLAN access rejected error message.

 

I currenlty have 2.4 and 5ghz sharing the same SSID. I have disabled MU-MIMO, OFDNA (on the 2.4Ghz network which is the one the bulbs use), and WMM.

 

I have used wifi analyzer to move my network channels to uncrowded channels, and I have turned on 20/40Mhz coexistence.

 

I am at a loss, my best guess is that the RAX20 router has serious issues with another device on the network handling the DHCP leases, but before going through the hassle of reconfiguring all my devices to use the router for DHCP I wanted to see if I missed anything else. I do have traffic meter turned on, but I don't know how that would cause any issues (unless the CPU on this thing is such a potato that counting traffic overwhelms it). I have literally every other feature of this router turned off now. The only thing left (other than the wifi networks) is OFDNA on the 5ghz network and traffic monitor.

Message 1 of 10

Re: RAX20 - Certain Devices Taking Forever to Connect


@birdwing wrote:

.... my best guess is that the RAX20 router has serious issues with another device on the network handling the DHCP leases, but before going through the hassle of reconfiguring all my devices to use the router for DHCP


 

Sounds like a good guess. What happens if you let the router handle DHCP?

 

It may be a pain, but it is probably the only way of confirming your suspicions. Anything else is guesswork.

 

I do have traffic meter turned on, but I don't know how that would cause any issues (unless the CPU on this thing is such a potato that counting traffic overwhelms it).

 

You could turn off traffic meter, It is known to slow things down. And the RAX20 is hardly top of the range.

 

Using it with DHCP turned off could also be asking for trouble.

 

 

Message 2 of 10
pec967
Luminary

Re: RAX20 - Certain Devices Taking Forever to Connect

I think the key clue to this problem is the error message:


[WLAN access rejected: incorrect security] from MAC address **:**:**:**:**:**, Sunday, Aug 20, 2023 07:16:50

 

What happens if you downgrade your Wireless security option from WPA2-PSK [AES] to  WPA-PSK [TKIP] + WPA2-PSK[AES]?

 

 

Message 3 of 10
Kitsap
Master

Re: RAX20 - Certain Devices Taking Forever to Connect

As you have toggled the RAX20 features for Access Control and Traffic Meter, simply changing the check mark does not always clear the internal feature settings.  After you change these settings one way or the other, it is always good practice to restart your device (pull the power cord and reconnect).

 

iOT devices have varying degrees of sophistication and some work better with the original 2.4 GHz Wi-Fi band at the 20 MHz channel width.  Turning off the 20/40 MHz coexistence may help.

 

It could also help to set a fixed channel for your 2.4 GHz band and turn off smart connect.

 

 

 

 

 

 

Message 4 of 10
birdwing
Aspirant

Re: RAX20 - Certain Devices Taking Forever to Connect

WiZ bulbs support WPA2 for security.
If this was the issue the bulb would never connect. It eventually does. There are so many things that can trigger that error message that it's a borderline useless message. Even interference with neighboring networks can trigger that error message.
Message 5 of 10
birdwing
Aspirant

Re: RAX20 - Certain Devices Taking Forever to Connect

I have restarted my router after changing settings.

I turned on 20/40Mhz coexistence after the fact in an attempt to mitigate interference with neighboring wifi networks. The issue existed before that was turned on.

I haven't set a fixed channel for 2.4Ghz because of all the neighbors... I live in an apartment. I feel like whenever I set a fixed channel every other router around me decides to move to that channel.

Are there any benefits to a fixed channel that outweigh the routers ability to move away from crowded channels?

I have smart connect disabled already.
Message 6 of 10
birdwing
Aspirant

Re: RAX20 - Certain Devices Taking Forever to Connect

I am trying my hardest to keep DHCP off the router seeing as adguard is so much more convenient.
I will try turning off traffic meter and see if that helps.

In my opinion if the router is unable to function with DHCP off (having another DHCP server on the network) then Netgear either needs to fix their firmware or remove the ability to turn it off.

I will eventually try moving DHCP back to the router to confirm those suspicions, I just want to check all other avenues first... Seeing as that would be a PITA.
Message 7 of 10
Kitsap
Master

Re: RAX20 - Certain Devices Taking Forever to Connect


@birdwing wrote:
I haven't set a fixed channel for 2.4Ghz because of all the neighbors... I live in an apartment. I feel like whenever I set a fixed channel every other router around me decides to move to that channel.

Are there any benefits to a fixed channel that outweigh the routers ability to move away from crowded channels?


I think you are correct to leave the auto channel selection enabled.  I was unaware of your crowded RF environment.

 

My primary intent was to lessen the workload on your router and thus the time it takes to execute.  Disabling items like traffic meter and access control help do this.  Your RAX20 does not have the most capable cpu for a router.

 

 

 

 

 

Message 8 of 10
birdwing
Aspirant

Re: RAX20 - Certain Devices Taking Forever to Connect

Well. Nothing worked.
The bulbs worked great for two weeks and now they are unusable. My only explanation at this point is that it's the bulbs themselves, that somehow the wifi chips in the bulbs have damaged themselves in that two week period.

I even connected them via matter to a sonoff dongle, getting them off the router and no luck. They didn't connect at all until I turned the router back on, which means that they don't actually support Matter like WiZ claims.

Moral of the story, don't by wifi bulbs.
Message 9 of 10
Kitsap
Master

Re: RAX20 - Certain Devices Taking Forever to Connect


@birdwing wrote:
Well. Nothing worked.
The bulbs worked great for two weeks and now they are unusable. My only explanation at this point is that it's the bulbs themselves, that somehow the wifi chips in the bulbs have damaged themselves in that two week period.

I even connected them via matter to a sonoff dongle, getting them off the router and no luck. They didn't connect at all until I turned the router back on, which means that they don't actually support Matter like WiZ claims.

Moral of the story, don't by wifi bulbs.

I tend to agree.  They are a novelty item at best.

 

 

Message 10 of 10
Discussion stats
  • 9 replies
  • 639 views
  • 0 kudos
  • 4 in conversation
Announcements

Orbi WiFi 7