× Introducing the Orbi 970 Series Mesh System with WiFi 7 technology. For more information visit the NETGEAR Press Room.
Orbi WiFi 7 RBE973

Re: Revoked security certificate with remote login


Revoked security certificate with remote login

I have a RAX120 for over a year now that has a remote login issue which I have been troubleshooting "as time permits". I have set the RAX120 up for remote login to a static IP; https//:x.x.x.x:8080. In the past I have used other Netgear routers , Linksys routers, etc. for this connection without issue. Locally on the LAN I can log into the RAX120 from either from my laptop by accessing routerlogin.net or via the local IP for the router and as well from my iPhones "NightHawk" app.
But when I try to log in remotely over the web with either Edge or Chrome I receive:
Chrome shows that "This Certificate is OK" under Certificate Status
When I check the certificate info I see that the certificate is pointed to www.routerlogin.net and is valid until Thursday, July 29, 2021 8:53:50 PM.
I have updated the router firmware, I am using Win10 which is recently completely updated. At one point in the past, when I first installed the RAX120 I swear the remote login from web IP worked just fine.
I have looked around and I have done some research but I have found nothing conclusive, however I realize that this has some connection issue to routerlogin.net
I need suggestions or an answer to resolve my remote login problem.


Model: RAX120|Nighthawk AX12 12-Stream WiFi Router
Message 1 of 9

Re: Revoked security certificate with remote login

I used a Win 7 laptop to try and log in remotely to the router and that version of Explorer gave me security certificate warnings, but still provided me a link to "Proceed Anyways", which I used and I was able to successfully log in.

I believe that this tells me that the issue is with the NETGEAR security certificate and not with the browser settings...

Message 2 of 9

Re: Revoked security certificate with remote login

I have completely read the user manual in regards to remote management from a computer and as well concerning the Nighthawk app with regards to accessing the router with a mobile phone.

1. In my case, I can access the router remotely with the Nighthawk app.

2. I can access the router remotely using google or edge on my phone and entering the https://x.x.x.x:8080 IP address

3. I can access the remote router on a Win 7 PC, althought it throws a certificate error and I am allowed to "Proceed" with both Edge and Chrome

4. I cannot access the remote router on a Win 10 PC with either Chrome or Edge because the ssl certificate error is "Certificate is Revoked" and there is no option to proceed.

Message 3 of 9

Re: Revoked security certificate with remote login

I am beginning to feel as though I am the only person with this problem or that I am totally overlooking something completely obvious.

But then, maybe I am the only one wanting to talk about it. 🙂

So, after more investigating, what I did recently was to lower all the security levels to their lowest level for "Internet Options", included both routerlogin.net and my routers remote IP address into "trusted sites" and then I created a desktop shortcut for MSIE, included my routers IP address-port as part of the target and then executed the shortcut as "Run As Administrator".

That did not change anything. It still throws the certificate error.

So then I created a Chrome desktop shortcut which included "--ignore-certificate-errors" plus my routers IP address-port and that actually allowed me to get the credentials sign-in box without any issue. So, there is a "Work-Around" per se in Chrome. But it's not a fix, it's still a bandaid.

However in MSIE, there seems to be the typical MS "hamstringing" issue of protecting me from myself even if I am versed enough to make several technical changes.... therefore, it's not possible to get MSIE to disregard certificate errors for an individual WAN IP address. I did see that there is a way to make registry changes to disregard all certificate errors for all addresses, but I did not explore that option.

Now, I may be out in Left Field somewhere, but it appears at this juncture that "WIN10, MSIE, Chrome", depending on what WIN10 service level upgrade is being executed, interprets routerlogin.net as a potential intermediary interception threat because WIN10 is looking for one thing and getting two. One from my Netgear router and one from routerlogin.net which is where the view certificate link points to. I think the way WIN10 deals with that is WIN10 "Revokes" the certificate locally, that causing the "Revoke" error with the view certificate reporting that the certificate is "OK".

I am going to try a few more things.

I'll be back.....



Message 4 of 9
NETGEAR Employee Retired

Re: Revoked security certificate with remote login

Hello additude, 


Thanks for writing a detailed description of your issue. Looking forward to your next update! Please feel free to private message me if you're still having issues. 




Message 5 of 9

Re: Revoked security certificate with remote login

Thanks Christian,

I will....

For as of now, the only working solution I have is Chrome browser with --ignore_certificate_errors (which Chrome complains about as unsupported) followed by my https://xxx.xxx.xxx.xxx:8080 Remote Login IP address or my Win 7 Laptop....


Unfortunately this morning, that IP address is not responding so it could be the Spectrum modem set to bridge or... hopefully not, the RAX 120 is locked up..... with the current lockup issues .... oh well, I'll see later. I am remote to that router at this time.



Message 6 of 9

Re: Revoked security certificate with remote login

I have the same issue on my R9000 on Macbook and there is no way I can overide it in either Safari, firefox or Opera.


@Christian_RWill Netgear going to fix the certificate issue? Is there any way to bypass this is Mac OS? I am running Mac OS Catalina.

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 7 of 9

Re: Revoked security certificate with remote login

I have the same issue on a R9000. I am using a MacBook Pro to access a Windows 10 Home desktop remotely using teamviewer. I am accessing the router then locally through both MS Edge and Chrome. I have added the routers trusted certificate to Windows 10 certificate store as Netgear support indicates in their steps. The certificate shows it has been added to the store successfully and the certificate expiration is still current. The certificate always indicates revoked and I have tried https for all domain names on the certificate with no success. Any overide I have tried shows revoked certificate but is none the less an inconvenience as this needs to be corrected. Please Netgear fix this.
Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 8 of 9

Re: Revoked security certificate with remote login

It's still broken for me as well and the only bandaid I was able to figure out for my Windows 10 machine was:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --ignore-certificate-errors https://your.wan.ip.here:8080

Where 8080 is the remote port. I think the default is 8080 .... 


Message 9 of 9
Discussion stats
  • 8 replies
  • 0 kudos
  • 4 in conversation

Orbi WiFi 7