Reply
Highlighted
Follower

RBR850 debug screen No Telnet Option

Hello All, I have a Orbi RBR850 that works great however, I need to seperate out the 2.5 & 5 bands and name them different so some of my older devices will connect to 2.5 & not time out trying to connect to the 5 since they share the ssid name

 

I came across a 192.168.1.1/debug.htm login to enable telnet so I can command line the script to fix this, however the telnet check box doesnt exist on that page. There is only debugging options and log scanning options. Does anyone know how I can turn on telnet services on this unit? Or is there a different page with the new firmware of these devices?  Its currently on a 3.15.2 I believe.


Thanks so much

 

AP

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 22
Highlighted
Guru

Re: RBR850 debug screen No Telnet Option

Please post about this over in the Orbi AX Forum:

https://community.netgear.com/t5/Orbi-AX/bd-p/en-home-orbi-ax

 

Thank you. 


@AP4120 wrote:

Hello All, I have a Orbi RBR850 that works great however, I need to seperate out the 2.5 & 5 bands and name them different so some of my older devices will connect to 2.5 & not time out trying to connect to the 5 since they share the ssid name

 

I came across a 192.168.1.1/debug.htm login to enable telnet so I can command line the script to fix this, however the telnet check box doesnt exist on that page. There is only debugging options and log scanning options. Does anyone know how I can turn on telnet services on this unit? Or is there a different page with the new firmware of these devices?  Its currently on a 3.15.2 I believe.


Thanks so much

 

AP


 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 2 of 22
Highlighted
Prodigy

Re: RBR850 debug screen No Telnet Option


@AP4120 wrote:

Hello All, I have a Orbi RBR850 that works great however,
...

Does anyone know how I can turn on telnet services on this unit? Or is there a different page with the new firmware of these devices?  Its currently on a 3.15.2 I believe.


My Orbi AX is running the latest V3.2.15.25_1.3.15 firmware.  As you say, the Enable Telnet checkbox option no longer exists on the /debug.htm page.  I previously turned on Telnet when my Orbi was running an older firmware.  I can confirm that telnet still works with my Orbi even though the checkbox no longer appears on that debug page.

 

Therefore you could probably downgrade to an earlier firmware, enable telnet, and then upgrade back to the current firmware.

Message 3 of 22
Highlighted
Sensei

Re: RBR850 debug screen No Telnet Option


@Mikey94025 wrote:

My Orbi AX is running the latest V3.2.15.25_1.3.15 firmware.  As you say, the Enable Telnet checkbox option no longer exists on the /debug.htm page.  I previously turned on Telnet when my Orbi was running an older firmware.  I can confirm that telnet still works with my Orbi even though the checkbox no longer appears on that debug page.

That seems almost "too good to be true."  On my RBR50, enabling telnet does not survive a reboot, much less a firmware change. And, if I go too long between connecting with telnet, the option no longer works even though the check box says it should.

I love my Orbi.
Message 4 of 22
Highlighted
Guru

Re: RBR850 debug screen No Telnet Option

Even if that was true, any factory reset would probably disable telnet. NG maybe stopping the behind the scenes tweekers that are afforded on Orbi AC. 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 5 of 22
Highlighted
Apprentice

Re: RBR850 debug screen No Telnet Option

Try https://github.com/insanid/netgear-telenetenable

 

This worked for me on a RBR750.

 

The debug.htm page on that one has JavaScript that disables the "enable telnet" button.

Presumably, if you curled it it would still work.

 

Very bizarre, but insanid's script still worked for me.

Message 6 of 22
Highlighted
Prodigy

Re: RBR850 debug screen No Telnet Option


@CrimpOn wrote:


That seems almost "too good to be true."  On my RBR50, enabling telnet does not survive a reboot, much less a firmware change. And, if I go too long between connecting with telnet, the option no longer works even though the check box says it should.


Ah, someone posted that with the latest RBR850 firmware telnet is always enabled.   That would explain why my telnet still works and perhaps why you see different behavior with your RBR50.

 

Message 7 of 22
Highlighted
Guru

Re: RBR850 debug screen No Telnet Option

I would confirm that a factory reset hasn't been performed on that post. If Telnet was enabled and carried forward thru a FW and and the system was NOT factory reset, then  I would presume telnet may persist thru the update. If a factory reset was performed on the system, I can confirm that telnet is not enabled as I have done with my system, and can not access telnet at all with default FW settings after the reset. 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 8 of 22
Highlighted
Apprentice

Re: RBR850 debug screen No Telnet Option

No factory reset is needed. A simple reboot of the router re-disables the telnet interface for me, at least if it was enabled with the specially crafted telnet packet.

Message 9 of 22
Highlighted
Prodigy

Re: RBR850 debug screen No Telnet Option


@gb777 wrote:

No factory reset is needed. A simple reboot of the router re-disables the telnet interface for me, at least if it was enabled with the specially crafted telnet packet.


Strange... On my RBR850 rebooting does not disable Telnet for my unit.  I've tested twice now and I can still telnet to 192.168.1.1.  I'm running V3.2.15.25_1.3.15 and enabled telnet using the Debug page on an older firmware.

 

 

Message 10 of 22
Highlighted
Apprentice

Re: RBR850 debug screen No Telnet Option

It's possible that there is some setting in their nvram that survives reboots. My router never had the telnet interface enabled under an older firmware, I bought and upgraded the firmware to the version where the "enable telnet" button doesn't show on the debug.htm webpage.

 

FWIW:

 

root@RBR750:/# nvram show | grep -i telnet
telnetd_enable=0

maybe that's it.

Message 11 of 22
Highlighted
Prodigy

Re: RBR850 debug screen No Telnet Option

Thanks.  For comparison this is what my RBR850 does:

root@RBR850:/# uptime
 15:44:53 up  2:37,  load average: 1.42, 1.48, 1.45
root@RBR850:/#
root@RBR850:/# nvram show | grep -i telnet
telnetd_enable=1
Message 12 of 22
Highlighted
Apprentice

Re: RBR850 debug screen No Telnet Option

root@RBR750:/# nvram set telnetd_enable=1
root@RBR750:/# nvram show | grep -i telnet
telnetd_enable=1

the next time my family approves a gap in netflix/youtube traffic I'll reboot the router and try it out .... ;-)

Message 13 of 22
Highlighted
Apprentice

Re: RBR850 debug screen No Telnet Option

unfortunately, the `nvram set telnetd_enable` did not stick. Upon a simple reboot (RBR750), I had to reenable telnet.

 

Odd. Does someone know more about the `nvram` settings and how to make them stick?

Message 14 of 22
Highlighted
Apprentice

Re: RBR850 debug screen No Telnet Option

Problem solved. Forgot to add nvram commit after nvram set telnetd_enable=1

Message 15 of 22
Highlighted
Aspirant

Re: RBR850 debug screen No Telnet Option

I found that “downgrading” to the oldest firmware on the support page allowed me to enable telnet. Access was still intact after re-upgrading to the latest firmware. Hope that helps.
Message 16 of 22
Highlighted
Guru

Re: RBR850 debug screen No Telnet Option

telnet can be enabled on current v6 FW as well using the telnetenabler from the git repo that out on the net. 


@Modernz wrote:
I found that “downgrading” to the oldest firmware on the support page allowed me to enable telnet. Access was still intact after re-upgrading to the latest firmware. Hope that helps.

 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 17 of 22
Highlighted
Tutor

Re: RBR850 debug screen No Telnet Option

when do you get the mac address for the lan port from?

 

does this mean I need to be connected to the router via ethernet rather than wifi to run the script?

Message 18 of 22
Highlighted
Guru

Re: RBR850 debug screen No Telnet Option

From the sticker under the RBR. Probably either connection will work. 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 19 of 22
Highlighted
Prodigy

Re: RBR850 debug screen No Telnet Option


@parisv wrote:

when do you get the mac address for the lan port from?


The MAC address for the LAN port is also displayed on orbilogin.com / Advanced tab, under Router Information.  The MAC address for the upstream internet connection is under Internet Port.

 

Message 20 of 22
Highlighted
Tutor

Re: RBR850 debug screen No Telnet Option

ok I've tried the command from cmd in admin mode exactly the way the readme says it should run and telnet is still not working.

 

is it possible to get an output of the python script to see if it's actually working?

Message 21 of 22
Highlighted
Guru

Re: RBR850 debug screen No Telnet Option

If the script executed with out any errors, then telnet should be working. 

Can you access the telnet using teraterm or putty at all? The one time I did it it worked for me on my 8 series RBR.


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 22 of 22
Top Contributors
Discussion stats
  • 21 replies
  • 1820 views
  • 2 kudos
  • 7 in conversation
Announcements