Reply

Re: RB-50 network is running fine but app says 'no internet connection' - can not get into app

blackSP
Aspirant

RB-50 network is running fine but app says 'no internet connection' - can not get into app

Like the title says, my RB-50 network is running fine but the orbi app on my huawei mate 20 pro says 'no internet connection' after I had to do a factorey reset of my phone. So I cannot get into app, previously no problems. Reinstalled the app a few times,reset my ISP modem just to be sure, reset the RB-50 plus sattelite. network comes up fine, all my device have internet connection, can access the RB50 through 192.168.1.1 just fine.

 

Running this firmware: https://kb.netgear.com/000061838/RBR50-RBS50-Firmware-Version-2-5-1-16

Just to be sure I installed the orbi app on an old tablet. After adding at as trusted I can open the app just fine.

 

Any ideas? Keep the tablet for this is not an option, it's really old and can fall appart any day now ;}

Message 1 of 10
blackSP
Aspirant

Re: RB-50 network is running fine but app says 'no internet connection' - can not get into app

If anybody knows how to fix this, I would really appreciate some pointers.

Thanks

Message 2 of 10
blackSP
Aspirant

Re: RB-50 network is running fine but app says 'no internet connection' - can not get into app

Wow, this must be the most helpful brand supported forum ever. Are there really no Netgear folks here that have an idea? OK, I can access the unit through my browser but I really want to be able to use the app, which I no longer can...

Message 3 of 10
Christian_R
NETGEAR Moderator

Re: RB-50 network is running fine but app says 'no internet connection' - can not get into app

Hello blackSP, 

 

Does the same issue persist on another mobile device? May you provide the current app version you have installed on that device. You may also use the link the below to get in contact with our support team. 

 

https://www.netgear.com/support/default.aspx

 

Christian 

 

Message 4 of 10
byasutomi
Aspirant

Re: RB-50 network is running fine but app says 'no internet connection' - can not get into app

My issue started today 7/29/20.  I am trying to figure this out now because after a year my wifi is now not working.

Message 5 of 10
blackSP
Aspirant

Re: RB-50 network is running fine but app says 'no internet connection' - can not get into app

Hi, thanks for responding. I almost gave up on the RBR50's so I stopped checking here. I'll install the app on a friends phone to check if it works there. I'm running the latest app from google play (2.6.0.1214). FYI, I run quite a lot of connectivity apps, also for my work's networks, and Netgear is the only one that gives this problem. Will get back soon!

Message 6 of 10
blackSP
Aspirant

Re: RB-50 network is running fine but app says 'no internet connection' - can not get into app

OK, just installed the latest version on a Huawei Mate 10 running Android 10 and it works fine there.

On my Huawei Mate 20 running Android 10.1 there's no way I get ot to connect to my network, whatever I do it says 'no internet connection'. Obviously my phone is connected to my 250 mb/s wifi network, just as 6 or 7 other devices.

 

I already cleard app cach, dalvik cache, reinstalled the latest 10.1 rom trough e-recovery, uninstalled, reinstalled the Orbi app.

 

So, what's next?

I can contact support but I rather have a public discussion so others can benefit for the results.

Thanks,

Rob

Message 7 of 10
blackSP
Aspirant

Re: RB-50 network is running fine but app says 'no internet connection' - can not get into app

I'm selling the overprized Netgear Orbi RB50 rubish routers.

Know why? Because Netgear does not care about their customers.

 

You pay an awful amount of euros to get the 'best of the best' and than trouble starts with no help from the company.

 

Very sad.

Message 8 of 10
byasutomi
Aspirant

Re: RB-50 network is running fine but app says 'no internet connection' - can not get into app

My cousin's bf fixed it and I do not know what he did.  It is something in the settings when you go on the actually settings in the computer.  I had to pay for the tech service twice and they couldnt help.  Dealing with the return has been a bigger nightmare than trying to figure out how to get the internet back on.

Message 9 of 10
blackSP
Aspirant

Re: RB-50 network is running fine but app says 'no internet connection' - can not get into app

Given the overwhelming support Netgear gives to their most valued customers I trully recommend to buy their most expensive top of the line products.

 

NOT

 

Shame on you Netgear.

I'm being very polite now...

Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 566 views
  • 0 kudos
  • 3 in conversation
Announcements