Get Orbi Pro now


Orbi Pro Support

Login to discuss Orbi Pro

Reply
Highlighted
Initiate

Considering returning Orbi Pro SRK60

Hi everyone -

 

I'm hoping someone can help me.

 

I bought a 3 pack Orbi Pro a little over 2 weeks ago and am seriously considering returning it and wanted to ask for advice on last ditch things to try before I give up on this thing. 

 

I moved from an Apple AirPort Extreme and Time Capsule setup. I have several computers running macOS, Windows and Linux as well as several iOS devices. 

 

I have FiOS and have tried setting up the Orbi as a router and as an access point and I have the same issue either way. Every day at least one device falls off the WiFi network and when I try reconnecting it tells me that the password is wrong. Today, a Mac Mini also suddenly would not connect and when I tried re-entering the SSID and password, macOS would report “no network found.” 

 

All of these issues get resolved immediately with a reboot of the Orbi router, but I can’t continue to do this several times daily. 

 

I installed the latest firmware today and the issue continues. I have tried setting the 2.4GHz channel to 6 based on another thread. 

 

What else can i try or which firmware can I roll back to?

 

Thanks. 

Model: SRK60B03|Orbi Pro Tri-Band Business WiFi System
Message 1 of 7

Accepted Solutions
Highlighted
Aspirant

Re: Considering returning Orbi Pro SRK60

Thanks for your answer Josh. Sorry I was upset, but I've been really upset many times since I installed the Orbi system. Anyway, I checked back in this communtiy for answers and found another critical guys post about netgear and you guys trying to support us. Of course it's better for all of us if we can solve the problems instead of just hating.

 

I will contact you with the serial nr. I already have put in the number in my account and tonight I clicked on "activate" so I think you can see my number, but I will message you anyway.

 

I'm not really sure it's just the satellite causing my problems with the wifi disconnecting, but something between the router and the satellite is wrong. Or just the wifi in general from the router (and then satellite of course). We have connected apple-tv, a desktop computer, arlo pro and some other stuff by cables from the router and this stuff works (in general). So we get internet from the router but the wifi is disconnecting. I don't know how the router and the satellite is synchronized but when they disconnect I also loose the connection to the stuff connected with cables from the satellite.

The thing I would like to know is, where should I start and which steps should I follow? I have read the manual, and have tried to do like it says. I don't want to read the manual anymore, it did'nt work for my system. If someone can write down the steps I should try or send me a link with basic instructions I will give it a try again. Thanks for your time.

View solution in original post

Message 6 of 7

All Replies
Highlighted
NETGEAR Moderator

Re: Considering returning Orbi Pro SRK60

@natallica,

 

Welcome to the community! Smiley Happy 

 

Are the Orbi Pro satellites connected via Ethernet Backhaul or wirelessly synced to the Orbi Pro router?  

 

Just to double check, what specific firmware version is exactly installed on your Orbi Pro System?  The latest firmware version is v2.3.5.108 that was just released a few day ago and you can download it here

 

Have you tried to perform a factory reset on all of your Orbi Pro devices?  If not, I suggest you to perform a factory reset on all of your Orbi Pro devices then reconfigure it from scratch and observe if the same problem occurs. 

 

 

Regards,

 

DaneA
NETGEAR Community Team

Message 2 of 7
Highlighted
Initiate

Re: Considering returning Orbi Pro SRK60

Hi -

 

No Ethernet backhaul, but I am using the Ethernet ports on each unit to connect some computers to the network that way.

 

I am running v108 of the firmware.

 

I did open a ticket with Netgear and spoke to someone on the phone who told me to change my 2.4GHz channel to 1 and 5GHz channel to 44, but that hasn't resolved the "wrong password" issue and having devices disconnecting from the network throughout the day.

 

I have reset everything and it also didn't help.

Message 3 of 7
Highlighted
Aspirant

Re: Considering returning Orbi Pro SRK60

I bought this useless **bleep** for over a year ago, the Orbi Pro Business WiFi System, I only have one satellite though. Router SRR60 and SRS60 - firmware V2.3.5.108. I should have returned it back while I had the chance!!

 

But we had new internet fiber installed in the house and thought it was trouble with the new internet connection so we continued contact the Internet provider. Every f*cking day we lost wifi. Since our neighbours did'nt complain on the fiber we finally started to blame the Orbi Pro System. I hate spending time on setting up things again and again, but since my wife complained about the wifi and tried to fixed this in the weekend everything died. So I had to start from scratch, turn off all power, disconnect cables, reset the fiber modem, reset the router and satellite, update firmware, connect everything. When I finally had done all steps I could'nt find the wifi name in the list.. it had renamned the SSID to something else, so it took some time to realize our wifi was working under another name. Anyway, I could rename it and everything seemed to work. It worked the rest of the sunday, amazing!! So I connected the NAS, started to backup devices and so on. I was happy for about one day, til this evening and the satellite disconnected and started to mess up the wifi again. Now the satellite is powered off, and I'm using the wifi(!) from the router.

 

I'm so angry because all trouble we have had with the wifi, when this **bleep** was supposed to be one of the best wifi-systems for small business. When I checked the invoice it was like one week over the warranty, which was one year from the store. So YES, if you still have the opportunity to send your system back and get the money back - DO IT! I'm fed up with this. Nothing helps!

 

As a note I want to tell that I also have the Netgear Arlo Pro system (cameras). Something went wrong with the installation to, so I was close to return the cameras. (I had the older Arlo system, working all good, but I had to buy expensive batteries so I bought the new Arlo Pro). Anyway, I reinstalled everything and the Pro system started to work and have worked since then. But this Orbi Pro **bleep** seems to be totally useless crap which can't be fixed!

Message 4 of 7
Highlighted
NETGEAR Expert

Re: Considering returning Orbi Pro SRK60

In regards to the satellite disconnecting. How often until the satellite disconnects? It may be an issue with the satellite and I would recommend having a case opened with support on this issue so we can further troubleshoot the device disconnecting. Please send me a private message with the Orbi Pro router's serial and I can have a case opened with support to determine the cause of the issue.

Message 5 of 7
Highlighted
Aspirant

Re: Considering returning Orbi Pro SRK60

Thanks for your answer Josh. Sorry I was upset, but I've been really upset many times since I installed the Orbi system. Anyway, I checked back in this communtiy for answers and found another critical guys post about netgear and you guys trying to support us. Of course it's better for all of us if we can solve the problems instead of just hating.

 

I will contact you with the serial nr. I already have put in the number in my account and tonight I clicked on "activate" so I think you can see my number, but I will message you anyway.

 

I'm not really sure it's just the satellite causing my problems with the wifi disconnecting, but something between the router and the satellite is wrong. Or just the wifi in general from the router (and then satellite of course). We have connected apple-tv, a desktop computer, arlo pro and some other stuff by cables from the router and this stuff works (in general). So we get internet from the router but the wifi is disconnecting. I don't know how the router and the satellite is synchronized but when they disconnect I also loose the connection to the stuff connected with cables from the satellite.

The thing I would like to know is, where should I start and which steps should I follow? I have read the manual, and have tried to do like it says. I don't want to read the manual anymore, it did'nt work for my system. If someone can write down the steps I should try or send me a link with basic instructions I will give it a try again. Thanks for your time.

View solution in original post

Message 6 of 7
Highlighted
Apprentice

Re: Considering returning Orbi Pro SRK60

Are you having the issues with both Ethernet connected and WiFi devices? Asking because I had to temporarily move my NAS to an Ethernet port on one of my satellites and it's losing connectivity every few days. I dont have any issues when it's connected to any of my other switches, just when it's connected to the Orbi Pro satellite. 

Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 1612 views
  • 1 kudo
  • 5 in conversation
Announcements