Reply

SXK80 no internet on ethernet ports with VLAN set

Architekt
Tutor

SXK80 no internet on ethernet ports with VLAN set

I'm on firmware v3.2.6.100. I have my SXK80 router and several satellites connected to it via ethernet backhaul. On my office satellite, I set 2 of the physical ethernet ports to have a VLAN profile of ID 20, client isolation UNCHECKED, network isolation CHECKED. Anything I plug into these ports doesn't have internet access, only local network access. I've tried changing from trunk to access for the mode: no change. I've tried having both client and network isolation checked: no change. I can only get internet access on the ethernet ports if I use the Default vlan profile. Is there something I'm missing about how this is supposed to work with regards to the ethernet ports? I have my wifi SSIDs using different VLAN profiles with success.

Attached is a pic of an example set up. Circled in red is a port set to use VLAN that doesn't have internet access. If I plug it into anything with the Default VLAN profile, it'll have internet access.

 

Message 1 of 7

Accepted Solutions
Architekt
Tutor

Re: SXK80 no internet on ethernet ports with VLAN set

I found the issue regarding my ports and connectivity issues: it was an error on my end. I had forgotten to set up the appropriate VLAN setting on my pfsense firewall that's in front of the orbi (which is in AP mode). Once I set that up properly, the ports work as expected configured to the VLAN id I set it to. So this is not an Orbi error but rather user error.

View solution in original post

Message 7 of 7

All Replies
GMoGoody8
Luminary

Re: SXK80 no internet on ethernet ports with VLAN set

So from what I gathered from the manual is the following 

Trunk Mode - Port Used For Ethernet Backhaul or WAN port. 

Access Mode - Port Used a regular assigned VLAN 

"Assign Access mode to a VLAN that includes ports that support client and end devices.
For the satellite, if a port is connected to the base (router), set the mode to Trunk."

Looks like you have that Port setup in Trunk Mode. Have you tried access mode?

My Setup (Cable 1000Mbps/50Mbps overprovisioned)>S33>SXR80 V3.2.5.102(Router Mode)
Message 2 of 7
Architekt
Tutor

Re: SXK80 no internet on ethernet ports with VLAN set

Yes. I originally tried access mode as mentioned, no dice, then trunk second, also no dice. Neither mode had internet access. Perhaps this is a bug with the current firmware?

Message 3 of 7
GMoGoody8
Luminary

Re: SXK80 no internet on ethernet ports with VLAN set

Perhaps. I have not upgraded to that FW as of yet and my devices are not having any issues 

My Setup (Cable 1000Mbps/50Mbps overprovisioned)>S33>SXR80 V3.2.5.102(Router Mode)
Message 4 of 7
Architekt
Tutor

Re: SXK80 no internet on ethernet ports with VLAN set

There may be something goofy with this firmware version. Since I just got the device, it's the only version I'm familiar with so I don't have any knowledge about earlier ones. One other thing I notice is that if I change both access mode AND vlan profile at the same time for an ethernet port, after it finishes applying, it comes back up as trunk and default no matter what I set. I wanted to test access mode again. I found that I had to first set the 2 ports to access, hit apply, wait a very long time for the router to reboot and all satellites to come back up (like 10-15 minutes, and these are all ethernet wired to the router). Then when that finished, I had to change the vlan profile, hit apply, and wait another 10-15. It then finally took. Anyway, here is a screenshot of it with access set. Still no internet on those ports. Internet only works on those ports if the vlan profile is set to default (access mode doesn't matter in that case, trunk or access both equally provided internet). I would imagine this is a bug.

Message 5 of 7
GMoGoody8
Luminary

Re: SXK80 no internet on ethernet ports with VLAN set

It probably is FW related. I'm on the previos version becasue I didn't like one of the "Known Bugs" in the release notes 

"This firmware contains the following known issues:

 

  • After updating the router firmware, existing clients can be steered to the router because the wireless readiness in the router is faster than the wireless readiness in the satellite. Workaround: Connected clients might notice slower throughput or a weaker signal, which resolves when the user roams or reconnects.
  • WPA3-Enterprise might not work with iPhone 11 (supports 802.11ax) and above on iOS 14 and above. Workaround: Do not use WPA3-Enterprise."


I have attached my setup

My Setup (Cable 1000Mbps/50Mbps overprovisioned)>S33>SXR80 V3.2.5.102(Router Mode)
Message 6 of 7
Architekt
Tutor

Re: SXK80 no internet on ethernet ports with VLAN set

I found the issue regarding my ports and connectivity issues: it was an error on my end. I had forgotten to set up the appropriate VLAN setting on my pfsense firewall that's in front of the orbi (which is in AP mode). Once I set that up properly, the ports work as expected configured to the VLAN id I set it to. So this is not an Orbi error but rather user error.

View solution in original post

Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 350 views
  • 1 kudo
  • 2 in conversation
Announcements