Orbi WiFi 7 RBE973

Satelite sharing wifi without password


Satelite sharing wifi without password

I build up the network with SXR50 and SXK50.
Both device got the error message like [Failed to update GUI language, please wait].
And the satelite is sharing the wifi without password, i dont know how to shut it down.
It can login to the debug page, but failed to enable debug.
I did tried to manual upgrade, reset for several times.
Is there any way to force the satelite reinstall?
Message 1 of 9

Re: Satelite sharing wifi without password

Hi @hugo55 ,


Thanks for connecting to Netgear community forum. 

Yes, there is an option to reset Satellite using pin. There is a small hole next to power input.

Router or Satellite to its factory settings. Use the end of a paper clip or a similar object to press and hold the Reset button on the back of the router or satellite for at least seven seconds. The router or satellite resets and returns to the factory settings.

Blinking amber: The router or satellite is resetting to factory default settings.


Please refer screenshot.


If you still have a issue, please pm me or will connect over zoom call.





Message 2 of 9

Re: Satelite sharing wifi without password

I did tried to reset for several time
Message 3 of 9

Re: Satelite sharing wifi without password

what's the FW version? Are router sand satellite up-to-date?

Message 4 of 9

Re: Satelite sharing wifi without password

I'm sorry to hear that you're experiencing issues with your network setup using the SXR50 and SXK50 devices. Troubleshooting network equipment can be complex, but I'll try to provide some general suggestions:

1. Failed to update GUI language: This error message indicates a problem with updating the graphical user interface language on your devices. It's possible that there's a software or firmware issue. You can try the following steps:

- Ensure you have a stable internet connection during the update process.
- Check if there are any firmware updates available for your devices on the manufacturer's website. If so, download and apply the latest firmware to see if it resolves the language update issue.
- If the problem persists, contact the manufacturer's support for further assistance. They may have specific troubleshooting steps or be able to provide you with a solution.

2. Shared Wi-Fi without a password: If you want to disable the Wi-Fi sharing without a password, you'll need to access the router settings. Typically, you can do this by entering the router's IP address into a web browser and logging in to the administration interface. Once logged in, you can disable the option for Wi-Fi sharing without a password. The exact steps can vary depending on the router model, so consult the user manual or the manufacturer's support documentation for specific instructions.

3. Failed to enable debug and manual upgrade attempts: If you've tried enabling debug mode and performing manual upgrades without success, it's best to contact the manufacturer's support for guidance. They can provide specific instructions on how to enable debug mode or may have other troubleshooting steps to resolve the issue.

4. Forcing satellite reinstallation: Depending on the device and its firmware, there may be an option to initiate a factory reset or reinstall the firmware from scratch. Again, referring to the manufacturer's documentation or reaching out to their support team will provide you with the most accurate instructions for your specific devices.

Remember to provide as much detail as possible when contacting the manufacturer's support team. This will help them understand your specific situation and provide appropriate solutions.

Message 5 of 9

Re: Satelite sharing wifi without password

Hi, just check the firmware has been update automatic, the GUI language can be upgrade.


But the wifi network [ORBI96] still sharing without password.

I tried to connect with my phone and check the console shows that it is connecting to the network [4] belong to Orbi Pro SXK50 Satellite-1.

I have check all the wireless are using different password. Both wireless 1-4 are need password to connect.


Message 6 of 9

Re: Satelite sharing wifi without password

Firmware v4.3.1.106 has a related bugfix. Can you check router and satellite upgrade to the version? 

Message 7 of 9

Re: Satelite sharing wifi without password

Please note both router and satellite has been update to the latest firmware automatic.

I had disable the auto update function but did not work.

I am very disappointed about that it can't be use the Asuswrt-Merlin, so much bugs appears and I have no choice to decide to upgrade.

Message 8 of 9

Re: Satelite sharing wifi without password

Is the router managed by Insight?


Can you PM me debug data to analyze root root?


1. Login to Router and Satellite debug page https://<ip address of SXR80/SXS80>/debug.htm

2. Click on start capture and wait for few mins before you save the debug logs. Collect the debug logs from satellite as well.



Message 9 of 9
Top Contributors
Discussion stats
  • 8 replies
  • 1 kudo
  • 4 in conversation