Reply

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

rmadilao
Guide

iPhone has slow fronthaul connection to Satellites due to ATF throttling

Hi Folks,

  I'm having a front haul problem with my Orbi Pro satellite connection to my iPhone.  I'm suppose to have 250Mbps download and 12 Mbps upload.   Using other devices such as a Macbook physically wired into the ethernet port of a satellite (or even connected wirelessly but not moving it around), I can confirm the backhaul of the satelite is perfectly fine.  It's when I roam around with my Iphone going from router node to satellite node, as it transitions to the satellite, my download speed is throttled down from 250Mbps to 40Mbps and slower, eventually losing internet connectivity all together.  What's even crazier is, I can have another iPhone (say my wife's phone, connected to the same satellite I'm having a problem with), and her download speed is completely fine at 250Mbps.

    The only workaround I found is, if I login to the router or satellite node and flush the ATF table for ath2 on either the satellite node giving me the problem, or on the base router, my download speed instantly resumes.  Interesing huh?

  I have tried all the debugging steps: Latest firmware, factory reset, disabled Implicit Beamforming, disabled MU MIMO, disabled Fast Roaming, lowered TxPower, you name it, I'ved tried it.

  The only thing that can recover my iPhone downlink speed to the satellite node is to do the ATF table flush.  

  I have opened a support cast with a Level 2 support specialist for 2 weeks now, but even the Level 2 support specialist cannot get an answer.  I'm an engineer myself, so I know how it works.  Nobody in Netgear firmware development wants to answer the question or they know it's a problem internally and just don't have a solution.  Yeah, it sucks that way.

 

   Does anybody who works for Netgear here, know of a command to just disable the ATF completely on the satellite nodes?  Btw, for those that are curious, in your "wlanconfig", there is a flushatftable command.  If you are experiencing similar issues, try it.   Also, this problem is not specific to one satellite.   It's happened randomly on any of the satellites I have.  But never on the router node.  Nothing else works except that command, but I can't keep doing that daily.

  

 

 

 

Model: Orbi Pro Tri-band WiFi System (SRK60) AC3000
Message 1 of 27
DaneA
NETGEAR Moderator

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

Hi @rmadilao,

 

I inquired your concern to the NETGEAR Support Team and found out that your concern has been inquired to the engineering team.  You may want to send a follow-up on your online case you have opened and check if there is a feedback coming from the engineering team.

 

You mentioned that your wife's iPhone works just fine.  Kindly compare the settings of your iPhone to your wife's iPhone to check why your wife's iPhone works fine? 

 

It would help if you are going to get screenshots as well as logs or wireless packet capture from your iPhone and your wife's iPhone and attach it on your online case to help with the investigation. 

 

 

Regards,

 

DaneA
NETGEAR Community Team

Message 2 of 27
rmadilao
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

3 weeks now and no response. And I have done 2 follow ups already. Absolutely no response. Like I mentioned before, Netgear’s own level 2 support cannot even get a response. Good luck to a customer like me getting one. LOL.
As well, it does happen on my wifes iphone too. Its just random luck where her device was ok at that point in time.
I have further debugged this on my own since Netgear’s engineers or support have been useless. The problem is basically during the transition from node to node. During a successful handoff, I will get proper download speeds and do not get throttled. During some handoffs, it kills my download speed on the new node. I can even walk back to my previous node, recover, and go back to the target node that had problems and make it recover by going again.
Ive also tried adding cron jobs on each satellite to flush the ATF table regularly but that wont help because the problem is only triggered by a bad node to node transition.
Message 3 of 27
rmadilao
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

Actually, I take that back about the cron job.  I can add a cron job with an increased frequency of every minute to flush the ATF table which then recovers my iPhone from 30Mbps back to 250Mbps on the node where I had a bad handoff transition.  What this means is, in the worst case scenario, I would just have to wait 1 minute till the next flush if I had a bad handoff from node to node.  However, this is really a bandaid workaround and is not the proper way to fix the problem.  I'd rather not have to flush the ATF table every minute.     

Message 4 of 27
DaneA
NETGEAR Moderator

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

@rmadilao,

 

I just inquired to the NETGEAR Support about your online case.  I found out that the Level 2 support expert assigned to your online case has sent you an e-mail about 4 or 5 days ago and there is no feedback from you.  Kindly respond to it.  

 

 

Regards,

 

DaneA

NETGEAR Community Team

Message 5 of 27
rmadilao
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

I have always responded to the level 2 support mail to me when there is something to respond to.  The reason I did not respond to the last one was because there was nothing to respond to.  All she did was update me again tellng me she is still trying to get information from the engineers.   And sent me a link about 802.11n ATF.    Because you said what you said here, I responded to her saying Ok, to confirm her message.  

 

If you all want to see what the message exchanges have been between myself and the level 2 support personnel, I will gladly take screenshots and post them all here.  Is that what you want?

 

Message 6 of 27
DaneA
NETGEAR Moderator

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

@rmadilao,

 

It is not necessary to post your conversation with the Level 2 support expert here. 

 

I am not part of the NETGEAR Support Team, but I will try to inquire your concern to the higher tier of NETGEAR Support.  I will post here once I got a feedback.  

 

 

Regards,

 

DaneA

NETGEAR Community Team

Message 7 of 27
DaneA
NETGEAR Moderator

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

@rmadilao,

 

Just an update on this, the higher tier of NETGEAR Support recommended to have your online case be escalated to the engineering team for further investigation.  

 

 

Regards,


DaneA

NETGEAR Community Team

Message 8 of 27
Leenewman
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

I am having siimilar problem — sometimes I get 300mbs with iPhones and iPads (on both main router and sattelite), then a minute later only 30mbs.  What I discovered by looking at the connected devices table is that my devices are flipping back and forth constantly between 2.4G and 5G connections.  When on 5G, I get the appropriate speed — when on 2.4Gi get the slower speed.  I tried turning off SSID broadcasting for 2.4G but it doesn’t seem to actually turn off his band, it just hides it —so Iphones and IPads still flip between 2.4 and 5.

Model: Orbi Pro Tri-band WiFi System (SRK60) AC3000
Message 9 of 27
rmadilao
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

@Leenewman That's a different problem.  I made sure I was connected to 5Ghz only by separating the SSIDs.  You'll have to do it manually and telnet to each node to save the configuration. (ie: not in the GUI).  Mine was due to interference from multiple nodes during handshake transition from one node to the next, which caused the ATF to throlttle me down to lower speeds.  Anyhow, I solved my issues by reducing to a 2-node system and finding alternative solutions to the coverage I needed in place of the removed nodes.  With only 2 nodes, there is no more interference occurring and things work perfectly now.    I couldn't wait for Netgear as their support was going nowhere and my 30-day return period was coming to an end for the extra satellites I purchased.  Oh wells.

Message 10 of 27
rmadilao
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

Of course it supports it. 🙂
Message 11 of 27
rmadilao
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

You need to separate your SSID before you can do that.
Message 12 of 27
rmadilao
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

@Case850. Already have that app. Its not related to deadspots. The handoff from node1 to node 2 is susceptible to interference when a third node is nearby. Engages ATF throttling erroneously.
Message 13 of 27
Leenewman
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

>>>  I tried turning off SSID broadcasting for 2.4G but it doesn’t seem to actually turn off his band, it just hides it —so Iphones and IPads still flip between 2.4 and 5.


@Case850wrote:

>>>  I tried turning off SSID broadcasting for 2.4G but it doesn’t seem to actually turn off his band, it just hides it —so Iphones and IPads still flip between 2.4 and 5.

 

@Leenewman

Leave the SSID broadcasting both 2.4G & 5G. However on your iOS devices "Forget this Network" for the 2.4G SSID. Thus they will only ever connect to the 5G.


As I think someone above mentions, this requires separating the SSIDs -- not sure if that is possible - I remember reading another thread with people complaining that these were not separable, but perhaps now they are?   If so, if anyone knows how to do it via interface (not hacking), I would like to know how to do it!

Message 14 of 27
Leenewman
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling


@Case850wrote:

@Leenewman

As an example configure your SSIDs with different names. See page 86, 87 of the Orbi user manual

Leenewman-2.4G

Leenewman--5G



i must have a different product or admin tool.  I see only the option to change SSID for both 2.4 and 5G together (1st screenshot below) and then on another admin page (2nd screenshot below) the option to toggle SSID broadcasting for both bands,  but as I mentioned in a previous post this just hides the 2.4G, it doesn't turn it off and my iphones and ipads on the network still get bounced between 2.4 and 5G by the router and the satellite.

wireless setup.pngwireless setup 2.png 

 

 


 

Message 15 of 27
Leenewman
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling


@Case850wrote:

@Leenewman

I see what you mean, perhaps a workaround is to turn the 2.4G SSID broadcast off and also turn the 2.4G Transmit power down.


Sigh. this is supposed to be a "pro" system -- I am starting to wonder!  I've got the system installed according to the manual (an IT professional did it for me, and I've checked it)... the satellite is 40ft from router in line-of-site, and I can sit at one desk and get 300/300 on my iMac connected on 5G to main router with iphone sitting next to it connected to same router on 2.4G that gets 30/30 -- but then sometimes the phone connects at 5G and then it too gets 300/300.  Same story for an iMac and iPhone at another desk near the satellite.   No clue why (1) devices bounce between 2.4 and 5G , and (2) why 2.4G is only delivering 30/30 not 300/300!  

 

At level 2 support now...  they keep asking for more and more info (i've run sniffers, debug logs, send them network diagrams, environment descriptions)... and haven't given me a single thing to try.

Message 16 of 27
Leenewman
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling


@Case850wrote:

@Leenewman

 

Are you running Ethernet backhaul?

 


I think so. In the "attached devices" admin page for main router, it shows the satellite with "Backhaul Status" = "Good" (sometimes it is "Poor").  I looked around in the admin site and don't see options for turning backhaul on/off.   The satellite is connected to the main router wirelessly, although I did run cables so that I have the option to connect them via Cat6.  

Message 17 of 27
rmadilao
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

There has been numerous feature requests for separate 2.4 and 5.0 SSID.  The response I had was "no scheduled timeline" for it.  It's just so that they can advertise single SSID and dumb down the product a bit for the average user, although, being an Orbi "PRO" system, it really shouldn't be the case.  I can understand the argument for the "Home" version though.

 

As for your device connecting over 2.4 intead of 5.0, the only real way of eliminating that is to configure separate SSIDs for 2.4 and 5.0.  The firmware supports it as they are just standard WLAN interfaces in a BusyBox operating system underneath the GUI.  Just use the config set wla="<ssid>", config save, method on all your nodes and you'll be happy.   That's how I run my system and it's quite stable.  My 5.0Ghz devices allways connect on the 5.0Ghz band.

Message 18 of 27
Leenewman
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling


@rmadilaowrote:

As for your device connecting over 2.4 intead of 5.0, the only real way of eliminating that is to configure separate SSIDs for 2.4 and 5.0.  The firmware supports it as they are just standard WLAN interfaces in a BusyBox operating system underneath the GUI.  Just use the config set wla="<ssid>", config save, method on all your nodes and you'll be happy.   That's how I run my system and it's quite stable.  My 5.0Ghz devices allways connect on the 5.0Ghz band.


It worked!  I followed the instructions in this post: https://community.netgear.com/t5/Orbi/How-to-set-a-separate-SSID-for-the-5-GHz-network-on-your-Orbi/...

NOTE:  on mac sierra or high sierra, "telnet" no longer exists as a terminal command.  you can use the "nc" command.  I just downloaded Telnet Lite from the App Store, installed it and it worked perfectly.  In my case I telneted into main raouter at 10.0.0.1 and changed the SSID for the 2.4G network, and then rebooted.  All devices capable of 5G are now sticking to 5G (so far), and only devices not capable of 5G are using 2.4G.  I also telneted into my satellite and checked the two SSIDs and the change i made on the main router was automatically reflected in the satellite, so there was not need to manually split the two bands in the satellite.  

Message 19 of 27
rmadilao
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

@Leenewman   Great you got it working!   I think the reason I have to change mine manually on both the router and satellite is because I use specific channel for 2.4Ghz.  Mine used to be what you described where you just change it on the router and the satellite automatically reflects it.  But it won't do that when you're on specific 2.4Ghz channel.  And also keep in mind, if you ever did change from Auto to a specific channel, you'll have to redo the config command.

 

Telnet is just part of inetutils which you can obtain from Brew or Macports or GNU.  I like to tinker around so there are other utilities beyond Telnet in those packages.

 

 

 

 

Message 20 of 27
Leenewman
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

After splitting, roaming seems to be better and all 5g capable mobile devices obviously stay on 5G now -- rather than bouncing between 5G and 2.4G.  

 

That said, still getting low speeds on 2.4G. I've got a 300mbps symmetric line coming in, and when on 5G and reasonably near the router or satellite, SpeedTest shows I am getting the full 300mbps.  On 2.4G, the best I get is 30mbps - even though in Router Status page of the admin site, it tells me "up to 400mbps" for 2.4G.  

Anyone know why 2.4G might be limiting bandwidth?  I thought it might be because I have guest network turned on, so I turned it off -- no change.  

Message 21 of 27
wase4711
Luminary

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

you'll never see real world internet speeds on 2.4g of 400mb; thats theoretical, not real world

 

getting 30-60 mb on 2.4g is all you will ever get on any router; remember, you only need 25 mb speed to stream 4k video, so you arent missing anything or losing anything when you only get 30 mb on 2.4g, if thats what you are streaming video on, but I would use the 5G network whenever possible

Message 22 of 27
rmadilao
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

Yup.  400mbps is only theoretial on 2.4Ghz.   Actual speeds are much much lower.  30-60 sounds about right.   Now that you have separated your 2.4 and 5.0, you can maintain your high bandwidth devices on the 5Ghz and not worry about the 2.4Ghz limitations.

 

Also, you will notice not just roaming, but also first connection to your 5Ghz network will be much faster since the router doesn't have to do bandsteering anymore.

Message 23 of 27
rmadilao
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling

You can optionally be an a** and take the 40MHz by unticking 20/40MHz co-existence. :)) 

Don't know your environment.   If you're home or office is far from other homes/buildings, you can take the 40MHz bandwidth.   The setting is just to play nice with your neighbors if you are in a dense area.  The best is to run a network analyzer app.  You can see what your neighbors are using and choose a channel nobody else is on.

Message 24 of 27
Leenewman
Guide

Re: iPhone has slow fronthaul connection to Satellites due to ATF throttling


@Case850wrote:

@Leenewman

Well done on separating the 2.4G & 5G SSIDs.

 

Just as a bit of a tidy up on the 2.4G side from Message 18;

The 20/40 MHz Coexistence should be enabled (ticked). This is important to avoid interference with neighbours.

@THE 2.4G channel is set to Auto and that should mean the router selects non overlapping bands of either channel 1, 6, 11 @ 20 Hz. However the Netgear routers are not always doing that. Thus you need to check that and if need be manually select channel 1,6,11.


Thanks for these suggestions.  I am going to use nearly exclusively the 5G - i think there is only a network printer on 2.4G .  I've left the 2.4G on "Auto" channel setting, as i am in an apartment building with many routers using 1,6,11 and the Router Status page shows it at "Auto ( 9(P) + 13(S) )".   I've got the 5G set to 48 (there is no Auto option). 

Message 25 of 27
Top Contributors
Discussion stats
  • 26 replies
  • 9494 views
  • 3 kudos
  • 4 in conversation
Announcements