Reply
Aspirant

Cannot associate my Spotify Premium Account with Alexa on my Orbi Voice satelite

Unable to associate my Spotify Premium account with Alexa.

Located in Switzerland. (Amazon and Spotify accounts both located in Switzerland too)
I succeeded to load Alexa on my Orbi Voice. Alexa is working.
I was not abble to add the Alexa App on my iPhone since it is not available on the Swiss Applestore !
So I installed the the EchoSetup App instead to configure Alexa.
When I try to associate Spotify with Alexa (as the the new default music app), it is impossible. "Spotify" appears in grey and cannot be selected.
I read in some places this was due to the location in Switzerland... I tried to locate my Amazon account in France, but the issue remains the same.

Is there a trick to do this ? Thanks in advance for an explanation. 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router, RBS40V|Orbi Voice Add-on WiFi Satellite and Smart Speaker
Message 1 of 2

Accepted Solutions
Highlighted
Aspirant

Re: Cannot associate my Spotify Premium Account with Alexa on my Orbi Voice satelite

Ok. I finally found the solution.
It is necessary to change the localisation of the "Content and Devices" section of your amazon account if it is located in Switzerland. Go to Preferences and then if the Country/Region is set to Switzerland, change it to France or Germany. You'll have to give a valid adress and phone number in the selected country. Warning: Do NOT change your delivery address. It can stay in Switzerland. (And i's of course better in order to receivo your arders !). Once changed, use the browser version of Alexa (at alexa.amazon.fr) to associate Alexa to your Spotify Premium account. (You won't be abble to download the iPhone Alexa app from the swiss Applestore since it is not present there... ). Anyway it is also possible to download it from the us Applestor.  (Change the country of your "iTunes Apple store" settings on your iPhone and click on your Apple identifiant and choose "Display the Apple Identifiant" then change the Country to United States.)  

View solution in original post

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 2 of 2

All Replies
Highlighted
Aspirant

Re: Cannot associate my Spotify Premium Account with Alexa on my Orbi Voice satelite

Ok. I finally found the solution.
It is necessary to change the localisation of the "Content and Devices" section of your amazon account if it is located in Switzerland. Go to Preferences and then if the Country/Region is set to Switzerland, change it to France or Germany. You'll have to give a valid adress and phone number in the selected country. Warning: Do NOT change your delivery address. It can stay in Switzerland. (And i's of course better in order to receivo your arders !). Once changed, use the browser version of Alexa (at alexa.amazon.fr) to associate Alexa to your Spotify Premium account. (You won't be abble to download the iPhone Alexa app from the swiss Applestore since it is not present there... ). Anyway it is also possible to download it from the us Applestor.  (Change the country of your "iTunes Apple store" settings on your iPhone and click on your Apple identifiant and choose "Display the Apple Identifiant" then change the Country to United States.)  

View solution in original post

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 1207 views
  • 0 kudos
  • 1 in conversation
Announcements