Orbi WiFi 7 RBE973
Reply

Re: Double NAT on wired. Open NAT on wifi

wfletchb99
Star

Double NAT on wired. Open NAT on wifi

I know the Double/Strict NAT general topic has been beaten to death, but I could not find a situation matching mine.

 

Recently replaced my R7000 with this RBK752.  No issues except for the one mentioned in the subject line.

 

My Xbox is located in the room with the RBS750.  The RBR750 is downstairs.  When I connect my Xbox to wifi (connecting to the satellite), NAT is open.   When I connect via network cable to the RBR750 (through house ethernet wiring), it goes to Double NAT/Strict. 

 

The basic setup in the house is the same as it was with the R7000.  I used the same ethernet connection to the R7000 as I'm using with the RBR750.  I have WAN set to open NAT and have verified that I am forwarding the correct ports.  My RG is a Pace 5268AC from AT&T meaning that the router function can't be completely bypassed, but I have used DMZ Plus to simulate the bypass.  Again, this setup with the Pace RG been the case and working fine for over 2 years.

 

Note that I started with port forwarding on the ethernet MAC address/fixed IP and then when I switched to wifi I changed the port forwarding to that connection when I saw the Double NAT on the ethernet MAC.  I have things set to port triggering right now so that it should work for either connection.  The behavior using port triggering is the same with wifi working with Open NAT and ethernet Double/Strict.

 

One final note is that if I start the Xbox with wifi,  it will be Open NAT,  When I plug in ethernet, it goes to Double/Strict.  If I then unplug the ethernet cable and wifi with the RBS750 satellite reconnects, it remains Double/Strict.  I have to reboot the Xbox for it to return to Open.

 

Firmware on both devices updated to V3.2.17.12_1.4.14.  Any suggestions would be greatly appreciated.   

Message 1 of 7

Accepted Solutions
FURRYe38
Guru

Re: Double NAT on wired. Open NAT on wifi

Xbox has always been problematic when it comes to NAT status. Disable all Instant ON features. This was one problem Xbox 1 had a few years ago. Not sure if it was ever addressed by MS.

 

2nd, do not do 30/30/30 resets on Orbi. 15 second button press is only needed on Orbi systems. 

 

You shouldn't need any PF or Port Triggering configurations. You only need uPnP enabled and thats its. IF you have two game consoles, you can set NAT Filter to Open if you use both consoles online at the same time. I'd try setting a IP address reservation for your consoles ON the RBR router.

 

After making router changes and the RBR reboots. Press and hold the front power button on the xbox console until it shuts off. Then turn it back on. 

View solution in original post

Message 5 of 7

All Replies
FURRYe38
Guru

Re: Double NAT on wired. Open NAT on wifi

What is the Mfr and model# of the Internet Service Providers modem/ONT the NG router is connected too?

Is the modem in bridge mode or router mode? 

 

Has a factory reset and setup from scratch been performed since last FW update? 

Message 2 of 7
FURRYe38
Guru

Re: Double NAT on wired. Open NAT on wifi

Oops, I see the model # of the modem...

Message 3 of 7
wfletchb99
Star

Re: Double NAT on wired. Open NAT on wifi

The problem started while I had the previous firmware (3.2.16.22)...which was the firmware at purchase.  I did not do a reset with that firmware version, but  I did a regular reset with the new firmware before I posted my original question.  After reading your response, I did a 30/30/30 reset, set up the router, and tried port forwarding and then port triggering again.  So far, the problem seems to be the same.  Immediately after the 30/30/30, it was actually worse as even wifi was showing as a Double NAT with port forwarding.  However, after a full shutdown, remove power, and restart of the Xbox, at least the wifi is back to being open NAT.  

 

I also got out my old Xbox One and tried it to see if the problem was related to my Xbox Series X.  I put the Xbox One beside the RBR750 (rather than the satellite) and it is also showing double NAT even in wifi.  However, I have not done any iterative testing of the Xbox One, so I don't want to draw any conclusions from this brief experiment. I did not attempt to connect the Xbox One to the router with an ethernet cable.

 

At the very least, it seems like my NAT status, as evaluated by the Xbox, is relatively "unstable."  It seems like there is something in how the Xbox reads the status.  After all of this resetting and then making changes, I would be tempted to just live with wifi if it was simply stable, but I fear that one day I'm going to get stuck with double NAT even in wifi and not be able to get it to open status.

 

Any further suggestions would be welcome.  Thanks.

Message 4 of 7
FURRYe38
Guru

Re: Double NAT on wired. Open NAT on wifi

Xbox has always been problematic when it comes to NAT status. Disable all Instant ON features. This was one problem Xbox 1 had a few years ago. Not sure if it was ever addressed by MS.

 

2nd, do not do 30/30/30 resets on Orbi. 15 second button press is only needed on Orbi systems. 

 

You shouldn't need any PF or Port Triggering configurations. You only need uPnP enabled and thats its. IF you have two game consoles, you can set NAT Filter to Open if you use both consoles online at the same time. I'd try setting a IP address reservation for your consoles ON the RBR router.

 

After making router changes and the RBR reboots. Press and hold the front power button on the xbox console until it shuts off. Then turn it back on. 

Message 5 of 7
wfletchb99
Star

Re: Double NAT on wired. Open NAT on wifi

@FURRYe38 

Thanks for your suggestions.  On the initial setup of the Orbi out of the box, I did as you suggest with just UPNP and no other setting changes. The lengths I had gone to with WAN Open NAT Filtering, Port Forwarding, and finally Port Triggering were out of frustration when the NAT was continuing to bite me (pun intended),  Your last message though, prompted me to start over. From that, I have backed into the apparent solution and am embarrassed it was so simple.

 

I was so busy "fixing" the new parts of the network setup and so focused on the wifi vs ethernet symptom that I didn't look at the beginning of the chain.  I finally went into the Pace RG interface and saw that though DMZ+ was still set, the device that it was set up for was my old R7000.  Everything bar the NAT had been working perfectly, so I never considered needing to update the Modem/Router settings for the RBR750.  Two clicks later and a reboot of the Pace device and all seems good.  My Xbox Series X shows open NAT on both wired and wifi and my old Xbox One shows open on it's wifi now, too.  I'm going to leave things as they are with the WAN Open NAT Filtering and Port Triggering set for now.   If things continue to work well, then I'll start pulling out those provisions until I get back to the setup you have suggested.  I won't be using the Xbox One, so the multiple console aspect is no concern. 

 

I definitely fit into the category of knowing enough to be dangerous.  Hopefully, my stupidity will help someone else down the road.

 

Your suggestions were all spot on.  Thanks for the ideas and your quick response.  

Message 6 of 7
FURRYe38
Guru

Re: Double NAT on wired. Open NAT on wifi

There ya go. 

Glad you figured it out. Please mark your thread as solved so others will know.


Enjoy. Smiley Wink

Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 3555 views
  • 2 kudos
  • 2 in conversation
Announcements

Orbi WiFi 7