Orbi WiFi 7 RBE973
Reply

I updated the firmware for one of my satellites from V6.3.7.10 on RBS960 Orbi to V7.2.6.31 wrong one

GadgerUK
Aspirant

I updated the firmware for one of my satellites from V6.3.7.10 on RBS960 Orbi to V7.2.6.31 wrong one

Hello all, the first post

 

I updated the firmware for one of my satellites form V6.3.7.10 on RBS960 Orbi to the V7.2.6.31 only then to realise that this was for America, not Europe. Europe should use V7.2.6.29

 

How do I get either back to either V6.3.7.10 or to Europe V7.2.6.29

 

As I might be selling them, to upgrade to the RBS970 system. 

 

And want them corrected before selling them.

 

Thank you for your help Andrew

 

Bad grammar and spelling, sorry, dyslexic.

 

 

Message 1 of 4
FURRYe38
Guru

Re: I updated the firmware for one of my satellites from V6.3.7.10 on RBS960 Orbi to V7.2.6.31 wrong

Log into the RBS web pages and after you've downloaded the v6 FW files to a wired PC, send the RBS FW file to each RBS. Then send the v6 RBR FW lastly. 

I believe for the EU region, last supported version of FW for all EU regions is v6. No idea when NG will be supporting v7 for the EU region. 

Message 2 of 4
GadgerUK
Aspirant

Re: I updated the firmware for one of my satellites from V6.3.7.10 on RBS960 Orbi to V7.2.6.31 wrong

Thank you for the reply. Will that downgrade the V7.2.6.31, the wrong one for America firmware I currently have on the one satellite, back to the V6.3.7.10 Euro current firmware?

Message 3 of 4
FURRYe38
Guru

Re: I updated the firmware for one of my satellites from V6.3.7.10 on RBS960 Orbi to V7.2.6.31 wrong

Yes, manually downloading the v6 RBS FW file and applying it to the RBS web page will downgrade the RBS back to v6. 

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 399 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi 770 Series