Orbi WiFi 7 RBE973
Reply

Netgear Orbi RBK853 Interface Broken

AACTech1
Follower

Netgear Orbi RBK853 Interface Broken

I recently bought an RBK852 (RBK850 router & RBS850 satellite) for a small business that I support. Upon setup, it worked fine. Now, when I login to check the settings, the user interface is gone. It has been replaced with a new interface that is illustrated in the attached screen shot. It will not let me make any changes. 

  • Hardware Version: RBS850
  • Firmware Version: V3.2.16.6_1.4.4

I had remote management enabled, but it won't let me login remotely. Oddly, the network is functional - I'm able to login remotely to the computers using TeamViewer. This allows me to login to the router from within the network. I can't make any changes to the router - no Wi-Fi control, no LAN, no WAN, nothing.

 

The Orbi is connected to an Arris TG1672 modem. We have Spectrum cable internet. The user interface has never worked with Google Chrome, so I'm forced to user Internet Explorer, which is how I was able to capture the attached screen shot. As you can see, this screen shot shows a completely different user interface for the Orbi than normal.

 

If there is a new version of the firmware for this router, I'd like to know. It won't let me automatically check for a firmware update, but it will let me upload a new firmware file, if I had one. This is happening to other users on the forum, I see. 
Orbi Issue.jpg

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 1 of 2
FURRYe38
Guru

Re: Netgear Orbi RBK853 Interface Broken

Thats the RBS log in and status page, you can't make any changes to the RBS, accept for updating FW. This is how the RBS web page works. 

 

Use the RBRs login page, found at 192.168.1.1 or orbilogin.net. 

 

 

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 416 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 7