Orbi WiFi 7 RBE973
Reply

Re: Orbi RBR350 in AP mode - not always getting DHCP IP when roaming

danielschenk
Guide

Orbi RBR350 in AP mode - not always getting DHCP IP when roaming

Hi folks,

 

I have a frequent issue with my Orbi setup in AP mode which is quite annoying. When roaming around with my device throughout the house, I often find that I get no connectivity, while the WiFi signal is still great. When I check the DHCP status of my device in this situation, I often find it resorted to a 169.254.x.x (link-local, autoIP) address. The only possible reason for this IMO is that the DHCP request, which the device did after roaming to the other AP, timed out. I've actually verified this in the macOS logs on my MacBook (there was a request, but no timely reply, making it go into autoIP).

 

This usually recovers when I completely disable and re-enable the WiFi on my device, but of course, this is only a workaround and something which should not be required to do.

 

Below is a schematic of my setup. It seems to me that I encounter the issue the most when I'm getting closer to my 2nd floor station, which might indicate it's an issue with the wireless backhaul, because the other stations are wired.

 

The cause is not 100% certain to blame Orbi of course (especially with the smart switches in between), but my reasons why I think the chances are high that it is Orbi:

  • I didn't have this issue yet before I got Orbi (I was using the builtin FR!TZBox WiFi, together with a wired FR!TZ repeater in the attic, connected via the same switch path)
  • I seem to have the issue when nearing the only Orbi station which has a wireless backhaul
    • To make this even more evident: before I reduced the Orbi's TX power to 50% I often had the issue in the attic as well. Afterwards much less often, which indicates that my device probably likes to switch to the attic station sooner (because the 2nd floor becomes too weak) and gets back on wired backhaul which doesn't have this issue.
  • The issue occurs after roaming, but can be workaround by toggling the WiFi on the client (why would a switch block a 1st DHCP request, but shortly thereafter allow the 2nd one...?) so this could indicate that the Orbi station handles roaming clients differently than "freshly" connecting clients (turning their wifi on)
  • Roaming with the previous FR!TZ wifi system worked fine with the same clients and network setup
  • I've disabled IGMP / MLD snooping, DHCP proofing and any other feature which I suspect of interfering with multicast on the smart switches
  • I've installed the latest firmware on everything
    • One of the changelogs of the GS108Tv3 firmware indicated fixing an issue related to passing DHCP when there's an extra device in between, but apparently this fix didn't help

Any ideas?

 

Orbi setupOrbi setup

Message 1 of 11
ekhalil
Master

Re: Orbi RBR350 in AP mode - not always getting DHCP IP when roaming

How good is the wireless backhaul to the “bad satellite”? Can you please check this in the web GUI, under “Attached Devices “, do you see that satellite connected to the router over 2.4 or 5 GHz?
Does thing become better if the satellite is brought closer to the router?

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBR850 + RBS850 + 2x RBS750 + 3xRBS350, Wired/Wireless BH / Orbi RBR50 + 6x RBS50 + RBS40V + RBS50Y, Wired/Wireless BH | Switches NG GS208Time Zone CET (Sweden)

Message 2 of 11
danielschenk
Guide

Re: Orbi RBR350 in AP mode - not always getting DHCP IP when roaming

The status of the backhaul is 5G and good. I've never seen it show something different (apart from seeing "synchronising configuration" instead of "good" briefly once in a while, which I assume is normal?)

Below is a screenshot of the status (in Dutch, sorry for that). "verdieping1" is the 2nd floor satellite (yeah, in Dutch we call that 1st floor :D)

 

Would it still make sense to try to bring it closer to the router when it says good here? This would mean I would move it away from the back of my house which might worsen my backyard coverage. As the summer is now ending anyway here, this might not be a problem for a temporary test 😉 another thing I was thinking of, is hooking it up to one of these Netgear Powerline kits I still have laying around (but they unfortunately don't work that well in my current house).

 

danielschenk_1-1663186481937.png

 

 

Message 3 of 11
ekhalil
Master

Re: Orbi RBR350 in AP mode - not always getting DHCP IP when roaming

One of the reasons for “synchronising configuration” is that the satellite lost connection with the router.
So, I’m still suspecting that the issue is caused by a bad radio connection with the satellite.
Please try to test to get the nodes closer or remove some obstacles in between if applicable.
If you have the possibility to use Ethernet over powerline then I would suggest to test that as well, this will for sure be more stable than the wireless backhaul.

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBR850 + RBS850 + 2x RBS750 + 3xRBS350, Wired/Wireless BH / Orbi RBR50 + 6x RBS50 + RBS40V + RBS50Y, Wired/Wireless BH | Switches NG GS208Time Zone CET (Sweden)

Message 4 of 11
danielschenk
Guide

Re: Orbi RBR350 in AP mode - not always getting DHCP IP when roaming

Thanks for the tip. I'll first do a test by powering off the 2nd floor satellite, and to make up for the lost coverage, put the system back to 100% TX power, because I think I can survive with that. I think this is a better test for isolating the issue than using a bad powerline adapter or finding a better backhaul spot.

 

After I've isolated the issue to the 2nd floor satellite this way I can start trying the other things. I will keep you posted.

Message 5 of 11
CrimpOn
Guru

Re: Orbi RBR350 in AP mode - not always getting DHCP IP when roaming

I am confused about two aspects of this problem:

 

  • Why does the device make a DHCP request?  The major benefit of mesh WiFi is the ability roam seamlessly from one Access Point to another.  If the device is switching from one Orbi Access Point to a different Orbi Access Point, this is supposed to be handled IEEE 802.11k/v/r
    https://www.tp-link.com/us/support/faq/2097/#:~:text=Fast%20Roaming%20is%20a%20feature,of%20clients%... 
      I would think that the IP address reservation would remain in effect until it expires.  This leads to speculation that what has happened is the device has totally lost connection to WiFi and is thus "starting over".
  • Connecting Access Points through the WAN port.  There have been numerous examples demonstrating that Orbi satellites will not function when the router is in "router mode" and the satellite is connected to the WAN port rather than through a LAN port.  The router "knows" where satellites are expected to be and will not talk to one through the WAN port. Yes, "access point mode is different", but I am not sophisticated enough to know exactly how "different". Were I in this position, I would get out my 100ft Ethernet patch cable and (temporarily) connect that attic satellite directly to a router LAN port.

    If this solution works, it would be a simple matter of creating a VLAN connection between the satellite and the router LAN port using the GS108 VLAN and the router LAN port.

 

I love my Orbi.
Message 6 of 11
Garwoofoo
Apprentice

Re: Orbi RBR350 in AP mode - not always getting DHCP IP when roaming

This sounds a lot like the problem that's been reported in a few threads here where iPhones especially are losing connection when roaming between satellites.

 

I don't think the precise reason has been identified yet and it looks like an Orbi bug for sure but it does seem to occur more in setups that have a mixture of wired and wireless satellites. Since I moved both of my satellites to wireless I haven't seen the issue.

Message 7 of 11
ekhalil
Master

Re: Orbi RBR350 in AP mode - not always getting DHCP IP when roaming


@Garwoofoo wrote:

This sounds a lot like the problem that's been reported in a few threads here where iPhones especially are losing connection when roaming between satellites.

 

I don't think the precise reason has been identified yet and it looks like an Orbi bug for sure but it does seem to occur more in setups that have a mixture of wired and wireless satellites. Since I moved both of my satellites to wireless I haven't seen the issue.


It looks like an old issue from 2019 is back now again. I see few people reporting issues with wired backhaul. That issue was caused by loops when a satellite is paired with both wired and wireless backhaul. There was a workaround for that issue at that time:

https://community.netgear.com/t5/Orbi/Wired-backhaul-configured-but-still-shows-WLAN-Backhaul/m-p/17...

 

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBR850 + RBS850 + 2x RBS750 + 3xRBS350, Wired/Wireless BH / Orbi RBR50 + 6x RBS50 + RBS40V + RBS50Y, Wired/Wireless BH | Switches NG GS208Time Zone CET (Sweden)

Message 8 of 11
danielschenk
Guide

Re: Orbi RBR350 in AP mode - not always getting DHCP IP when roaming


@Garwoofoo wrote:

This sounds a lot like the problem that's been reported in a few threads here where iPhones especially are losing connection when roaming between satellites.

 

I don't think the precise reason has been identified yet and it looks like an Orbi bug for sure but it does seem to occur more in setups that have a mixture of wired and wireless satellites. Since I moved both of my satellites to wireless I haven't seen the issue.


I see it happening the most on my iPhone indeed, however, my MacBook suffers from it too, from time to time. Additionally, my girlfriend's Samsung S22 Ultra also has some issues when at my house. It regularly disconnects, and when I go to the WiFi menu, it even briefly flashes "incorrect password" before reconnecting again, which is very weird. Maybe it just experiences the same missing IP address combined with some UI/translation bug.

 

When I wrote my opening post a few days ago I noticed that I wasn't actually on the latest Orbi FW. I updated first and let it run a few more days before changing anything else. The issue reproduced, so I can be sure FW changed anything with regards to the issue. I'm now testing with the 2nd floor satellite removed as described in my previous post.

Message 9 of 11
ekhalil
Master

Re: Orbi RBR350 in AP mode - not always getting DHCP IP when roaming

Can you please try this procedure in the wired satellite:
1. Switch off the Satellite
2. Go to Attached Devices in the web GUI and click on the "Disconnect" button beside the Satellite in questions
3. Turn on the Satellite and use a paper clip to factory reset the Satellite
4. When the Satellite is up after factory reset, press the Sync button on the Satellite (while the Ethernet cable to the Router is connected) and then on the Router
5. When the Satellite is added it should behave correctly.

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBR850 + RBS850 + 2x RBS750 + 3xRBS350, Wired/Wireless BH / Orbi RBR50 + 6x RBS50 + RBS40V + RBS50Y, Wired/Wireless BH | Switches NG GS208Time Zone CET (Sweden)

Message 10 of 11
danielschenk
Guide

Re: Orbi RBR350 in AP mode - not always getting DHCP IP when roaming

I've encountered the issue several times now without the wireless satellite. This means that either the wireless satellite wasn't the cause, or it wasn't the only one.

 


@ekhalil wrote:
Can you please try this procedure in the wired satellite:
1. Switch off the Satellite
2. Go to Attached Devices in the web GUI and click on the "Disconnect" button beside the Satellite in questions
3. Turn on the Satellite and use a paper clip to factory reset the Satellite
4. When the Satellite is up after factory reset, press the Sync button on the Satellite (while the Ethernet cable to the Router is connected) and then on the Router
5. When the Satellite is added it should behave correctly.

I'm currently away from home for a little while but will try this as soon as I get back.

Message 11 of 11
Top Contributors
Discussion stats
  • 10 replies
  • 1284 views
  • 4 kudos
  • 4 in conversation
Announcements

Orbi WiFi 7