Orbi WiFi 7 RBE973
Reply

RBR850 has serious issues with streaming video apps

Dedalus
Follower

RBR850 has serious issues with streaming video apps

Old orbi system was working great, but I upgraded to the rbr850 for better speeds. 

 

Was unstable until I realized the satellite upgraded to the latest FW but the router couldn't until I pushed a manual upgrade. 

 

My issue is that the system easily maxes out the throughput and the connection is always stable, but some streaming applications either buffer endlessly or never load at all.

-Disney plus works fine through a browser, but if I load up the app on a phone or one of my rokus I can browse the titles fine, but the videos never actually load (same thing with vudu). Itunes works fine.

-SlingTV video actually loads up, but it buffers constantly to the point that it's unwatchable.

Stuff like youtube or hulu works great.

 

IDK what the issue could be. I set it up like my old system (DMZ+ on an at&t fiber gateway) so it should work fine in theory. I've factory reset the system like 5 times already and I keep fiddling with the settings but nothing fixes it. I'm starting to think it might be an issue with the firmware since I've literally run out of things to try.

 

What confuses me even more is that the Disney+ app works fine if I cast the video from my phone to another display

Message 1 of 3
CrimpOn
Guru

Re: RBR850 has serious issues with streaming video apps

A couple of the people who watch this forum have also upgraded to the AX product, but the majority of us have only the WiFi 5 product.  You may find that more people with experience relevant to your question will notice a post in the Orbi AX forum: https://community.netgear.com/t5/Orbi-AX/bd-p/en-home-orbi-ax 

Message 2 of 3
FURRYe38
Guru

Re: RBR850 has serious issues with streaming video apps

What Firmware is currently loaded?

 

What happens if you disable DMZ on the modem and configure the RBR for AP mode? 


@Dedalus wrote:

Old orbi system was working great, but I upgraded to the rbr850 for better speeds. 

 

Was unstable until I realized the satellite upgraded to the latest FW but the router couldn't until I pushed a manual upgrade. 

 

My issue is that the system easily maxes out the throughput and the connection is always stable, but some streaming applications either buffer endlessly or never load at all.

-Disney plus works fine through a browser, but if I load up the app on a phone or one of my rokus I can browse the titles fine, but the videos never actually load (same thing with vudu). Itunes works fine.

-SlingTV video actually loads up, but it buffers constantly to the point that it's unwatchable.

Stuff like youtube or hulu works great.

 

IDK what the issue could be. I set it up like my old system (DMZ+ on an at&t fiber gateway) so it should work fine in theory. I've factory reset the system like 5 times already and I keep fiddling with the settings but nothing fixes it. I'm starting to think it might be an issue with the firmware since I've literally run out of things to try.

 

What confuses me even more is that the Disney+ app works fine if I cast the video from my phone to another display


 

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 1219 views
  • 1 kudo
  • 3 in conversation
Announcements

Orbi 770 Series